Welcome to the Cumulus Support forum.

Latest Cumulus MX release 3.7.0 (build 3089) - 28 July 2020 (please see important announcement regarding releases since 3.5.0)
Legacy Cumulus 1 release v1.9.4 (build 1099) - 28 November 2014 (a patch is available for 1.9.4 build 1099 that extends the date range of the NOAA report and Snow Index drop-down menus to 2030)

Use this link to Download the Software (Cumulus MX / Cumulus 1 and other related items). Software

no display of trends graphics

Discussion and questions about Cumulus weather station software version 1. This section is the main place to get help with Cumulus 1 software developed by Steve Loft that ceased development in November 2014.
Post Reply
Thunderstorm
Posts: 34
Joined: Tue 26 Mar 2019 8:49 am
Weather Station: Davis Vantage Pro
Operating System: Win10

no display of trends graphics

Post by Thunderstorm »

Hi,

I do not have a display of the trends graphics.

https://odenwald-wetter.de/cumulus/trends.htm

In the settings for / sites / options I have selected web graphs. Who can help me?
Many greetings
thunderstorm

User avatar
mcrossley
Posts: 6745
Joined: Thu 07 Jan 2010 9:44 pm
Weather Station: Davis VP2
Operating System: Buster Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: no display of trends graphics

Post by mcrossley »

I'm a bit rusty on the standard web site - but it looks like you have the Cumulus MX web site not the Cumulus 1 site?

Thunderstorm
Posts: 34
Joined: Tue 26 Mar 2019 8:49 am
Weather Station: Davis Vantage Pro
Operating System: Win10

Re: no display of trends graphics

Post by Thunderstorm »

No, I have cumulus 1.9.4 built 1099 installed. The files ftp.log and debug.log do not show any errors.

User avatar
beteljuice
Posts: 2971
Joined: Tue 09 Dec 2008 1:37 pm
Weather Station: None !
Operating System: W10 - Threadripper 16core, etc
Location: Dudley, West Midlands, UK

Re: no display of trends graphics

Post by beteljuice »

The page is giving a 404 for graphconfig.json ?
Image
......................Imagine, what you will KNOW tomorrow !

Thunderstorm
Posts: 34
Joined: Tue 26 Mar 2019 8:49 am
Weather Station: Davis Vantage Pro
Operating System: Win10

Re: no display of trends graphics

Post by Thunderstorm »

Thanks for the answer. And what does that tell me when this error is displayed?
https://odenwald-wetter.de/graphconfig.json :?

Thunderstorm
Posts: 34
Joined: Tue 26 Mar 2019 8:49 am
Weather Station: Davis Vantage Pro
Operating System: Win10

Re: no display of trends graphics

Post by Thunderstorm »

Sorry, the link has to be: https://odenwald-wetter.de/cumulus/graphconfig.json
I can not find the file graphconfig.json anywhere!

User avatar
beteljuice
Posts: 2971
Joined: Tue 09 Dec 2008 1:37 pm
Weather Station: None !
Operating System: W10 - Threadripper 16core, etc
Location: Dudley, West Midlands, UK

Re: no display of trends graphics

Post by beteljuice »

As stated, you seem to have mx pages, but they are saying <#webtag> v 1.9.4 ?

The highchart graphs are part of the mx install.

From the wiki:
Cumulus MX should also upload by FTP eleven .json files that Cumulus MX creates in the top level directory (that is, the one it's been installed in), for the graphs ("graphconfig.json", "tempdata.json", "pressdata.json", "winddata.json", "wdirdata.json", "humdata.json", "raindata.json", "solardata.json", "dailyrain.json", "sunhours.json", "dailytemp.json").

Apart from the differences in the user interface, and the differences in web pages for 'gauges.htm' and 'trends.htm' ....
Image
......................Imagine, what you will KNOW tomorrow !

Thunderstorm
Posts: 34
Joined: Tue 26 Mar 2019 8:49 am
Weather Station: Davis Vantage Pro
Operating System: Win10

Re: no display of trends graphics

Post by Thunderstorm »

Hello,
I originally wanted to install CuMx. Remains of it still seem to be in the system. Now I want to make a cut, otherwise it will not work. I have saved all data of Cu1 and the web files and now wants to install CuMx and then enter the existing weather data. How would you act in my place, so that nothing goes wrong?
Many greetings
thunderstorm

water01
Posts: 1943
Joined: Sat 13 Aug 2011 9:33 am
Weather Station: WH1081
Operating System: Windows 10 64bit
Location: Burnham-on-Sea
Contact:

Re: no display of trends graphics

Post by water01 »

I am sorry it would appear you never got a reply to your last post.

If you look in the Wiki here https://cumuluswiki.org/a/Cumulus_MX there is complete instructions on how to install CumulusMX using Cumulus 1 data.
David
Image

Post Reply