Welcome to the new home of the Cumulus Support forum.

Latest Cumulus release v1.9.4 (build 1099) - Nov 28 2014
Latest Cumulus MX release - v3.0.0 build 3044 7 December 2018. See the Wiki for download

FTP problem

Discussion and questions about Cumulus weather station software version 1. This section and its subforums are the main place to get help with Cumulus. Anything which is not specific to the type of weather station goes in here; for anything specific to a type of weather station, please use the appropriate subforum. Use the 'website development' section for any questions relating to creating or running a web site for Cumulus data. Discussion of the stations themselves in these sections is fine.
Post Reply
User avatar
Vagspel
Posts: 59
Joined: Wed 11 Jan 2017 12:29 pm
Weather Station: Davis Vantage 2 Plus
Operating System: W7

FTP problem

Post by Vagspel » Sat 14 Jul 2018 12:48 pm

Hi,

Our station has been working for over a year with no problems but suddenly we are having problems with the FTP.
Is it a problem with Cumulus or with our ISP?
//Gunnar
o-vader.se
You do not have the required permissions to view the files attached to this post.
Gunnar
www.o-vader.se
www.o.vader.se/mobil.php for mobile phones

User avatar
steve
Cumulus Author
Posts: 26714
Joined: Mon 02 Jun 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: FTP problem

Post by steve » Sat 14 Jul 2018 1:51 pm

It apparently can't connect to the server. There may be more information in the ftp log if you turn that on.
Steve

water01
Posts: 1486
Joined: Sat 13 Aug 2011 9:33 am
Weather Station: WH1081
Operating System: Windows 7 64bit HP SP1
Location: Somewhere in the USA
Contact:

Re: FTP problem

Post by water01 » Sat 14 Jul 2018 2:44 pm

A lot of ISPs have been switching to more secure SSL connections because of the problems with TLS 1.0 and 1.1 so you may have to check with your ISP.

User avatar
Vagspel
Posts: 59
Joined: Wed 11 Jan 2017 12:29 pm
Weather Station: Davis Vantage 2 Plus
Operating System: W7

Re: FTP problem

Post by Vagspel » Thu 19 Jul 2018 2:28 pm

Hi Steve,

No more info in the ftplog.
Strange is that when Cumulus does retries when there is problems with the ftpconnection the program stops and has to be restarted.
Is there something wrong with our ftp settings?
Skärmklipp.PNG
//Gunnar
o-vader.se
You do not have the required permissions to view the files attached to this post.
Gunnar
www.o-vader.se
www.o.vader.se/mobil.php for mobile phones

water01
Posts: 1486
Joined: Sat 13 Aug 2011 9:33 am
Weather Station: WH1081
Operating System: Windows 7 64bit HP SP1
Location: Somewhere in the USA
Contact:

Re: FTP problem

Post by water01 » Thu 19 Jul 2018 2:33 pm

You have nothing in Directory. Usually this is the base directory on your server as specified by your ISP i.e. public_html or htdocs.

User avatar
Vagspel
Posts: 59
Joined: Wed 11 Jan 2017 12:29 pm
Weather Station: Davis Vantage 2 Plus
Operating System: W7

Re: FTP problem

Post by Vagspel » Thu 19 Jul 2018 2:39 pm

Thanks Water01,
Ok, I will check with our ISP.
//Gunnar
Gunnar
www.o-vader.se
www.o.vader.se/mobil.php for mobile phones

User avatar
Vagspel
Posts: 59
Joined: Wed 11 Jan 2017 12:29 pm
Weather Station: Davis Vantage 2 Plus
Operating System: W7

Re: FTP problem

Post by Vagspel » Thu 19 Jul 2018 3:18 pm

There is no need for a directory according to our ISP ftp.o-vader.se goes directly to the root directory where the Cumulus files are situated.
//Gunnar
Gunnar
www.o-vader.se
www.o.vader.se/mobil.php for mobile phones

User avatar
PaulMy
Posts: 1730
Joined: Sun 28 Sep 2008 11:54 pm
Weather Station: Davis Vantage Pro 2+ w/Envoy USB
Operating System: Windows-8
Location: Komoka, ON Canada
Contact:

Re: FTP problem

Post by PaulMy » Thu 19 Jul 2018 3:47 pm

Your trends do seem to indicate periods of no data http://www.o-vader.se/images/temp.png?1532015052626
Do you other upload to other sites and if so do they also show loss of updates for the same periods?

Enjoy,
Paul

User avatar
Vagspel
Posts: 59
Joined: Wed 11 Jan 2017 12:29 pm
Weather Station: Davis Vantage 2 Plus
Operating System: W7

Re: FTP problem

Post by Vagspel » Thu 19 Jul 2018 4:45 pm

Correct Paul, this was when the ftp did not work and Cumulus came to a stop :-(
//Gunnar
Gunnar
www.o-vader.se
www.o.vader.se/mobil.php for mobile phones

User avatar
steve
Cumulus Author
Posts: 26714
Joined: Mon 02 Jun 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: FTP problem

Post by steve » Fri 20 Jul 2018 3:00 pm

There's nothing at all in the ftp log?
Steve

User avatar
Vagspel
Posts: 59
Joined: Wed 11 Jan 2017 12:29 pm
Weather Station: Davis Vantage 2 Plus
Operating System: W7

Re: FTP problem

Post by Vagspel » Fri 20 Jul 2018 4:16 pm

Yes there is something in one ftplog at the end.
Also the box was ticked “restart if unplugged” and then when the ftp problem happened two Cumulus was running when I checked the task manager.

//Gunnar
You do not have the required permissions to view the files attached to this post.
Gunnar
www.o-vader.se
www.o.vader.se/mobil.php for mobile phones

User avatar
steve
Cumulus Author
Posts: 26714
Joined: Mon 02 Jun 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: FTP problem

Post by steve » Fri 20 Jul 2018 4:39 pm

You're getting timeouts, that's all it's possible to say from the information available to Cumulus. Often, using active ftp mode when it's not required will cause this (because the packets can't get through the firewalls), but if you've tried unsetting that, I don't know what else to suggest.
Steve

User avatar
Vagspel
Posts: 59
Joined: Wed 11 Jan 2017 12:29 pm
Weather Station: Davis Vantage 2 Plus
Operating System: W7

Re: FTP problem

Post by Vagspel » Fri 20 Jul 2018 8:57 pm

Ok Steve I will try unchecking aktiv ftp and see if that works :-)
//Gunnar
Gunnar
www.o-vader.se
www.o.vader.se/mobil.php for mobile phones

User avatar
Vagspel
Posts: 59
Joined: Wed 11 Jan 2017 12:29 pm
Weather Station: Davis Vantage 2 Plus
Operating System: W7

Re: FTP problem

Post by Vagspel » Sun 22 Jul 2018 8:56 am

Sometimes the problem is closer then you think :-)
After changing switch, cables, new ADSL modem, deep checking for virus and so on I noticed when configuring the new moden while Cumulus was running the browser lost contact with the modem and I could at the same time see that Cumulus did FTP retries.
I could repeat this with only the browser running so could it be the network card that was giving me the trubbel?

Whent in to town and bought a USB3 network card and voalà now it has been up running for 24h with no problems.

Lets hope that this solved the problem, the next couple of days will show. :lol:


//Gunnar
Gunnar
www.o-vader.se
www.o.vader.se/mobil.php for mobile phones

Post Reply