Welcome to the Cumulus Support forum.

Latest Cumulus MX release 3.9.0 (build 3095) - 09 October 2020 (please see announcement regarding releases since 3.5.0)
Legacy Cumulus 1 release v1.9.4 (build 1099) - 28 November 2014 (a patch is available for 1.9.4 build 1099 that extends the date range of the NOAA report and Snow Index drop-down menus to 2030)

Use this Wiki link to Download the Software (Cumulus MX / Cumulus 1 and other related items).

Extra Sensors Negative Temperature

Topics about the Beta trials up to Build 3043, the last build by Cumulus's founder Steve Loft. It was by this time way out of Beta but Steve wanted to keep it that way until he made a decision on his and Cumulus's future.

Moderator: mcrossley

Post Reply
User avatar
Werk_AG
Posts: 182
Joined: Sun 13 Jan 2013 8:04 pm
Weather Station: WeatherDuino Pro2 PLUS
Operating System: Windows 7
Location: Cercal CDV - Portugal
Contact:

Extra Sensors Negative Temperature

Post by Werk_AG »

I have one of my Extra Sensors temperature reporting -10ºC

With Cumulus1, this value is correctly shown in Extra Sensors windows, but with Cumulus MX this value is shown as 40ºC.
There is any possibility that Cumulus MX isn't work well with negative temperatures from Extra sensors?

User avatar
steve
Cumulus Author
Posts: 26702
Joined: Mon 02 Jun 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: Extra Sensors Negative Temperature

Post by steve »

I'm guessing this is extra temp 7? When I changed the code to do the checks for 255 for the dewpoint, I moved the point at which I subtract the 90F from the supplied figure. I missed putting it back in for extra temp 7.
Steve

User avatar
Werk_AG
Posts: 182
Joined: Sun 13 Jan 2013 8:04 pm
Weather Station: WeatherDuino Pro2 PLUS
Operating System: Windows 7
Location: Cercal CDV - Portugal
Contact:

Re: Extra Sensors Negative Temperature

Post by Werk_AG »

Your guess is right! Exactely the extra temp 7.

Post Reply