Welcome to the Cumulus Support forum.

Latest Cumulus MX release 3.9.1 (build 3096) - 31 October 2020 (please see announcement regarding releases since 3.5.0)
Legacy Cumulus 1 release v1.9.4 (build 1099) - 28 November 2014 (a patch is available for 1.9.4 build 1099 that extends the date range of the NOAA report and Snow Index drop-down menus to 2030)

Use this Wiki link to Download the Software (Cumulus MX / Cumulus 1 and other related items).

Showing Offline

Discussion of the Weather34 web site template

Moderators: saratogaWX, weatherist34

gmcotton
Posts: 17
Joined: Fri 21 Jun 2019 9:51 pm
Weather Station: Davis Vantage Pro2 Plus
Operating System: Windows 10

Showing Offline

Post by gmcotton »

Good day,

I just switched hosting providers and had my site migrated. Now when I go to my site (ve9gc.gmcotton.com/PWS) it shows offline. When I check the FTP logs, everything seems in order.
I'm at a bit of a loss. The site loads with historical data from a few days ago but is not updating.

Any and all advice most welcome.

Gordon

User avatar
rogerthn
Posts: 311
Joined: Thu 11 Apr 2013 6:31 pm
Weather Station: Ecowitt GW1000/GW1003
Operating System: Raspberry Pi OS Lite Buster
Location: Trollhättan Sweden
Contact:

Re: Showing Offline

Post by rogerthn »

Image

User avatar
PaulMy
Posts: 2295
Joined: Sun 28 Sep 2008 11:54 pm
Weather Station: Davis VP2+ Cumulus1 / CummulusMX
Operating System: Windows8 / Windows10
Location: Komoka, ON Canada
Contact:

Re: Showing Offline

Post by PaulMy »

Hi Gordon,
Looks like your realtime.txt is updating http://ve9gc.gmcotton.com/PWS/realtime.txt but you have not yet FTP the contents of the webfiles folder to your site so that it displays in full as well as to make the gauges work.

Enjoy,
Paul

User avatar
beteljuice
Posts: 3061
Joined: Tue 09 Dec 2008 1:37 pm
Weather Station: None !
Operating System: W10 - Threadripper 16core, etc
Location: Dudley, West Midlands, UK

Re: Showing Offline

Post by beteljuice »

but http://ve9gc.gmcotton.com/PWS/ is not ;)

Weather34 template ... the various php files are returning 'offline' for some reason.

A change of timezone perhaps ?
Image
......................Imagine, what you will KNOW tomorrow !

User avatar
PaulMy
Posts: 2295
Joined: Sun 28 Sep 2008 11:54 pm
Weather Station: Davis VP2+ Cumulus1 / CummulusMX
Operating System: Windows8 / Windows10
Location: Komoka, ON Canada
Contact:

Re: Showing Offline

Post by PaulMy »

On further checking seems you have the standard Cumulus template online as well as the Saratoga and the HWS PWS. The Saratogo is not current but http://ve9gc.gmcotton.com/PWS/ seems to be okay and updating. Your CumulusMX v3.0.0 b3050 is quite old but if all you want is the realtime.txt for your HWS then that will still do.

Enjoy,
Paul

gmcotton
Posts: 17
Joined: Fri 21 Jun 2019 9:51 pm
Weather Station: Davis Vantage Pro2 Plus
Operating System: Windows 10

Re: Showing Offline

Post by gmcotton »

Thank you for the replies.

Roger, that is interesting that the index.htm is showing correctly. I never actually looked at the "plain" version of the site.

Paul, not sure what you mean. All the files from the previously working site were transferred to the new site. Both were linux based though the new one has the more recent PHP version so that things that didn't show before now do. The only thing that I changed was the ftp login and file path as it is different on the new server. I'm not sure where you are seeing updating on the Saratoga page as it sure isn't here.

Well maybe I'll just clean off the directory and try a fresh install.


Gordon

User avatar
beteljuice
Posts: 3061
Joined: Tue 09 Dec 2008 1:37 pm
Weather Station: None !
Operating System: W10 - Threadripper 16core, etc
Location: Dudley, West Midlands, UK

Re: Showing Offline

Post by beteljuice »

You have two realtime.txt , one in 'root' the other in pws/

Only the one in pws/ has the correct (local) timestamp - but the HWS template is not displaying the data from either of these - so where is it getting its values from ?
Image
......................Imagine, what you will KNOW tomorrow !

gmcotton
Posts: 17
Joined: Fri 21 Jun 2019 9:51 pm
Weather Station: Davis Vantage Pro2 Plus
Operating System: Windows 10

Re: Showing Offline

Post by gmcotton »

Well beteljuice, that is a good question.

The extra realtime is likely due to getting the upload path right.

Can I over write my current Cumulus MX install with the latest and perhaps an update to the HWS template?

And I guess the next question if I install the latest Cumulus MX will I lose all my settings? Trying to find the logins and PW for WU , Weathercloud etc will not be fun.


Gordon

water01
Posts: 2000
Joined: Sat 13 Aug 2011 9:33 am
Weather Station: WH1081
Operating System: Windows 10 64bit
Location: Burnham-on-Sea
Contact:

Re: Showing Offline

Post by water01 »

And I guess the next question if I install the latest Cumulus MX will I lose all my settings? Trying to find the logins and PW for WU , Weathercloud etc will not be fun.
You shouldn't if you install over the top and do NOT lose/overwrite your existing Cumulus.ini file where all the settings are held. I do it all the time no problem.
David
Image

gmcotton
Posts: 17
Joined: Fri 21 Jun 2019 9:51 pm
Weather Station: Davis Vantage Pro2 Plus
Operating System: Windows 10

Re: Showing Offline

Post by gmcotton »

Thank you Water01

gmcotton
Posts: 17
Joined: Fri 21 Jun 2019 9:51 pm
Weather Station: Davis Vantage Pro2 Plus
Operating System: Windows 10

Re: Showing Offline

Post by gmcotton »

So I have upgraded to the latest MX and still no joy, so it isn't MX causing the problem.

I'll clean out the PWS folder and see what happens next

User avatar
PaulMy
Posts: 2295
Joined: Sun 28 Sep 2008 11:54 pm
Weather Station: Davis VP2+ Cumulus1 / CummulusMX
Operating System: Windows8 / Windows10
Location: Komoka, ON Canada
Contact:

Re: Showing Offline

Post by PaulMy »

Paul, not sure what you mean. All the files from the previously working site were transferred to the new site. Both were linux based though the new one has the more recent PHP version so that things that didn't show before now do. The only thing that I changed was the ftp login and file path as it is different on the new server. I'm not sure where you are seeing updating on the Saratoga page as it sure isn't here.
Probably some remnants of an early templates install...
http://ve9gc.gmcotton.com/
http://ve9gc.gmcotton.com/wxstatus.php
http://ve9gc.gmcotton.com/PWS/index.htm

Your HWS site seems to be updating as best as I can see, including the Nov and Today graphs http://ve9gc.gmcotton.com/PWS/ or am I missing something?

Enjoy,
Paul

gmcotton
Posts: 17
Joined: Fri 21 Jun 2019 9:51 pm
Weather Station: Davis Vantage Pro2 Plus
Operating System: Windows 10

Re: Showing Offline

Post by gmcotton »

Found the template

gmcotton
Posts: 17
Joined: Fri 21 Jun 2019 9:51 pm
Weather Station: Davis Vantage Pro2 Plus
Operating System: Windows 10

Re: Showing Offline

Post by gmcotton »

Please correct me if I'm wrong. All I have to do is unzip and upload to my PWS folder (which is currently empty) and tell Cumulus MX to up load its data to the same folder.

gmcotton
Posts: 17
Joined: Fri 21 Jun 2019 9:51 pm
Weather Station: Davis Vantage Pro2 Plus
Operating System: Windows 10

Re: Showing Offline

Post by gmcotton »

SOLVED!

Cleaned the directory, installed the HWS template, finally got the path straight for the realtime.txt and now the station is back online.

Many thanks to all who offered suggestions. They all helped me rethink the problem and get to the solution.

Gordon
Last edited by gmcotton on Fri 20 Nov 2020 2:53 am, edited 1 time in total.

Post Reply