Welcome to the Cumulus Support forum.

Latest Cumulus MX release 3.16.1 (build 3183) - 06 May 2022

Legacy Cumulus 1 release v1.9.4 (build 1099) - 28 November 2014 (a patch is available for 1.9.4 build 1099 that extends the date range of drop-down menus to 2030)

Download the Software (Cumulus MX / Cumulus 1 and other related items) from the Wiki

If you are interested in supporting Cumulus then maybe you would like to contribute to the maintenance of the Wiki? This need not take hours of your time - just a half hour here and there can make a big difference, particularly if many people are doing this. Any contributions are very welcome, whether they involve new content or editing of existing content. It will be very helpful to current and future users of Cumulus software if the Wiki is kept well-maintained and current. If you are interested then please contact forum user saratogaWX and ask for a Wiki account.

errant readings

Discussion of the Weather34 web site template

Moderators: saratogaWX, weatherist34

Post Reply
Mark14
Posts: 79
Joined: Thu 23 Aug 2012 8:53 pm
Weather Station: Ecowitt HP3501
Operating System: Windows 10
Location: Konin, Poland

errant readings

Post by Mark14 »

I very like the Weather34 template but I have some problems with Dewpoint readings that are still 0.0*C. I do not know why?

I have also noticed inflated gust readings eg. today I saw even 62 km/h but max. recorded gust equaled 38.6 km/h and it is consistent with data on WU.

Here is my website: http://mark014.beep.pl/CU-HWS/index.php?lang=en
Image
Mapantz
Posts: 1267
Joined: Sat 17 Dec 2011 11:55 am
Weather Station: Davis Vantage Pro2
Operating System: Windows 11 x64
Location: Dorset - UK
Contact:

Re: errant readings

Post by Mapantz »

Your realtime.txt is showing a dewpoint of 0.0, so it must be an issue with your stations data?!

http://mark014.beep.pl/realtime.txt
Image
Mark14
Posts: 79
Joined: Thu 23 Aug 2012 8:53 pm
Weather Station: Ecowitt HP3501
Operating System: Windows 10
Location: Konin, Poland

Re: errant readings

Post by Mark14 »

It is strange because Awekas also uploads my readings based on realtime.txt file and dewpoint is not 0.0*C:
https://www.awekas.at/en/instrument.php?id=15748
Image
Mapantz
Posts: 1267
Joined: Sat 17 Dec 2011 11:55 am
Weather Station: Davis Vantage Pro2
Operating System: Windows 11 x64
Location: Dorset - UK
Contact:

Re: errant readings

Post by Mapantz »

I don't think Awekas uses the realtime.txt? Not if you're sending data via CMX?

Strange though, as your realtime.txt definitely shows 0.0
Image
User avatar
mcrossley
Posts: 9969
Joined: Thu 07 Jan 2010 9:44 pm
Weather Station: Davis VP2/WLL
Operating System: Buster Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: errant readings

Post by mcrossley »

Is MX showing the dewpoint as zero in the admin interface? If so it sounds like your station is not providing a dew point value, if that is the case then you must get MX to calculate it using the station settings, options.
Mark14
Posts: 79
Joined: Thu 23 Aug 2012 8:53 pm
Weather Station: Ecowitt HP3501
Operating System: Windows 10
Location: Konin, Poland

Re: errant readings

Post by Mark14 »

Thanks. Yes, I had to set calculation of the dewpoint by Cumulus.

However, I have a problem with the rainfall displays. I changed in Station settings / Annual Rainfall and added my current 'year-to-date amount' but my monthly rainfall changed to zero. Where can I edit rainfall totals for the month and year?
Image
sfws
Posts: 1104
Joined: Fri 27 Jul 2012 11:29 am
Weather Station: Chas O, Maplin N96FY, N25FR
Operating System: rPi 3B+ with Buster (full)

Re: errant readings

Post by sfws »

https://cumuluswiki.org/a/FAQ#Where_doe ... ls_from.3F

Correction is covered in a later FAQ set
Mark14
Posts: 79
Joined: Thu 23 Aug 2012 8:53 pm
Weather Station: Ecowitt HP3501
Operating System: Windows 10
Location: Konin, Poland

Re: errant readings

Post by Mark14 »

If you need to, you can specify a year-to-date total to add in for the period up to the point where you started using Cumulus, so that your first year’s total is correct.
I did it but on my admin interface I have now corrected year rainfall: 116 mm but month value is 0.

The FAQ description is a bit complicated, old CUmulus and MX issues are mixed up. In general, however, if I understand it correctly all changes you need to edit in the dayfile.txt file
The current rain readings for May are still there for the following days and it is right but why Cumulus does not show them in the month summary...?

Another question that arises is the possibility of generating additional records for dayfile.txt I started Cumulus MX on May 7, but from August 2019 my station Ecowitt 3501 was running. Can this data be generated somehow for this file?
Image
User avatar
PaulMy
Posts: 3041
Joined: Sun 28 Sep 2008 11:54 pm
Weather Station: Davis VP2+ Cumulus1 / CummulusMX
Operating System: Windows8 / Windows10
Location: Komoka, ON Canada
Contact:

Re: errant readings

Post by PaulMy »

Another question that arises is the possibility of generating additional records for dayfile.txt I started Cumulus MX on May 7, but from August 2019 my station Ecowitt 3501 was running. Can this data be generated somehow for this file?
CumulusMX does not have a Create Missing function. This is a function in Cumulus1 and uses the Cumulus monthly log files to populate the missing. However as CumulusMX added the Ecowitt GW1000 station in late 2019 there would be no Cumulus monthly log files for Ecowitt stations from before that time.

Enjoy,
Paul
sfws
Posts: 1104
Joined: Fri 27 Jul 2012 11:29 am
Weather Station: Chas O, Maplin N96FY, N25FR
Operating System: rPi 3B+ with Buster (full)

Re: errant readings

Post by sfws »

PaulMy wrote: Sat 16 May 2020 1:22 pm This is a function in Cumulus1 and uses the Cumulus monthly log files to populate the missing
Paul, if you think about it, the additional fields in the content of dayfile.txt and monthly log files from 3.6.0, mean that C1 can no longer be used to plug this gap in MX functionality, irrespective of weather station type.
User avatar
PaulMy
Posts: 3041
Joined: Sun 28 Sep 2008 11:54 pm
Weather Station: Davis VP2+ Cumulus1 / CummulusMX
Operating System: Windows8 / Windows10
Location: Komoka, ON Canada
Contact:

Re: errant readings

Post by PaulMy »

@sfws, I am aware of that.

Enjoy,
Paul
Mark14
Posts: 79
Joined: Thu 23 Aug 2012 8:53 pm
Weather Station: Ecowitt HP3501
Operating System: Windows 10
Location: Konin, Poland

Re: errant readings

Post by Mark14 »

CumulusMX does not have a Create Missing function.
It's a pity. Maybe to make it easier it could be an option to add new records in Dayfile viewer/editor html file...?

My point is why I cannot see month rainfall for May here:
Image

if this data is present in dayfile (total rainfall column)?
Image
Image
Post Reply