Welcome to the Cumulus Support forum.

Latest Cumulus MX release 3.9.1 (build 3096) - 31 October 2020 (please see announcement regarding releases since 3.5.0)
Legacy Cumulus 1 release v1.9.4 (build 1099) - 28 November 2014 (a patch is available for 1.9.4 build 1099 that extends the date range of the NOAA report and Snow Index drop-down menus to 2030)

Use this Wiki link to Download the Software (Cumulus MX / Cumulus 1 and other related items).

Blank after configuring

Discussion of the Weather34 web site template

Moderators: saratogaWX, weatherist34

Post Reply
User avatar
HansR
Posts: 1536
Joined: Sat 20 Oct 2012 6:53 am
Weather Station: Davis Vantage Pro 2+
Operating System: Raspbian GNU/Linux 10 (Buster)
Location: Wagenborgen (NL)
Contact:

Blank after configuring

Post by HansR »

I am trying out the Weather34 site template but I run into a problem.

I install by copying all files to my websiteroot - it is outside my cumulus system which runs on a raspberry and realtime.txt is transferred OK. I run the configuration. I skip the database (is that compulsory?) but fill in everything else. after this is all done, I save the configuration and the screen goes blank. Refresh, reload, exit browser and restart, nothing works. I can't get back into the configuration nor the index. The site hangs and I am left to delete the whole thing and start again. I did this twice, don't feel like trying again.

If the database is compulsory, do I need to upload into the database directly from Cumulus (on the Raspberry)?
https://meteo-wagenborgen.nl / Cumulus 3.9.1 (build: 3096)
Davis Vantage Pro 2+ / Raspberry Pi 3 Model B Plus Rev 1.3
Raspbian Buster / 5.4.51-v7+ armv7l
Mono JIT compiler version 6.12.0.90 (tarball Fri Sep 4 14:21:54 UTC 2020)

User avatar
PaulMy
Posts: 2295
Joined: Sun 28 Sep 2008 11:54 pm
Weather Station: Davis VP2+ Cumulus1 / CummulusMX
Operating System: Windows8 / Windows10
Location: Komoka, ON Canada
Contact:

Re: Blank after configuring

Post by PaulMy »

Hi Hans,
No, you do not need to use the DB and settings to use the template with Cumulus. The current conditions come from Cumulus realtime.txt so it is important to get that path correct.

After the files are FTP to your site and after completing the various settings (you may need to get APIs from the third party services as indicated in the settings), as you indicate you have done, it should work. I have been using and installing various versions of the template for nearly 4 years and have not had the blank screen issue.

Sorry I can't be of help on the lock up issue.

Enjoy,
Paul

User avatar
HansR
Posts: 1536
Joined: Sat 20 Oct 2012 6:53 am
Weather Station: Davis Vantage Pro 2+
Operating System: Raspbian GNU/Linux 10 (Buster)
Location: Wagenborgen (NL)
Contact:

Re: Blank after configuring

Post by HansR »

Could not get it working.
Sticking with Saratoga templates, which gives me some feeling of having more control.
Thnx, Hans
https://meteo-wagenborgen.nl / Cumulus 3.9.1 (build: 3096)
Davis Vantage Pro 2+ / Raspberry Pi 3 Model B Plus Rev 1.3
Raspbian Buster / 5.4.51-v7+ armv7l
Mono JIT compiler version 6.12.0.90 (tarball Fri Sep 4 14:21:54 UTC 2020)

Post Reply