Page 1 of 1

Latest (final) Cumulus version

Posted: Fri 04 Jan 2019 10:37 pm
by Steepleian
Didn't want to bother Brian with this, but has anyone noticed any problem with the rainfall module for 3 December version?

I am getting strange values for yesterday's rainfall. For example it is currently showing 0.591mm (https://claydonsweather.org.uk/CU). We have not experienced rain for several days and my hardware only records in 0.3mm intervals anyway.

Re: Latest (final) Cumulus version

Posted: Fri 04 Jan 2019 10:55 pm
by Steepleian
Steepleian wrote:
Fri 04 Jan 2019 10:37 pm
Didn't want to bother Brian with this, but has anyone noticed any problem with the rainfall module for 3 December version?

I am getting strange values for yesterday's rainfall. For example it is currently showing 0.591mm (https://claydonsweather.org.uk/CU). We have not experienced rain for several days and my hardware only records in 0.3mm intervals anyway.
Just spotted the problem: -

rainfall.php line 16, change variable $weatherflow to $weather

However this correction shows an empty display for zero rainfall so need to have a closer look.

Re: Latest (final) Cumulus version

Posted: Fri 04 Jan 2019 11:06 pm
by Steepleian
Steepleian wrote:
Fri 04 Jan 2019 10:55 pm
Steepleian wrote:
Fri 04 Jan 2019 10:37 pm
Didn't want to bother Brian with this, but has anyone noticed any problem with the rainfall module for 3 December version?

I am getting strange values for yesterday's rainfall. For example it is currently showing 0.591mm (https://claydonsweather.org.uk/CU). We have not experienced rain for several days and my hardware only records in 0.3mm intervals anyway.
Just spotted the problem: -

rainfall.php line 16, change variable $weatherflow to $weather

However this correction shows an empty display for zero rainfall so need to have a closer look.
OK solved the problem.

rainfall.php. Change the lines 16 to 18 to this: -

Code: Select all

<?php echo "Yesterday<br>";echo "<rainblue>",$weather["rainydmax"],"</rainblue>";
if($weather["rain_units"]=="mm"){echo "&nbsp;<raingrey>".$weather["rain_units"]."</raingrey>";}
else echo " <grey>in</grey>";?>
This now gives a correct display of 0.0mm for zero rain yesterday.

Re: Latest (final) Cumulus version

Posted: Sat 05 Jan 2019 4:12 pm
by saratogaWX
Thanks for finding the fix. I've pushed the fix to the GitHub distribution. https://github.com/ktrue/CU-HWS

Best regards,
Ken

Re: Latest (final) Cumulus version

Posted: Sun 06 Jan 2019 4:49 pm
by GiveToLive
Thanks for the fix. Really appreciated.