Welcome to the Cumulus Support forum.

Latest Cumulus MX release 3.14.0 (build 3159) - 04 December 2021

Legacy Cumulus 1 release v1.9.4 (build 1099) - 28 November 2014 (a patch is available for 1.9.4 build 1099 that extends the date range of drop-down menus to 2030)

Download the Software (Cumulus MX / Cumulus 1 and other related items) from the Wiki

If you are interested in supporting Cumulus then maybe you would like to contribute to the maintenance of the Wiki? This need not take hours of your time - just a half hour here and there can make a big difference, particularly if many people are doing this. Any contributions are very welcome, whether they involve new content or editing of existing content. It will be very helpful to current and future users of Cumulus software if the Wiki is kept well-maintained and current. If you are interested then please contact forum user saratogaWX and ask for a Wiki account.

Alternative CumulusMX Interface

Share your Cumulus MX user interface here

Moderator: mcrossley

yamen
Posts: 1
Joined: Wed 10 Nov 2021 3:17 pm
Weather Station: Rosenborg 68750
Operating System: windows 10

Re: Alternative CumulusMX Interface

Post by yamen »

Same issue confirmed.
Software: CumulusMX 3.13.8 (3154)
Hardware: Raspberry pi zero W (bullseye)
Weather station: Rosenborg 68750 (wh1090 clone).

NeilThomas
Posts: 88
Joined: Thu 11 Oct 2012 9:51 am
Weather Station: Davis Vantage Pro2
Operating System: Raspberry Pi 4
Location: Gloucester
Contact:

Re: Alternative CumulusMX Interface

Post by NeilThomas »

Hi Guys

I have looked through all the code and can find no reason why this has happed. However, I am having difficulty with transferring stuff between my rPi and Mac using VNC. So I am wondering if the transfer stripped out or corrupted the zip file.

Would either of you be prepared to test the system for me. I can provide you with a new zip file that will create a second copy of the alternative interface in a folder ai.CumulusMX-v2 so that it won't corrupt your existing system. This will come directly from my rPi.
Neil Thomas
website: oaktreewebs.co.uk | Davis Vantage Pro II | CumulusMX, Raspberry Pi 4 | MX build 3154

User avatar
HansR
Posts: 2659
Joined: Sat 20 Oct 2012 6:53 am
Weather Station: GW1100 (WS80/WH40)
Operating System: Raspberry OS/Buster/Bullseye
Location: Wagenborgen (NL)
Contact:

Re: Alternative CumulusMX Interface

Post by HansR »

NeilThomas wrote:
Mon 15 Nov 2021 3:05 pm
Hi Guys

I have looked through all the code and can find no reason why this has happed. However, I am having difficulty with transferring stuff between my rPi and Mac using VNC. So I am wondering if the transfer stripped out or corrupted the zip file.

Would either of you be prepared to test the system for me. I can provide you with a new zip file that will create a second copy of the alternative interface in a folder ai.CumulusMX-v2 so that it won't corrupt your existing system. This will come directly from my rPi.
Sure, post/send it.
Hans

https://meteo-wagenborgen.nl
https://meteo-wagenborgen.nl/CMX4/index.html
Cumulus build 3149 ● Ecowitt GW1100/WS80/WH40 ● RPi 3B+ ● Raspbian 5.10.52-v7+ ● Mono 6.12.0.122

water01
Posts: 2316
Joined: Sat 13 Aug 2011 9:33 am
Weather Station: WH1081
Operating System: Windows 10 64bit
Location: Burnham-on-Sea
Contact:

Re: Alternative CumulusMX Interface

Post by water01 »

I can test it as well.
David
Image

AndyKF650
Posts: 166
Joined: Thu 20 Aug 2020 8:35 am
Weather Station: Davis VP2 Plus
Operating System: RPiv4 Debian Bullseye Windows 11
Location: Jersey Channel Islands
Contact:

Re: Alternative CumulusMX Interface

Post by AndyKF650 »

Yes count me in as a tester as well.

NeilThomas
Posts: 88
Joined: Thu 11 Oct 2012 9:51 am
Weather Station: Davis Vantage Pro2
Operating System: Raspberry Pi 4
Location: Gloucester
Contact:

Re: Alternative CumulusMX Interface

Post by NeilThomas »

Hi all

Version 2 of the Alternative Interface is finally ready with thanks to AndyKF650, HansR and water01 who kindly helped me iron out the bugs.

This version has the same look and feel as version 1 but now uses flex containers wherever possible and appropriate. This is mainly in the 'weather data' pages making it easy for you to change the order in which blocks are displayed. It also makes better use of space when viewing on smaller screens. This applies to the following pages:
  • The Dashboard - The alarms can be hidden and the sunrise, etc., data is displayed in a popup.
  • Current readings - All blocks align correctly and can also be made to be then same height.
  • Gauges - All blocks align correctly and you can reorder them according to your needs just by changing their 'order=x' style. You don't need to cut-n-paste.
  • All Chart pages - All charts are zoomable, and the selection buttons always display as full rows. You can change their order as above if you want.
  • Today v Yesterday - All done using flex containers, the 'Pressure', 'Hums' and 'Solar' panels can be re-arranged in their panel and all 4 large panels can also be reordered.
  • Weather Records - The buttons and the main category panels all use flex boxes so can be reorganised to suite your specific interest - for example you can put rainfall at the top if preferred.
  • Extra Sensors - If you only have CO2 and Partical sensors these can be placed at the top of the page to avoid having to scroll down.
  • Airlink Sensors - Arranged as columns; outdoor / indoor by default but, again can be changed.
The Main Configuration pages
Only superficial changes have been made to these such as any that use a row of buttons, all of which are in flex boxes. The exception to this are the Data Logs pages which have had one of the library javascript files modified to make better use of the popup panel used to actually edit values.
The only other change is to the Diary / Conditions editor pages which are now combined into one page.

Down load using the link below.
You do not have the required permissions to view the files attached to this post.
Last edited by NeilThomas on Thu 25 Nov 2021 3:47 pm, edited 1 time in total.
Neil Thomas
website: oaktreewebs.co.uk | Davis Vantage Pro II | CumulusMX, Raspberry Pi 4 | MX build 3154

Mapantz
Posts: 1076
Joined: Sat 17 Dec 2011 11:55 am
Weather Station: Davis Vantage Pro2
Operating System: Windows 10 x64
Location: Dorset - UK
Contact:

Re: Alternative CumulusMX Interface

Post by Mapantz »

I think I have installed this before I saw the 'withdrawn to errors'

It seems to be working fine?

Great work anyway- really like it!

I do see one error though; Loading the gauges page has dew point as the default, but there's no reading, if I change it to feels like, there's no reading either.

Side note: Not sure if you're interested in using them, but I put together my own set of images for up/down arrows and online/offline.
cmx_img.zip
You do not have the required permissions to view the files attached to this post.
Image

NeilThomas
Posts: 88
Joined: Thu 11 Oct 2012 9:51 am
Weather Station: Davis Vantage Pro2
Operating System: Raspberry Pi 4
Location: Gloucester
Contact:

Re: Alternative CumulusMX Interface

Post by NeilThomas »

Hi

One of my testers has reported an error when trying to access the Page Manager which controls the header and footer positioning on every page. It also loads any theme you have switched too. I have not been able to replicate the error so I have removed the comment about Errors.

With regards to the gauge issue, I don't use the 'Feels Like' readings and when I switch to that gauge, I also get no response from the gauge. However, the Dew Point reading does work. I'll put that on my todo list to check that Have included all the required data.

Neil
Neil Thomas
website: oaktreewebs.co.uk | Davis Vantage Pro II | CumulusMX, Raspberry Pi 4 | MX build 3154

Mapantz
Posts: 1076
Joined: Sat 17 Dec 2011 11:55 am
Weather Station: Davis Vantage Pro2
Operating System: Windows 10 x64
Location: Dorset - UK
Contact:

Re: Alternative CumulusMX Interface

Post by Mapantz »

NeilThomas wrote:
Thu 25 Nov 2021 3:53 pm

With regards to the gauge issue, I don't use the 'Feels Like' readings and when I switch to that gauge, I also get no response from the gauge. However, the Dew Point reading does work. I'll put that on my todo list to check that Have included all the required data.

Neil
The dew point shows this when I first load the page:
Screenshot 2021-11-25 155855.png
However, if I switch to windchill for example, then back to dew point, it works.

PS: Small typo on the 'Recent Charts' page title.
Screenshot 2021-11-25 160056.png
You do not have the required permissions to view the files attached to this post.
Image

User avatar
HansR
Posts: 2659
Joined: Sat 20 Oct 2012 6:53 am
Weather Station: GW1100 (WS80/WH40)
Operating System: Raspberry OS/Buster/Bullseye
Location: Wagenborgen (NL)
Contact:

Re: Alternative CumulusMX Interface

Post by HansR »

NeilThomas wrote:
Thu 25 Nov 2021 3:53 pm
Hi

One of my testers has reported an error when trying to access the Page Manager which controls the header and footer positioning on every page. It also loads any theme you have switched too. I have not been able to replicate the error so I have removed the comment about Errors.

With regards to the gauge issue, I don't use the 'Feels Like' readings and when I switch to that gauge, I also get no response from the gauge. However, the Dew Point reading does work. I'll put that on my todo list to check that Have included all the required data.

Neil
I must copy the directory to interface/ai.cmx-v2 to get it working, I would expect it to be ai.cmx which does not work.
The version should not be in the directory name.

NB: you may call me by name, I am not afraid of what I say here even if in error which is just human.
Hans

https://meteo-wagenborgen.nl
https://meteo-wagenborgen.nl/CMX4/index.html
Cumulus build 3149 ● Ecowitt GW1100/WS80/WH40 ● RPi 3B+ ● Raspbian 5.10.52-v7+ ● Mono 6.12.0.122

NeilThomas
Posts: 88
Joined: Thu 11 Oct 2012 9:51 am
Weather Station: Davis Vantage Pro2
Operating System: Raspberry Pi 4
Location: Gloucester
Contact:

Re: Alternative CumulusMX Interface

Post by NeilThomas »

Hi Hans

There is nothing in the code that makes it directory specific. Nothing is accessed using an absolute path to resources in stored in this release, only relative urls are used. Libraries from the default installation are accessed using an absolute url so don't include any reference to the directory used to contain the alternative interface.

My system is running from a completely different subdirectory in 'interface'. In fact I have just completely renamed the parent folder for this version and it still functions as expected.

Neil
Neil Thomas
website: oaktreewebs.co.uk | Davis Vantage Pro II | CumulusMX, Raspberry Pi 4 | MX build 3154

User avatar
PaulMy
Posts: 2831
Joined: Sun 28 Sep 2008 11:54 pm
Weather Station: Davis VP2+ Cumulus1 / CummulusMX
Operating System: Windows8 / Windows10
Location: Komoka, ON Canada
Contact:

Re: Alternative CumulusMX Interface

Post by PaulMy »

Nice job Neil, and thanks for continued development.
I do see one error though; Loading the gauges page has dew point as the default, but there's no reading, if I change it to feels like, there's no reading either.
With regards to the gauge issue, I don't use the 'Feels Like' readings and when I switch to that gauge, I also get no response from the gauge. However, the Dew Point reading does work. I'll put that on my todo list to check that Have included all the required data.
My ai-v2 Gauges show Dew point as default and as 3.6° which is ok and the popup also shows it correct. However if I change to Feels Like it shows -20.0 which I believe is like null, and the popup shows Feels Like Temperature Lowest and highest as -9999° C at undefined . Feels like is in my monthly data files. All the other selectable items, Apparent, Wind Chill, etc. are ok including the popup. And that then also leads to... Should that Gauge block be identified as Dewpoint, or as Other Temps?

The Gauges in the default website show correct for Dew point, Feels like, etc... http://www.komokaweather.com/cumulusmx/gauges.htm

Enjoy,
Paul

User avatar
HansR
Posts: 2659
Joined: Sat 20 Oct 2012 6:53 am
Weather Station: GW1100 (WS80/WH40)
Operating System: Raspberry OS/Buster/Bullseye
Location: Wagenborgen (NL)
Contact:

Re: Alternative CumulusMX Interface

Post by HansR »

NeilThomas wrote:
Thu 25 Nov 2021 4:22 pm
Hi Hans

There is nothing in the code that makes it directory specific. Nothing is accessed using an absolute path to resources in stored in this release, only relative urls are used. Libraries from the default installation are accessed using an absolute url so don't include any reference to the directory used to contain the alternative interface.

My system is running from a completely different subdirectory in 'interface'. In fact I have just completely renamed the parent folder for this version and it still functions as expected.

Neil
I just retried the same exercise (copy as is to interface/ai.cmx-v2 and then rename to ai.cmx) and indeed it now works.
It may have been a cache issue (the previous test version was ai.cmx and had errors).
I should have done a ctrl-F5 before reporting.
Hans

https://meteo-wagenborgen.nl
https://meteo-wagenborgen.nl/CMX4/index.html
Cumulus build 3149 ● Ecowitt GW1100/WS80/WH40 ● RPi 3B+ ● Raspbian 5.10.52-v7+ ● Mono 6.12.0.122

NeilThomas
Posts: 88
Joined: Thu 11 Oct 2012 9:51 am
Weather Station: Davis Vantage Pro2
Operating System: Raspberry Pi 4
Location: Gloucester
Contact:

Re: Alternative CumulusMX Interface

Post by NeilThomas »

Hi Hans

That is such an easy mistake to make. The number of times I have done it I don’t care to think. It’s even easier when editing Wordpress sites the have their own cache, a theme cache and your own computer cache.

Neil.
Neil Thomas
website: oaktreewebs.co.uk | Davis Vantage Pro II | CumulusMX, Raspberry Pi 4 | MX build 3154

NeilThomas
Posts: 88
Joined: Thu 11 Oct 2012 9:51 am
Weather Station: Davis Vantage Pro2
Operating System: Raspberry Pi 4
Location: Gloucester
Contact:

Re: Alternative CumulusMX Interface

Post by NeilThomas »

Hi Paul

The next update to the AI v2 will fix this - I left out the Feels Like lines in the gaugefeed.js file. The update should happen later today.
PaulMy wrote:
Thu 25 Nov 2021 4:29 pm
Nice job Neil, and thanks for continued development.
I do see one error though; Loading the gauges page has dew point as the default, but there's no reading, if I change it to feels like, there's no reading either.
With regards to the gauge issue, I don't use the 'Feels Like' readings and when I switch to that gauge, I also get no response from the gauge. However, the Dew Point reading does work. I'll put that on my todo list to check that Have included all the required data.
My ai-v2 Gauges show Dew point as default and as 3.6° which is ok and the popup also shows it correct. However if I change to Feels Like it shows -20.0 which I believe is like null, and the popup shows Feels Like Temperature Lowest and highest as -9999° C at undefined . Feels like is in my monthly data files. All the other selectable items, Apparent, Wind Chill, etc. are ok including the popup. And that then also leads to... Should that Gauge block be identified as Dewpoint, or as Other Temps?

The Gauges in the default website show correct for Dew point, Feels like, etc... http://www.komokaweather.com/cumulusmx/gauges.htm

Enjoy,
Paul
Neil Thomas
website: oaktreewebs.co.uk | Davis Vantage Pro II | CumulusMX, Raspberry Pi 4 | MX build 3154

Post Reply