Welcome to the Cumulus Support forum.

Latest Cumulus MX release v3.4.0 (build 3064) - 19 February 2020.
    Legacy Cumulus 1 release v1.9.4 (build 1099) - 28 November 2014

    See the Wiki for downloading either version.

    Cumulux MX on Windows data errors at start up

    Discussion of version 3 of Cumulus, which runs on Windows, Linux, and OS X. All Cumulus MX queries in here, please.

    Moderator: mcrossley

    Post Reply
    hqrgro
    Posts: 28
    Joined: Sat 09 Jan 2010 3:37 pm
    Weather Station: WS 1080
    Operating System: Windows 10
    Location: Italy - Latitudine N 45° 36' 48" Longitudine E 08° 50' 51

    Cumulux MX on Windows data errors at start up

    Post by hqrgro » Thu 13 Feb 2020 6:14 pm

    Good evening,

    I use Cumlus from 2010, with Windows PC and Velleman WS3010 Meteo Station, in the last months I have updated the system to Cumulus MX.
    Every time the windows PC restart for an upgrade and I start CumulusMX I get wrong value for Wind, temperature, rain, all the data coming from the external sensor.
    That is really a nightmare, because I must spend a lot of time to change the records, and always I lost the trends and historical data.

    I have purchased a new Meteo station, I was thinking that problem was in my Meteo station, but nothing is changed, if I restart windowsand CumulusMX I get a lot of data errors.

    Sometime the only possibility to restart without error CumulusMS is to complete delete the all files in DATA directory.

    Someone have alredy faced this problem?
    SOmeone can suggest me how to proceed?

    Grazie
    Giorgio Rossi

    User avatar
    mcrossley
    Posts: 5997
    Joined: Thu 07 Jan 2010 9:44 pm
    Weather Station: Davis VP2
    Operating System: Stretch Lite rPi
    Location: Wilmslow, Cheshire, UK
    Contact:

    Re: Cumulux MX on Windows data errors at start up

    Post by mcrossley » Thu 13 Feb 2020 11:14 pm

    Please zip up your MXdiags folder and attach it here so we can take a look.

    hw1958
    Posts: 11
    Joined: Mon 06 Jan 2020 4:49 pm
    Weather Station: Davis Vantage Pro 2
    Operating System: Windows 10

    Re: Cumulux MX on Windows data errors at start up

    Post by hw1958 » Fri 14 Feb 2020 11:47 am

    I am having a similar problem though not quite as extreme. When I open up CumulusMX I have been getting an erroneous rainfall reading of 0.6mm whcih I have been removing by using 'Edit Today's Rain'. Today for the first time the error was 1.0mm.

    I think this has only been happening since the introduction of the latest version (1063)

    User avatar
    mcrossley
    Posts: 5997
    Joined: Thu 07 Jan 2010 9:44 pm
    Weather Station: Davis VP2
    Operating System: Stretch Lite rPi
    Location: Wilmslow, Cheshire, UK
    Contact:

    Re: Cumulux MX on Windows data errors at start up

    Post by mcrossley » Fri 14 Feb 2020 4:18 pm

    hw1958 wrote:
    Fri 14 Feb 2020 11:47 am
    I am having a similar problem though not quite as extreme. When I open up CumulusMX I have been getting an erroneous rainfall reading of 0.6mm whcih I have been removing by using 'Edit Today's Rain'. Today for the first time the error was 1.0mm.
    Did you have any rain registered for today before you started Cumulus?
    Can you zip up your MXdiags folder and attach it please

    hw1958
    Posts: 11
    Joined: Mon 06 Jan 2020 4:49 pm
    Weather Station: Davis Vantage Pro 2
    Operating System: Windows 10

    Re: Cumulux MX on Windows data errors at start up

    Post by hw1958 » Sun 16 Feb 2020 10:31 am

    It doesn't seem to matter whether there is no rain or rain before I start Cumulus as it always seems to add an amount. To begin with it was 0.6mm but recently has increased and today was 1.2 mm. Anyway I have attached the MXDIAGS zip file

    Howard
    You do not have the required permissions to view the files attached to this post.

    User avatar
    mcrossley
    Posts: 5997
    Joined: Thu 07 Jan 2010 9:44 pm
    Weather Station: Davis VP2
    Operating System: Stretch Lite rPi
    Location: Wilmslow, Cheshire, UK
    Contact:

    Re: Cumulux MX on Windows data errors at start up

    Post by mcrossley » Sun 16 Feb 2020 10:25 pm

    Do you have any rain multipliers set?

    I cannot see it is doing anything wrong a a first glance though.

    I think what I will need is one of the backups that puts your data in a state when you started one of the runs and got the issue.

    hw1958
    Posts: 11
    Joined: Mon 06 Jan 2020 4:49 pm
    Weather Station: Davis Vantage Pro 2
    Operating System: Windows 10

    Re: Cumulux MX on Windows data errors at start up

    Post by hw1958 » Mon 17 Feb 2020 9:22 am

    No I don't have any multipliers set for rainfall (Only for wind speed which doesn't seem to be an issue)
    Not sure what you require re your last sentence

    User avatar
    mcrossley
    Posts: 5997
    Joined: Thu 07 Jan 2010 9:44 pm
    Weather Station: Davis VP2
    Operating System: Stretch Lite rPi
    Location: Wilmslow, Cheshire, UK
    Contact:

    Re: Cumulux MX on Windows data errors at start up

    Post by mcrossley » Mon 17 Feb 2020 12:11 pm

    I need a copy of your data files before you start Cumulus, and the log after you start it.

    Before you start Cumulus though make sure that the debug and data logging is enabled - edit Cumulus.ini and set (or add if they do not exist) the following two lines in the [station] section...

    Logging=1
    DataLogging=1

    hw1958
    Posts: 11
    Joined: Mon 06 Jan 2020 4:49 pm
    Weather Station: Davis Vantage Pro 2
    Operating System: Windows 10

    Re: Cumulux MX on Windows data errors at start up

    Post by hw1958 » Fri 21 Feb 2020 5:03 pm

    I've attached the requested files
    1. the data before he startup having added the 2 suggested lines to the Cumulus.ini file first. ( I had to delete some of the older files as the folder was too big to send)
    2. The Feb20log.txt file.
    3. The dayfile.txt file
    4. The MXDiags folder (in case you needed it.
    Note that I open Cumulus at 10:57 on 21 Feb.
    \note also I have amended the Feb20log.txt file from 1st to late on the 20th so these ,ay not be representative in showing the problem.
    There has been no rain recorded today, 21st Feb, since midnight
    You do not have the required permissions to view the files attached to this post.

    hw1958
    Posts: 11
    Joined: Mon 06 Jan 2020 4:49 pm
    Weather Station: Davis Vantage Pro 2
    Operating System: Windows 10

    Re: Cumulux MX on Windows data errors at start up

    Post by hw1958 » Sat 22 Feb 2020 10:04 am

    and just an update on this.
    Today when I started up Cumulus it has come up with the correct rainfall and not added any erroneous increase.
    Nice to see but not sure why !!

    Post Reply