Welcome to the Cumulus Support forum.

Latest Cumulus MX release 3.8.0 (build 3090) - 12 August 2020 (please see important announcement regarding releases since 3.5.0)
Legacy Cumulus 1 release v1.9.4 (build 1099) - 28 November 2014 (a patch is available for 1.9.4 build 1099 that extends the date range of the NOAA report and Snow Index drop-down menus to 2030)

Use this link to Download the Software (Cumulus MX / Cumulus 1 and other related items). Software

Cannot Upload Realtimegauges.txt file

From build 3044 the development baton passed to Mark Crossley. Mark has been responsible for all the Builds since. He has made the code available on GitHub. It is Mark's hope that others will join in this development, but at the very least he welcomes your ideas for future developments (see Cumulus MX Development suggestions).

Moderator: mcrossley

Post Reply
trevbrp
Posts: 8
Joined: Tue 02 Aug 2016 8:44 pm
Weather Station: WMR 928
Operating System: Windows 10
Location: Peterborough

Cannot Upload Realtimegauges.txt file

Post by trevbrp »

Hi,

I was using CumulusMX 3 or so years ago, but it stopped working for me and as much as i tried I couldn't get it working again. I have tried to get Cumulus back up, but I am still unable to get the realtimegauges.txt to upload to my web server. I continually see the following in the log:-

2020-01-07 21:09:56.257 Attempting realtime FTP connect
2020-01-07 21:10:11.599 Error connecting ftp - Timed out trying to read data from the socket stream!
2020-01-07 21:10:11.600 Starting Realtime timer, interval = 10 seconds
2020-01-07 21:10:11.600 Normal running
2020-01-07 21:10:11.692 Start normal reading loop
2020-01-07 21:10:31.753 Warning, previous realtime ftp still in progress, skipping this period.

ftp log shows the following: (server address removed)

# Connect()
Status: Connecting to
Status: Disposing FtpSocketStream...

2020-01-07 21:26:36.441 Uploading web\realtimegauges.txt to /Cumulus/realtimegauges.txt

# OpenWrite("/Cumulus/realtimegauges.txttmp", Binary)

# Connect()
Status: Connecting to
Status: Disposing FtpSocketStream...

Even setting up a new install, the above is what I see.

Any clues what could be causing this issue ?

regards

Trev
Windows 10 Pro

User avatar
mcrossley
Posts: 6765
Joined: Thu 07 Jan 2010 9:44 pm
Weather Station: Davis VP2
Operating System: Buster Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: Cannot Upload Realtimegauges.txt file

Post by mcrossley »

The obvious answer is that you have the ftp server details incorrectly set in your configuration.

Post Reply