Welcome to the Cumulus Support forum.

Latest Cumulus MX release 3.6.10 (build 3086) - 24 June 2020 (please see important announcement regarding releases since 3.5.0)
Legacy Cumulus 1 release v1.9.4 (build 1099) - 28 November 2014 (a patch is available for 1.9.4 build 1099 that extends the date range of the NOAA report and Snow Index drop-down menus to 2030)

See the Wiki to download the software or click on the Downloads link in the Forum Banner.

Wrong rainfall data

From build 3044 the development baton passed to Mark Crossley. Mark has been responsible for all the Builds since. He has made the code available on GitHub. It is Mark's hope that others will join in this development, but at the very least he welcomes your ideas for future developments (see Cumulus MX Development suggestions).

Moderator: mcrossley

Post Reply
gloec
Posts: 5
Joined: Tue 06 Jan 2009 7:58 am

Wrong rainfall data

Post by gloec »

I am using Cumulus MX, the Rpi version and for some reason the rainfall data calculation is completely wrong in what is displayed in the web site.

A Davis Vantage Vue is connected to the Rpi and that started happening all of a sudden.

I have the latest version installed 3.2.1 b3057 and my dayfile.txt includes all the correct recorded data.

I am using Cumulus since Jan-2009.

I will be grateful for any help or ideas.

Many thanks!

Nikos
Athens, Greece
You do not have the required permissions to view the files attached to this post.

User avatar
mcrossley
Posts: 6587
Joined: Thu 07 Jan 2010 9:44 pm
Weather Station: Davis VP2
Operating System: Buster Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: Wrong rainfall data

Post by mcrossley »

It looks like you have a problem in your dayfile...
Error on line 3879 of dayfile.txt: Input string was not in a correct format.
I also see that the station logger interval is not set the same as Cumulus which is causing it to download the entire logger contents on startup.

And your FTP and MySQL logins are both failing - but you probably know this :)

gloec
Posts: 5
Joined: Tue 06 Jan 2009 7:58 am

Re: Wrong rainfall data

Post by gloec »

Hey mcrossley!

Thank you so much!

I corrected the line and the problem is now fixed.

Also, I corrected the interval and it does not download the entire logger anymore.

BTW your template is amazing!

Many thanks.

Post Reply