Welcome to the Cumulus Support forum.

Latest Cumulus MX release 3.6.10 (build 3086) - 24 June 2020 (please see important announcement regarding releases since 3.5.0)
Legacy Cumulus 1 release v1.9.4 (build 1099) - 28 November 2014 (a patch is available for 1.9.4 build 1099 that extends the date range of the NOAA report and Snow Index drop-down menus to 2030)

See the Wiki to download the software or click on the Downloads link in the Forum Banner.

Updated and now browser shows 'Connection Closed'

From build 3044 the development baton passed to Mark Crossley. Mark has been responsible for all the Builds since. He has made the code available on GitHub. It is Mark's hope that others will join in this development, but at the very least he welcomes your ideas for future developments (see Cumulus MX Development suggestions).

Moderator: mcrossley

TonyG
Posts: 26
Joined: Mon 18 May 2015 9:34 am
Weather Station: WH1081
Operating System: Raspian 3.18.11-Raspberry Pi Bv2
Location: Bradworthy, North Devon
Contact:

Updated and now browser shows 'Connection Closed'

Post by TonyG »

Hello all. It's been a long time since I had to post here. My motto has always been if it ain't broke leave it alone! Having said that I realised I was now running a very old version and so have updated to the latest version of MX. Looking back through the update posts I saw notice of a few major changes and the suggestion that all files in the distribution package be updated. (something to do with FTP and dlls I think) so this is what I've done.
Every thing seems to be OK, even my web page is being updated correctly BUT when I view with a web browser the 'Gauges' tab is showing all the gauges at null or zero and when I click on the 'Now' tab the web browser instantly pops up a 'Connection Closed' notification and all the fields are empty.
I repeat - all else seems OK and all the other tabs are displaying correctly.
Can anyone cleverer than me save me a few hours and point me in the right direction to fix these two issues. Thanks!

User avatar
mcrossley
Posts: 6587
Joined: Thu 07 Jan 2010 9:44 pm
Weather Station: Davis VP2
Operating System: Buster Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: Updated and now browser shows 'Connection Closed'

Post by mcrossley »

Clear your browser cache, and which browser are you using, the release 3056 main dashboard page does not work with IE.

TonyG
Posts: 26
Joined: Mon 18 May 2015 9:34 am
Weather Station: WH1081
Operating System: Raspian 3.18.11-Raspberry Pi Bv2
Location: Bradworthy, North Devon
Contact:

Re: Updated and now browser shows 'Connection Closed'

Post by TonyG »

Thanks Mark. I'm using current version of Firefox and Opera. Have cleared the cache. Same result using either.

User avatar
mcrossley
Posts: 6587
Joined: Thu 07 Jan 2010 9:44 pm
Weather Station: Davis VP2
Operating System: Buster Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: Updated and now browser shows 'Connection Closed'

Post by mcrossley »

Edit: forget that, you are talking about your web pages - my error :bash:

TonyG
Posts: 26
Joined: Mon 18 May 2015 9:34 am
Weather Station: WH1081
Operating System: Raspian 3.18.11-Raspberry Pi Bv2
Location: Bradworthy, North Devon
Contact:

Re: Updated and now browser shows 'Connection Closed'

Post by TonyG »

No - you were right first time. :D I didn't really give enough information. I'm running my Pi headless and access the Dashboard over Ethernet and a web browser on my PC. It's there that the Now and Gauges tabs report 'Connection closed' The other tabs show data and work correctly and my website weather page is being updated correctly.
You do not have the required permissions to view the files attached to this post.

User avatar
mcrossley
Posts: 6587
Joined: Thu 07 Jan 2010 9:44 pm
Weather Station: Davis VP2
Operating System: Buster Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: Updated and now browser shows 'Connection Closed'

Post by mcrossley »

Odd, as all the pages that update use the same web sockets mechanism.

Can you launch the Firefox Network tool ( Ctrl-Shift-E ) and see if you are getting any errors, the data should be coming on a connection labelled "ws"

I just tried Firefox on my install and the gauges are working OK.

User avatar
mcrossley
Posts: 6587
Joined: Thu 07 Jan 2010 9:44 pm
Weather Station: Davis VP2
Operating System: Buster Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: Updated and now browser shows 'Connection Closed'

Post by mcrossley »

Unfortunately Firefox does not show the actual web socket messages - if you do the same in Chrome, that will show all the WS messages as they are received.

TonyG
Posts: 26
Joined: Mon 18 May 2015 9:34 am
Weather Station: WH1081
Operating System: Raspian 3.18.11-Raspberry Pi Bv2
Location: Bradworthy, North Devon
Contact:

Re: Updated and now browser shows 'Connection Closed'

Post by TonyG »

Hi Mark, I appreciate your help.

I don't have Chrome but Opera seems to supply the info needed. I can't be 100% sure as this is now above and beyond my competence level! :-)

Pictures below show Network and Console responses from the Now tab.
You do not have the required permissions to view the files attached to this post.

water01
Posts: 1913
Joined: Sat 13 Aug 2011 9:33 am
Weather Station: WH1081
Operating System: Windows 10 64bit
Location: Burnham-on-Sea
Contact:

Re: Updated and now browser shows 'Connection Closed'

Post by water01 »

I assume you started Cumulus as root using "sudo mono CumulusMX.exe", because the 200 code means "Such a response means the remote resource located at the URL doesn't listen or at least can't respond to a websocket request."., which would happen if Cumulus could not open the listening port because it was started incorrectly.
David
Image

TonyG
Posts: 26
Joined: Mon 18 May 2015 9:34 am
Weather Station: WH1081
Operating System: Raspian 3.18.11-Raspberry Pi Bv2
Location: Bradworthy, North Devon
Contact:

Re: Updated and now browser shows 'Connection Closed'

Post by TonyG »

Thanks David. Yes, Cumulus is started as root - sudo mono etc. Also would not all pages would report the same if Cumulus was not started correctly? As it is it's just Now and Gauges that show this behaviour.

User avatar
mcrossley
Posts: 6587
Joined: Thu 07 Jan 2010 9:44 pm
Weather Station: Davis VP2
Operating System: Buster Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: Updated and now browser shows 'Connection Closed'

Post by mcrossley »

Very strange, and really hard to debug via a forum! Code 200 normally means success for HTML connection, but the web socket connection should return an error 101 code which means it is switching protocols to WebSockets.

What is also of interest is that the JavaScript on those pages, and the actual WebSocket code in CMX has not changed in quite a long time, and it is working for other people (me included) which points to some change in your environment.

Is there any chance of another copy of CMX running in background?

User avatar
HansR
Posts: 1082
Joined: Sat 20 Oct 2012 6:53 am
Weather Station: Davis Vantage Pro 2+
Operating System: Raspbian GNU/Linux 10 (Buster)
Location: Wagenborgen (NL)
Contact:

Re: Updated and now browser shows 'Connection Closed'

Post by HansR »

I notice you have a version 3.18 for raspbian. That is not really current while the hardware really can handle more.
Wouldn't it be an idea to upgrade the OS?
https://meteo-wagenborgen.nl / Cumulus 3.6.8 (build: 3084)
Davis Vantage Pro 2+ / Raspberry Pi 3 Model B Plus Rev 1.3
Raspbian Linux 10 (buster) / 4.19.118-v7+ armv7l
Mono JIT compiler version 6.8.0.123 (tarball Tue May 12 15:31:43 UTC 2020)

TonyG
Posts: 26
Joined: Mon 18 May 2015 9:34 am
Weather Station: WH1081
Operating System: Raspian 3.18.11-Raspberry Pi Bv2
Location: Bradworthy, North Devon
Contact:

Re: Updated and now browser shows 'Connection Closed'

Post by TonyG »

Thanks everyone.

Mark, there is only one instance of CMX running. I do run it in a detached screen but have always done so.

Hans, I did try to use the latest version of Raspbian (separate SD card) and although that was fine on my ageing Pi - the then needed version of Mono would not install. I think I'll just replace all the CMX files on the pi again, just in case I missed something, and see what happens.

grpanos
Posts: 1
Joined: Wed 06 Jan 2016 11:38 pm
Weather Station: ws-2350
Operating System: 10
Location: greece

Re: Updated and now browser shows 'Connection Closed'

Post by grpanos »

hello
i have the same error after i update from version 3.0.0 build 3043
with that old version everything work great
but with update
the section now say connection closed
and the section Gauses not work at all
i use chrome and firefox last versions
it run at win10 pro
i install again the old version and i try update it again with versions newer that i have and i take the same erros
Sorry about my english but i hope you understand what i mean

User avatar
mcrossley
Posts: 6587
Joined: Thu 07 Jan 2010 9:44 pm
Weather Station: Davis VP2
Operating System: Buster Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: Updated and now browser shows 'Connection Closed'

Post by mcrossley »

I worked through this with another user, it turned out to be just a stale cache issue. Clear the browser cache and it everything should work OK.

Post Reply