Welcome to the Cumulus Support forum.

Latest Cumulus MX release v3.1.2 build 3055 - 4 November 2019.
Legacy Cumulus 1 release v1.9.4 (build 1099) - 28 November 2014

See the Wiki for downloading either version.

Bad reading nooa monthly e yearly report

Discussion of version 3 of Cumulus, which runs on Windows, Linux, and OS X. All Cumulus MX queries in here, please.

Moderator: mcrossley

User avatar
mcrossley
Posts: 5733
Joined: Thu 07 Jan 2010 9:44 pm
Weather Station: Davis VP2
Operating System: Stretch Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: Bad reading nooa monthly e yearly report

Post by mcrossley » Thu 07 Nov 2019 1:07 pm

The Saratoga template doesn't use UTF-8 encoding, so yes you have to manipulate the text like that to get it to display correctly. A UTF-8 encoded NOAA file embedded in a UTF-8 encoded HTML page <pre> displays just fine.

User avatar
beteljuice
Posts: 2770
Joined: Tue 09 Dec 2008 1:37 pm
Weather Station: None !
Operating System: ex XP SP3 - now W10 laptop grr
Location: Dudley, West Midlands, UK

Re: Bad reading nooa monthly e yearly report

Post by beteljuice » Thu 07 Nov 2019 1:14 pm

Now't to do with the beteljuice.
The web page viewer simply wraps what is generated in <PRE> tags so that spaces / linefeeds are respected.

However Hans ... as you well know we are discovering an increasing amount of server / ftp combinations that are corrupting &deg; regardless of binary or ascii. (I think maybe something to do with binary 64 ?)

Although &deg; is one of the HTML5 preferred syntaxes, perhaps it should be replaced by whatever you finally found works for all ?
Image
......................Imagine, what you will KNOW tomorrow !

User avatar
HansR
Posts: 344
Joined: Sat 20 Oct 2012 6:53 am
Weather Station: Davis Vantage Pro 2+
Operating System: Raspbian GNU/Linux 9 (stretch)
Location: Wagenborgen (NL)
Contact:

Re: Bad reading nooa monthly e yearly report

Post by HansR » Thu 07 Nov 2019 2:55 pm

@Mark: OK apparently everybody has to find his own solution. Maybe I just change the default Saratoga encoding :)
@beteljuice:
beteljuice wrote:
Thu 07 Nov 2019 1:14 pm
However Hans ... as you well know we are discovering an increasing amount of server / ftp combinations that are corrupting &deg; regardless of binary or ascii. (I think maybe something to do with binary 64 ?)
Maybe... but see my next remark... :?
beteljuice wrote:
Thu 07 Nov 2019 1:14 pm
Although &deg; is one of the HTML5 preferred syntaxes, perhaps it should be replaced by whatever you finally found works for all ?
That whatever I found, works for all is actually not one solution: in my situation for CumulusUtils it means that I use "&deg;C" for HTML (having tried &#186; &#x00B0; and making some errors there) and "\u00B0C" for generated javascript. So far this works for me everywhere. :groan:
https://meteo-wagenborgen.nl / Cumulus MX 3.1.0-b3053
Davis Vantage Pro 2+ / Raspberry Pi 3 Model B Plus Rev 1.3
Raspbian GNU/Linux 10 (buster) / Linux 4.19.75-v7+ armv7l
Mono JIT compiler version 6.4.0.198 (tarball Tue Sep 24 01:45:47 UTC 2019)

Post Reply