Welcome to the Cumulus Support forum.

Latest Cumulus MX release v3.1.2 build 3055 - 4 November 2019.
Legacy Cumulus 1 release v1.9.4 (build 1099) - 28 November 2014

See the Wiki for downloading either version.

Can't Find Extra Web Files

Discussion of version 3 of Cumulus, which runs on Windows, Linux, and OS X. All Cumulus MX queries in here, please.

Moderator: mcrossley

ronwright418
Posts: 88
Joined: Thu 06 Sep 2012 7:08 pm
Weather Station: Davis Vantage Pro2
Operating System: Raspberry Pi 2
Location: Chesapeake, VA
Contact:

Can't Find Extra Web Files

Post by ronwright418 » Mon 04 Nov 2019 9:27 pm

I recently moved CumulusMX from a Pi2 to a Pi3 and updated to version 3053. As I look as MXdiags now I see diagnostics saying that the Extra Web Files cannot be found. I can't find the files in either Pi, but the results seem to work OK. Copies of the MXdiags and the Extra Web Files table are attached. What am I doing wrong??
Thanks,
Ron
You do not have the required permissions to view the files attached to this post.
Ron Wright (ronwright418)
Image

Phil23
Posts: 296
Joined: Sat 16 Jul 2016 11:59 pm
Weather Station: Davis Vantage Pro2 Plus
Operating System: Win7 Pro
Location: Australia

Re: Can't Find Extra Web Files

Post by Phil23 » Mon 04 Nov 2019 9:47 pm

Not sure why yore paths are set like

home/pi/CumulusMX/CumulusMX/..... etc
rather than
/home/pi/CumulusMX/..... etc
Image

ronwright418
Posts: 88
Joined: Thu 06 Sep 2012 7:08 pm
Weather Station: Davis Vantage Pro2
Operating System: Raspberry Pi 2
Location: Chesapeake, VA
Contact:

Re: Can't Find Extra Web Files

Post by ronwright418 » Tue 05 Nov 2019 12:03 pm

when I installed 3053 it added a folder, but this is the path to CumulusMX.exe and initially the extra files table read just home/pi/CumulusMX/... but the diagnostic was there then too.
Ron Wright (ronwright418)
Image

User avatar
mcrossley
Posts: 5733
Joined: Thu 07 Jan 2010 9:44 pm
Weather Station: Davis VP2
Operating System: Stretch Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: Can't Find Extra Web Files

Post by mcrossley » Tue 05 Nov 2019 2:05 pm

B3053 added some additional logging so if it cannot find the extra files to process it tells you - previously is just silently failed and ignored them.

Your diags file does show a couple of issued though...

Code: Select all

2019-11-04 14:55:01.619 Error at line 109 of data/Oct19log.txt : Input string was not in a correct format.
2019-11-04 14:55:01.619 Please edit the file to correct the error
That file needs looking at.

And it appears to be downloading you whole logger archive - that is a symptom of not having the logging interval set the same in Cumulus and your VP2.

ronwright418
Posts: 88
Joined: Thu 06 Sep 2012 7:08 pm
Weather Station: Davis Vantage Pro2
Operating System: Raspberry Pi 2
Location: Chesapeake, VA
Contact:

Re: Can't Find Extra Web Files

Post by ronwright418 » Tue 05 Nov 2019 3:15 pm

Thanks Mark. I won't be able to work on these until tomorrow. The line input error sounds like one I had before -- a lot of nuls before the data. How do I sync the diagnostic times with the VP2 and CumulusMX? Also, how do I stop the unnecessary diagnostic notes?
Ron
Ron Wright (ronwright418)
Image

User avatar
mcrossley
Posts: 5733
Joined: Thu 07 Jan 2010 9:44 pm
Weather Station: Davis VP2
Operating System: Stretch Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: Can't Find Extra Web Files

Post by mcrossley » Tue 05 Nov 2019 3:45 pm

Take your logging interval from Cumulus, and then with Cumulus stopped, use the WeatherLink utility to set the VP2 console to the same value.

Take a look at this thread: viewtopic.php?t=2473


The diagnostic messages will stop if you remove the filenames you aren't using from the Extra web files configuration. But presumably you put them in there for a reason at some point?

ronwright418
Posts: 88
Joined: Thu 06 Sep 2012 7:08 pm
Weather Station: Davis Vantage Pro2
Operating System: Raspberry Pi 2
Location: Chesapeake, VA
Contact:

Re: Can't Find Extra Web Files

Post by ronwright418 » Wed 06 Nov 2019 5:11 pm

Thanks Mark,
I'm not planning on buying any Weatherlink equipment though, so I guess I just have to live with that.
Ron
Ron Wright (ronwright418)
Image

User avatar
mcrossley
Posts: 5733
Joined: Thu 07 Jan 2010 9:44 pm
Weather Station: Davis VP2
Operating System: Stretch Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: Can't Find Extra Web Files

Post by mcrossley » Wed 06 Nov 2019 5:29 pm

Ah, you have a third party logger then? Pretty sure the WL software will work with them too.

You can set it via the serial port if you are happy to fire up a terminal emulator?

ronwright418
Posts: 88
Joined: Thu 06 Sep 2012 7:08 pm
Weather Station: Davis Vantage Pro2
Operating System: Raspberry Pi 2
Location: Chesapeake, VA
Contact:

Re: Can't Find Extra Web Files

Post by ronwright418 » Wed 06 Nov 2019 7:56 pm

Yes, I use a third party logger. Don't remember the details, but got it from someone in England. Not familiar with the term terminal emulator, but it seems PuTTy qualifies, and also FireZilla. I have and can use both. Do I just type SETPER 10 at the command prompt and that resets the VP2? should I be logging into the VP2 somehow? I am using 10 in Cumulus, is there a way to see what the VP2 is using?
Ron Wright (ronwright418)
Image

User avatar
mcrossley
Posts: 5733
Joined: Thu 07 Jan 2010 9:44 pm
Weather Station: Davis VP2
Operating System: Stretch Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: Can't Find Extra Web Files

Post by mcrossley » Wed 06 Nov 2019 8:24 pm

You have it, SETPER is the command to use, and putty is ideal. No login required.

Note, when you set the logger interval on the console it will clear the existing memory and start logging agin from that point forwards.

User avatar
mcrossley
Posts: 5733
Joined: Thu 07 Jan 2010 9:44 pm
Weather Station: Davis VP2
Operating System: Stretch Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: Can't Find Extra Web Files

Post by mcrossley » Wed 06 Nov 2019 8:25 pm

You have it, SETPER is the command to use, and putty is ideal. No login required.

Note, when you set the logger interval on the console it will clear the existing memory and start logging agin from that point forwards.

ronwright418
Posts: 88
Joined: Thu 06 Sep 2012 7:08 pm
Weather Station: Davis Vantage Pro2
Operating System: Raspberry Pi 2
Location: Chesapeake, VA
Contact:

Re: Can't Find Extra Web Files

Post by ronwright418 » Wed 06 Nov 2019 10:10 pm

Maybe I'm getting too old for this. I am logging into the Pi, right? It's been several years since I used Putty, but I'm asked for a login and password. When I use Pi and raspberry I get pi@pi/. SETPER is not recognized. Do I need to change some settings? Hate to be a nuisance. :oops:
Ron Wright (ronwright418)
Image

freddie
Posts: 508
Joined: Wed 08 Jun 2011 11:19 am
Weather Station: Davis Vantage Pro 2
Operating System: GNU/Linux (Ubuntu 18.04)
Location: Dorrington, Shropshire
Contact:

Re: Can't Find Extra Web Files

Post by freddie » Thu 07 Nov 2019 12:08 am

Your terminal emulator needs to be on the Pi if that is where you have your VP2 plugged in. You are using the terminal to connect to your VP2 to issue the SETPER command.
Freddie
Image

User avatar
HansR
Posts: 344
Joined: Sat 20 Oct 2012 6:53 am
Weather Station: Davis Vantage Pro 2+
Operating System: Raspbian GNU/Linux 9 (stretch)
Location: Wagenborgen (NL)
Contact:

Re: Can't Find Extra Web Files

Post by HansR » Thu 07 Nov 2019 5:07 am

@Ron: Yes, difficult to understand maybe. Try search 'setper' on the forum.
One of the emerging clarifying messages is this one (I think).
https://meteo-wagenborgen.nl / Cumulus MX 3.1.0-b3053
Davis Vantage Pro 2+ / Raspberry Pi 3 Model B Plus Rev 1.3
Raspbian GNU/Linux 10 (buster) / Linux 4.19.75-v7+ armv7l
Mono JIT compiler version 6.4.0.198 (tarball Tue Sep 24 01:45:47 UTC 2019)

ronwright418
Posts: 88
Joined: Thu 06 Sep 2012 7:08 pm
Weather Station: Davis Vantage Pro2
Operating System: Raspberry Pi 2
Location: Chesapeake, VA
Contact:

Re: Can't Find Extra Web Files

Post by ronwright418 » Thu 07 Nov 2019 4:38 pm

Thanks freddie and HansR. I now have Putty on the pi, but do not know how to log into the console. What destination do I nee to use? I have tried several of the suggestions in the search with no joy. 'ls /dev/tty' returns '/dev/tty'. Using '/dev/tty' as a command yields 'permission denied'. 'sudo /dev/tty' gets 'command not found'. I am using a third party logger. How do I talk to the console?
Thanks again, Ron
Ron Wright (ronwright418)
Image

Post Reply