Welcome to the Cumulus Support forum.

Latest Cumulus MX release v3.2.3 build 3059 - 04 December 2019.
    Legacy Cumulus 1 release v1.9.4 (build 1099) - 28 November 2014

    See the Wiki for downloading either version.

    FTP issue on RPI

    Discussion of version 3 of Cumulus, which runs on Windows, Linux, and OS X. All Cumulus MX queries in here, please.

    Moderator: mcrossley

    Post Reply
    User avatar
    franmiele
    Posts: 9
    Joined: Wed 11 Sep 2019 5:31 pm
    Weather Station: Davis
    Operating System: Debian Buster

    FTP issue on RPI

    Post by franmiele » Sat 14 Sep 2019 6:08 pm

    I have installed CumulusMX 3052 and have mono, Mono JIT compiler version 5.18.0.240 (Debian 5.18.0.240+dfsg-3 Sat Apr 20 05:16:08 UTC 2019), on Debian Buster. I also had the same issue when running CumulusMX ver 5051

    I cannot connect to my hosting site.

    I have tried port 21 and 22 also with active FTP and without. Nothing works


    I have the same setup on a win10 system and it works fine. When I use a program like WINSCP on my win10 system I have to use SFTP, but the Cumulusmx works fine.

    I have attached the ftp log but don't know what else you need to try to resolve this issue.
    ftplog.txt
    I think there may be a bug in CumulusMX that rears its head on the RaspberryPI setup

    Fran
    You do not have the required permissions to view the files attached to this post.
    Fran
    Hardware= RPI 2
    Debian10 (Buster)
    Mono 5.18

    User avatar
    mcrossley
    Posts: 5795
    Joined: Thu 07 Jan 2010 9:44 pm
    Weather Station: Davis VP2
    Operating System: Stretch Lite rPi
    Location: Wilmslow, Cheshire, UK
    Contact:

    Re: FTP issue on RPI

    Post by mcrossley » Sat 14 Sep 2019 6:40 pm

    CumulusMX is trying to connect to an IPv6 address, is that expected?

    If you need to connect to an IPv4 address, then you could try disabling IPv6 in debian, or enter the IP address into the config rather than a hostname.

    User avatar
    franmiele
    Posts: 9
    Joined: Wed 11 Sep 2019 5:31 pm
    Weather Station: Davis
    Operating System: Debian Buster

    Re: FTP issue on RPI

    Post by franmiele » Tue 17 Sep 2019 11:05 pm

    mcrossley wrote:
    Sat 14 Sep 2019 6:40 pm
    CumulusMX is trying to connect to an IPv6 address, is that expected?

    If you need to connect to an IPv4 address, then you could try disabling IPv6 in debian, or enter the IP address into the config rather than a hostname.
    No , I am not supposed to be going to a IPv6 address. When I ping the host name from my PC i get 2607:f1c0:1000:8a:3669:b738:6e03:500b coming back.

    While I ma trying re3spolve this issue I have lftp running and it connects fine from the RaspberryPI to the same host name.

    I did disable IPv6 in Debian.

    Still cannot connect.
    Fran
    Hardware= RPI 2
    Debian10 (Buster)
    Mono 5.18

    User avatar
    franmiele
    Posts: 9
    Joined: Wed 11 Sep 2019 5:31 pm
    Weather Station: Davis
    Operating System: Debian Buster

    Re: FTP issue on RPI

    Post by franmiele » Tue 17 Sep 2019 11:14 pm

    mcrossley wrote:
    Sat 14 Sep 2019 6:40 pm
    CumulusMX is trying to connect to an IPv6 address, is that expected?

    If you need to connect to an IPv4 address, then you could try disabling IPv6 in debian, or enter the IP address into the config rather than a hostname.
    I don't know if this is of any use but I just looked at the ftp log from when I used my win10 machine and found this is the log. My win10 system ftp'd fine using the same host name:

    # Connect()
    Status: Connecting to 2607:f1c0:1000:8a:3669:b738:6e03:500b:21
    Status: Disposing FtpSocketStream...
    Status: Connecting to 216.250.121.19:21
    Response: 220 FTP Server ready.
    Command: USER xxxxxxxxx
    Response: 331 Password required for xxxxxx
    Command: PASS ***
    Response: 230 User xxxxxxxx logged in
    Command: FEAT
    Response: 500 'FEAT': command unrecognized.
    Status: Text encoding: System.Text.ASCIIEncoding
    Command: SYST
    Response: 215 UNIX Type: L8
    Status: Auto-detected UNIX listing parser
    Fran
    Hardware= RPI 2
    Debian10 (Buster)
    Mono 5.18

    User avatar
    mcrossley
    Posts: 5795
    Joined: Thu 07 Jan 2010 9:44 pm
    Weather Station: Davis VP2
    Operating System: Stretch Lite rPi
    Location: Wilmslow, Cheshire, UK
    Contact:

    Re: FTP issue on RPI

    Post by mcrossley » Fri 20 Sep 2019 10:03 am

    So that tried to connect using IPv6 and failed, then tried using IPv4 and worked.

    What does the FTP log look like on your rPi now you have disabled IPv6?

    User avatar
    franmiele
    Posts: 9
    Joined: Wed 11 Sep 2019 5:31 pm
    Weather Station: Davis
    Operating System: Debian Buster

    Re: FTP issue on RPI

    Post by franmiele » Fri 20 Sep 2019 2:55 pm

    mcrossley wrote:
    Fri 20 Sep 2019 10:03 am
    So that tried to connect using IPv6 and failed, then tried using IPv4 and worked.

    What does the FTP log look like on your rPi now you have disabled IPv6?
    It looks that way.

    The log with IPv6 disabled looks that same as it did before it was disabled. i really think there is something wrong the cumulus FTP on a RPI.
    ftplog.txt
    You do not have the required permissions to view the files attached to this post.
    Fran
    Hardware= RPI 2
    Debian10 (Buster)
    Mono 5.18

    freddie
    Posts: 521
    Joined: Wed 08 Jun 2011 11:19 am
    Weather Station: Davis Vantage Pro 2
    Operating System: GNU/Linux (Ubuntu 18.04)
    Location: Dorrington, Shropshire
    Contact:

    Re: FTP issue on RPI

    Post by freddie » Fri 20 Sep 2019 7:28 pm

    franmiele wrote:
    Fri 20 Sep 2019 2:55 pm
    mcrossley wrote:
    Fri 20 Sep 2019 10:03 am
    So that tried to connect using IPv6 and failed, then tried using IPv4 and worked.

    What does the FTP log look like on your rPi now you have disabled IPv6?
    The log with IPv6 disabled looks that same as it did before it was disabled.
    If IPV6 really was disabled then you wouldn't be getting attempted connections to IPV6 addresses.
    Freddie
    Image

    User avatar
    franmiele
    Posts: 9
    Joined: Wed 11 Sep 2019 5:31 pm
    Weather Station: Davis
    Operating System: Debian Buster

    Re: FTP issue on RPI

    Post by franmiele » Fri 20 Sep 2019 7:52 pm

    freddie wrote:
    Fri 20 Sep 2019 7:28 pm
    franmiele wrote:
    Fri 20 Sep 2019 2:55 pm
    mcrossley wrote:
    Fri 20 Sep 2019 10:03 am
    So that tried to connect using IPv6 and failed, then tried using IPv4 and worked.

    What does the FTP log look like on your rPi now you have disabled IPv6?
    The log with IPv6 disabled looks that same as it did before it was disabled.
    If IPV6 really was disabled then you wouldn't be getting attempted connections to IPV6 addresses.
    It says it's disabled.
    Capture.JPG
    Image
    You do not have the required permissions to view the files attached to this post.
    Fran
    Hardware= RPI 2
    Debian10 (Buster)
    Mono 5.18

    freddie
    Posts: 521
    Joined: Wed 08 Jun 2011 11:19 am
    Weather Station: Davis Vantage Pro 2
    Operating System: GNU/Linux (Ubuntu 18.04)
    Location: Dorrington, Shropshire
    Contact:

    Re: FTP issue on RPI

    Post by freddie » Fri 20 Sep 2019 7:59 pm

    Did you reboot? If IPV6 really is disabled then your DNS resolver won't give you IPV6 addresses to connect to, as the concept of IPV6 will be unknown to the OS.
    Freddie
    Image

    User avatar
    franmiele
    Posts: 9
    Joined: Wed 11 Sep 2019 5:31 pm
    Weather Station: Davis
    Operating System: Debian Buster

    Re: FTP issue on RPI

    Post by franmiele » Fri 20 Sep 2019 10:14 pm

    freddie wrote:
    Fri 20 Sep 2019 7:59 pm
    Did you reboot? If IPV6 really is disabled then your DNS resolver won't give you IPV6 addresses to connect to, as the concept of IPV6 will be unknown to the OS.
    Yes sir, I did. St5ill not working
    Fran
    Hardware= RPI 2
    Debian10 (Buster)
    Mono 5.18

    ExperiMentor
    Posts: 130
    Joined: Tue 24 Nov 2015 11:30 pm
    Weather Station: Fine Offset & Davis Vantage Vue
    Operating System: Windows 10; Raspbian Buster
    Location: Switzerland

    Re: FTP issue on RPI

    Post by ExperiMentor » Mon 23 Sep 2019 10:26 pm

    I found this elsewhere - suggests that disabling IPV6 in the kernel will not disable it for applications.
    Configuring IPv6 support in the kernel and user space applications are separate. Settings such as

    net.ipv6.conf.all.disable_ipv6
    net.ipv6.conf.default.disable_ipv6
    etc.

    set IPv6 kernel support but applications will try to use IPv6 regardless if configured to do so. Whatever program is generating those syslog error entries will need to have its own settings adjusted.
    From: https://www.raspberrypi.org/forums/view ... ?p=1066111

    If you Google 'disable IPV6 raspberry Pi' you'll find plenty links and suggestions - looks like many have struggled with similar. And there are many other suggestions of how to disble beyond the tick box in the GUI.

    User avatar
    franmiele
    Posts: 9
    Joined: Wed 11 Sep 2019 5:31 pm
    Weather Station: Davis
    Operating System: Debian Buster

    Re: FTP issue on RPI

    Post by franmiele » Mon 23 Sep 2019 11:37 pm

    ExperiMentor wrote:
    Mon 23 Sep 2019 10:26 pm
    I found this elsewhere - suggests that disabling IPV6 in the kernel will not disable it for applications.
    Configuring IPv6 support in the kernel and user space applications are separate. Settings such as

    net.ipv6.conf.all.disable_ipv6
    net.ipv6.conf.default.disable_ipv6
    etc.

    set IPv6 kernel support but applications will try to use IPv6 regardless if configured to do so. Whatever program is generating those syslog error entries will need to have its own settings adjusted.
    From: https://www.raspberrypi.org/forums/view ... ?p=1066111

    If you Google 'disable IPV6 raspberry Pi' you'll find plenty links and suggestions - looks like many have struggled with similar. And there are many other suggestions of how to disble beyond the tick box in the GUI.
    You guys are awesome! That did it! Thank you VERY much.
    Fran
    Hardware= RPI 2
    Debian10 (Buster)
    Mono 5.18

    ExperiMentor
    Posts: 130
    Joined: Tue 24 Nov 2015 11:30 pm
    Weather Station: Fine Offset & Davis Vantage Vue
    Operating System: Windows 10; Raspbian Buster
    Location: Switzerland

    Re: FTP issue on RPI

    Post by ExperiMentor » Thu 26 Sep 2019 7:03 pm

    franmiele wrote:
    Fri 20 Sep 2019 7:52 pm
    It says it's disabled.

    Capture.JPG

    Image
    Just noticed that in the screenshot you posted above, it shows you've disable IPv6 for interface eth0. If you're connected using WiFi, you'd need to switch to a different tab first. Just wondering if that's what's been wrong all along ...

    User avatar
    franmiele
    Posts: 9
    Joined: Wed 11 Sep 2019 5:31 pm
    Weather Station: Davis
    Operating System: Debian Buster

    Re: FTP issue on RPI

    Post by franmiele » Thu 26 Sep 2019 7:38 pm

    ExperiMentor wrote:
    Thu 26 Sep 2019 7:03 pm
    franmiele wrote:
    Fri 20 Sep 2019 7:52 pm
    It says it's disabled.

    Capture.JPG

    Image
    Just noticed that in the screenshot you posted above, it shows you've disable IPv6 for interface eth0. If you're connected using WiFi, you'd need to switch to a different tab first. Just wondering if that's what's been wrong all along ...
    Thanks for the response but the issue has been resolved.
    Fran
    Hardware= RPI 2
    Debian10 (Buster)
    Mono 5.18

    Post Reply