Welcome to the Cumulus Support forum.

Latest Cumulus MX release v3.0.2 build 3052 - 13 September 2019.
Legacy Cumulus 1 release v1.9.4 (build 1099) - 28 November 2014

See the Wiki for downloading either version.

Install MonoDevelop

Discussion of version 3 of Cumulus, which runs on Windows, Linux, and OS X. All Cumulus MX queries in here, please.

Moderator: mcrossley

Post Reply
User avatar
HansR
Posts: 177
Joined: Sat 20 Oct 2012 6:53 am
Weather Station: Davis Vantage Pro 2+
Operating System: Raspbian GNU/Linux 9 (stretch)
Location: Wagenborgen (NL)
Contact:

Install MonoDevelop

Post by HansR » Mon 26 Aug 2019 8:53 am

Hi,
I am working on some development related to cumulus and installed the MonoDevelop for Strech on my Raspberry. I shutdown cumulus and did the install sequence for "the Mono repository" as described in the URL (just referred to).

After this, I started up cumulus again and with every page it had a problem saying:

Code: Select all

500 - Internal Server Error
Message

Failing module name: StaticFilesModule
The method or operation is not implemented.

Stack Trace

  at System.IO.Compression.DeflateStream.WriteAsyncMemory (System.ReadOnlyMemory`1[T] source, System.Threading.CancellationToken cancellationToken) [0x00000] in :0 
  at (wrapper remoting-invoke-with-check) System.IO.Compression.DeflateStream.WriteAsyncMemory(System.ReadOnlyMemory`1,System.Threading.CancellationToken)
  at System.IO.Compression.GZipStream.WriteAsync (System.ReadOnlyMemory`1[T] buffer, System.Threading.CancellationToken cancellationToken) [0x00026] in :0 
  at System.IO.Stream.CopyToAsyncInternal (System.IO.Stream destination, System.Int32 bufferSize, System.Threading.CancellationToken cancellationToken) [0x000c7] in <15c986724bdc480293909469513cfdb3>:0 
  at Unosquare.Labs.EmbedIO.Extensions.CompressAsync (System.IO.Stream buffer, Unosquare.Labs.EmbedIO.Constants.CompressionMethod method, System.IO.Compression.CompressionMode mode, System.Threading.CancellationToken cancellationToken) [0x002ef] in :0 
  at Unosquare.Labs.EmbedIO.Modules.FileModuleBase.WriteFileAsync (System.Boolean usingPartial, System.String partialHeader, System.Int64 fileSize, Unosquare.Labs.EmbedIO.IHttpContext context, System.IO.Stream buffer, System.Threading.CancellationToken ct) [0x0021f] in :0 
  at Unosquare.Labs.EmbedIO.Modules.StaticFilesModule.HandleFile (Unosquare.Labs.EmbedIO.IHttpContext context, System.String localPath, System.Boolean sendBuffer, System.Threading.CancellationToken ct) [0x002a5] in :0 
  at Unosquare.Labs.EmbedIO.HttpHandler.ProcessRequest (System.Threading.CancellationToken ct) [0x00144] in :0 
A refresh of the page gave the old situation and everything seems OK.
I had to repeat this for every page before I had the old situation back.
[edit]All the info for the graphs was lost btw (I have graphs for 48 hrs), that history is lost, it's rebuilding it.[/edit]
During installation I had several messages it had disable LLVM because it lacked SS5.

I did not install MonoDevelop yet. Any idea about the cause? Any danger for the system? Safe to continue?
Asking this because it is fundamentally my cumulus-raspberry for the meteo. That should work no matter what.

Best,
Hans Rottier

Davis Vantage Pro 2+
Raspberry Pi 3 Model B Plus Rev 1.3
Raspbian GNU/Linux 9 (stretch) / Linux 4.19.58-v7+
Mono JIT compiler version 4.6.2 (Debian 4.6.2.7+dfsg-1)
Cumulus MX 3.0.2 b3052
https://meteo-wagenborgen.nl

ExperiMentor
Posts: 90
Joined: Tue 24 Nov 2015 11:30 pm
Weather Station: Fine Offset
Operating System: Windows 10; Raspbian Buster
Location: Switzerland

Re: Install MonoDevelop

Post by ExperiMentor » Fri 30 Aug 2019 8:30 pm

Just wondering if you just updated the Raspberry Pi Operating System? Raspbian has been updated from Stretch (aka Raspbian 9) to Buster (Raspbian 10), and that appears to require a new version of mono. see https://www.mono-project.com/download/s ... n-raspbian

User avatar
HansR
Posts: 177
Joined: Sat 20 Oct 2012 6:53 am
Weather Station: Davis Vantage Pro 2+
Operating System: Raspbian GNU/Linux 9 (stretch)
Location: Wagenborgen (NL)
Contact:

Re: Install MonoDevelop

Post by HansR » Fri 30 Aug 2019 8:36 pm

Just read this thread with the whole experience.
I was just few hours before matt posted his issue.
Hans Rottier

Davis Vantage Pro 2+
Raspberry Pi 3 Model B Plus Rev 1.3
Raspbian GNU/Linux 9 (stretch) / Linux 4.19.58-v7+
Mono JIT compiler version 4.6.2 (Debian 4.6.2.7+dfsg-1)
Cumulus MX 3.0.2 b3052
https://meteo-wagenborgen.nl

Post Reply