Welcome to the Cumulus Support forum.

Latest Cumulus MX release v3.0.2 build 3052 - 13 September 2019.
Legacy Cumulus 1 release v1.9.4 (build 1099) - 28 November 2014

See the Wiki for downloading either version.

Dashboard won't load after upgrade

Discussion of version 3 of Cumulus, which runs on Windows, Linux, and OS X. All Cumulus MX queries in here, please.

Moderator: mcrossley

Post Reply
hillyjd
Posts: 29
Joined: Sun 23 Apr 2017 2:42 pm
Weather Station: Davis Vantage Vue
Operating System: Linux

Dashboard won't load after upgrade

Post by hillyjd » Sat 24 Aug 2019 9:56 pm

I just upgraded to CMX 3050. At the same time, I upgraded the RPi s/w from Jessie to Buster. Everything seemed to go fine, except that the Dashboard page and the Gauges page won't load on my PC when I type in the IP address. I get an error "Connection closed". However, all the other data (like charts and today/yesterday) have current data. Interestingly enough, the dashboard and gauges pages load on the RPi web browser when I use http://localhost:9999.

I should point out that I changed internet service providers at the same time as well (seemed like a good idea at the time). My new ISP modem took my LAN IP address (192.168.0.X) so my Wifi router started using the IP 10.0.0.X. I can see that my RPi is connected to my Wifi at IP 10.0.0.7. It's just that when I type in the new IP (10.0.0.7:9999) on my PC browser, the Dashboard page and Gauge page display, but all the data is default values - nothing current.

Any suggestions?

ExperiMentor
Posts: 90
Joined: Tue 24 Nov 2015 11:30 pm
Weather Station: Fine Offset
Operating System: Windows 10; Raspbian Buster
Location: Switzerland

Re: Dashboard won't load after upgrade

Post by ExperiMentor » Mon 02 Sep 2019 12:31 am

Yes - Raspbian Buster and the newly-updated release of Mono (v6.0.0) are incompatible, giving errors like this.
See this thread viewtopic.php?f=27&t=17564

To check what version of mono you have, enter:

Code: Select all

mono -V
If you've got v6.0.0 you have this problem. If you have v5.18 you would be in luck - but them I don't know the cause of your problem.

By the way, you can try refreshing the pages with the 500 Error - then they appear. But the Settings tab does not.

hillyjd
Posts: 29
Joined: Sun 23 Apr 2017 2:42 pm
Weather Station: Davis Vantage Vue
Operating System: Linux

Re: Dashboard won't load after upgrade

Post by hillyjd » Mon 02 Sep 2019 9:32 pm

When I got your reply, I opened up CMX and the Dashboard and Gauges pages actually worked on my PC! I have not changed ANY computer configuration on either my RPi or my PC since I installed CMX 3050. I tried it several times, and it seems to be working just fine. I have tried it dozens times over the past two weeks, and no valid data ever showed up. Until today. How crazy is that?

I switched over to my RPi and found that I'm running mono ver 4.6.2. So I'm way out of date on that. But if it's working fine, is there any reason to update mono?

r/
Jim

ExperiMentor
Posts: 90
Joined: Tue 24 Nov 2015 11:30 pm
Weather Station: Fine Offset
Operating System: Windows 10; Raspbian Buster
Location: Switzerland

Re: Dashboard won't load after upgrade

Post by ExperiMentor » Mon 02 Sep 2019 10:00 pm

At present I definitely would NOT update mono - the new version is giving problems.

I'm wondering how you have an old version despite having Raspbian Buster - I wouldn't have expected that to be possible. But "if it ain't broke, don't fix it" very much applies at the moment.

I would even suggest you should run this to make sure your mono does NOT get updated:

Code: Select all

sudo apt-mark hold mono-runtime mono-complete mono-devel
This 'marks' mono to be 'held' at the current version.
(It's supposed to be the case that update will not move up major versions (ie your v4 would not go to 5 or 6), but right now I don't trust it at all, so it's 'belt and braces' for me!)

Ralph1
Posts: 11
Joined: Sun 07 Apr 2019 6:47 pm
Weather Station: Instromet
Operating System: Ubuntu Linux

Re: Dashboard won't load after upgrade

Post by Ralph1 » Tue 03 Sep 2019 1:36 pm

It looks as as if I have found out about this problem too late. I will have to find out if it's possible to get an earlier version of mono and install that. I did not realise at the time what was causing the strange effects.

Now I have another problem. Normally when I want to look at the dashboard I use the command http://localhost:8898/index.html. Recently I attempted to make my site more secure by renaming my site from http://sidlawweather.co.uk to https://sidlawweather.co.uk. This involves adjusting the .htaccess file to change http:/ to https:/ and works fine for most sites but of course doesn't work for https://localhost:8898/index.html presumably for reasons of security. Does anyone have a fix for that, apart from changing my .htaccess file back again?m My system is Ubuntu Linux with the latest version and generally updates everything fairly regularly. Will have to stop that.

Fortunately it appears that CumulusMX continues to work normally and gathers data from my system.

Ralph1

hillyjd
Posts: 29
Joined: Sun 23 Apr 2017 2:42 pm
Weather Station: Davis Vantage Vue
Operating System: Linux

Re: Dashboard won't load after upgrade

Post by hillyjd » Tue 03 Sep 2019 2:24 pm

I double checked my debian version and it comes up 10.0 - which is Buster. Thanks for the tip about how to make sure mono doesn't get upgraded. I will definitely implement that.

One very minor oddity - I still get the "Connection is closed" error when I try to view the Dashboard and Gauges pages on my smart phone. But not on the PC. Not a big deal. Other than that, it's all working flawlessly.

r/
Jim

Ralph1
Posts: 11
Joined: Sun 07 Apr 2019 6:47 pm
Weather Station: Instromet
Operating System: Ubuntu Linux

Re: Dashboard won't load after upgrade

Post by Ralph1 » Sat 14 Sep 2019 1:29 pm

Strange to relate, I updated my version of Ubuntu Linux 18.04 this morning, and the dashboard missing problem has gone away. All pages are displaying correctly. So it appears that mono has been changed again and this time to good effect.

Ralph1

User avatar
HansR
Posts: 177
Joined: Sat 20 Oct 2012 6:53 am
Weather Station: Davis Vantage Pro 2+
Operating System: Raspbian GNU/Linux 9 (stretch)
Location: Wagenborgen (NL)
Contact:

Re: Dashboard won't load after upgrade

Post by HansR » Sat 14 Sep 2019 4:14 pm

Now that is interesting. I will create a Linux (debian on rPi) installation with all tools to their highest versions and see what happens.
I'll report back. If that is true, it would be the end of the troubles, but Ubuntu is not Raspbian :|
Hans Rottier

Davis Vantage Pro 2+
Raspberry Pi 3 Model B Plus Rev 1.3
Raspbian GNU/Linux 9 (stretch) / Linux 4.19.58-v7+
Mono JIT compiler version 4.6.2 (Debian 4.6.2.7+dfsg-1)
Cumulus MX 3.0.2 b3052
https://meteo-wagenborgen.nl

User avatar
HansR
Posts: 177
Joined: Sat 20 Oct 2012 6:53 am
Weather Station: Davis Vantage Pro 2+
Operating System: Raspbian GNU/Linux 9 (stretch)
Location: Wagenborgen (NL)
Contact:

Re: Dashboard won't load after upgrade

Post by HansR » Sun 15 Sep 2019 5:55 pm

Just to inform you that the problems are only partially solved. I created an installation from scratch:

Buster: stable config from july 7, update after installation;
Mono: complete installation, update after installation;
Cumulus: restore of my backup from several hrs ago, including the start/stop script.

I started cumulus and it went OK. And indeed I had access to the dashboard, the 500 errors were gone.
But still Cumulus creates a sep.19log.txt file i.s.o. sep19log.txt. Therefore it can't access my old data.

Conclusion: NOT good for Raspbian, can't upgrade. Still having locale problems.

Nice exercise though.
Hans Rottier

Davis Vantage Pro 2+
Raspberry Pi 3 Model B Plus Rev 1.3
Raspbian GNU/Linux 9 (stretch) / Linux 4.19.58-v7+
Mono JIT compiler version 4.6.2 (Debian 4.6.2.7+dfsg-1)
Cumulus MX 3.0.2 b3052
https://meteo-wagenborgen.nl

User avatar
mcrossley
Posts: 5626
Joined: Thu 07 Jan 2010 9:44 pm
Weather Station: Davis VP2
Operating System: Stretch Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: Dashboard won't load after upgrade

Post by mcrossley » Sun 15 Sep 2019 6:14 pm

Hans, what version of Mono did you end up with?

User avatar
HansR
Posts: 177
Joined: Sat 20 Oct 2012 6:53 am
Weather Station: Davis Vantage Pro 2+
Operating System: Raspbian GNU/Linux 9 (stretch)
Location: Wagenborgen (NL)
Contact:

Re: Dashboard won't load after upgrade

Post by HansR » Sun 15 Sep 2019 6:23 pm

Mono JIT compiler version 6.0.0.334 (tarball Thu Sep 12 21:54:37 UTC 2019)
Hans Rottier

Davis Vantage Pro 2+
Raspberry Pi 3 Model B Plus Rev 1.3
Raspbian GNU/Linux 9 (stretch) / Linux 4.19.58-v7+
Mono JIT compiler version 4.6.2 (Debian 4.6.2.7+dfsg-1)
Cumulus MX 3.0.2 b3052
https://meteo-wagenborgen.nl

Post Reply