Welcome to the Cumulus Support forum.

Latest Cumulus MX release v3.4.0 (build 3064) - 19 February 2020.
    Legacy Cumulus 1 release v1.9.4 (build 1099) - 28 November 2014

    See the Wiki for downloading either version.

    Problem Raspberry Zero W & WMR928N

    Discussion of version 3 of Cumulus, which runs on Windows, Linux, and OS X. All Cumulus MX queries in here, please.

    Moderator: mcrossley

    Post Reply
    DANUCOSUKO
    Posts: 2
    Joined: Wed 21 Aug 2019 10:42 am
    Weather Station: Oregon WMR928N
    Operating System: Windows XP

    Problem Raspberry Zero W & WMR928N

    Post by DANUCOSUKO » Wed 21 Aug 2019 2:36 pm

    Hi, I have a problem installing Cumulus with Raspbian in Raspberry Zero W and Oregon WMR928N With Serial to USB wire.

    When I make this:

    cd CumulusMX
    sudo mono CumulusMX.exe

    I received error

    Current culture: Spanish (Spain)
    Serial: D3708DFF9D118932285CF4F9CC761334
    Cumulus MX v.3.0.0 build 3050
    Today.ini = data/today.ini
    Last update=2019-08-21T13:10:00
    Cumulus running at: http://*:8998/
    (Replace * with any IP address on this machine, or localhost)

    What can I do?

    I replace cumulus.ini in raspberry with the same file in WindowsXP where I have my station and I received now this:

    Current culture: Spanish (Spain)
    Serial: D3708DFF9D118932285CF4F9CC761334
    Cumulus MX v.3.0.0 build 3050
    Today.ini = data/today.ini
    Last update=2019-08-21T13:10:00
    Cumulus running at: http://*:8998/
    (Replace * with any IP address on this machine, or localhost)
    21/08/2019 15:58:20
    Type Ctrl-C to terminate
    System.InvalidOperationException: Specified port is not open.
    at System.IO.Ports.SerialPort.CheckOpen () [0x00008] in <cc2aa03ac5ad4081bf06b 04ddbd6fdb9>:0
    at System.IO.Ports.SerialPort.get_BytesToRead () [0x00000] in <cc2aa03ac5ad408 1bf06b04ddbd6fdb9>:0
    at (wrapper remoting-invoke-with-check) System.IO.Ports.SerialPort.get_BytesTo Read()
    at CumulusMX.WMR928Station.Start () [0x0001a] in <d6033b1cf0324922a46e116d28d8 0723>:0
    at System.Threading.ThreadHelper.ThreadStart_Context (System.Object state) [0x 00014] in <15c986724bdc480293909469513cfdb3>:0
    at System.Threading.ExecutionContext.RunInternal (System.Threading.ExecutionCo ntext executionContext, System.Threading.ContextCallback callback, System.Object state, System.Boolean preserveSyncCtx) [0x00071] in <15c986724bdc48029390946951 3cfdb3>:0
    at System.Threading.ExecutionContext.Run (System.Threading.ExecutionContext ex ecutionContext, System.Threading.ContextCallback callback, System.Object state, System.Boolean preserveSyncCtx) [0x00000] in <15c986724bdc480293909469513cfdb3>: 0
    at System.Threading.ExecutionContext.Run (System.Threading.ExecutionContext ex ecutionContext, System.Threading.ContextCallback callback, System.Object state) [0x0002b] in <15c986724bdc480293909469513cfdb3>:0
    at System.Threading.ThreadHelper.ThreadStart () [0x00008] in <15c986724bdc4802 93909469513cfdb3>:0
    **** An error has occurred - please zip up the MXdiags folder and post it in the forum ****
    Press Enter to terminate
    Cumulus running at: http://*:8998/

    What can I do?
    Thanks.

    water01
    Posts: 1590
    Joined: Sat 13 Aug 2011 9:33 am
    Weather Station: WH1081
    Operating System: Windows 10 64bit
    Location: Burnham-on-Sea
    Contact:

    Re: Problem Raspberry Zero W & WMR928N

    Post by water01 » Wed 21 Aug 2019 3:20 pm

    The port in the XP installation .ini file is not the same as the port in the Raspbian.

    Go to the devices folder \dev and discover the port that the WMR928 is connected to and alter the .ini file to match it.
    David
    Image

    ExperiMentor
    Posts: 133
    Joined: Tue 24 Nov 2015 11:30 pm
    Weather Station: Fine Offset & Davis Vantage Vue
    Operating System: Windows 10; Raspbian Buster
    Location: Switzerland

    Re: Problem Raspberry Zero W & WMR928N

    Post by ExperiMentor » Sat 24 Aug 2019 6:03 pm

    On a Windows machine, Com ports are named com0, com1 etc
    But in linux (as used on R Pi) they are named /dev/ttyUSB0 or similar for a USB port emulating a serial port.
    That's why you cannot simply move Cumulus.ini from Windows to RPi
    As we've been discussing in another thread [viewtopic.php?f=27&t=17551], you unfortunately will not find the port name in folder /dev.

    First try:
    Make sure CumulusMX is not running.

    Code: Select all

    cd CumulusMX
    nano Cumulus.ini
    Find the line specifying the comport - it's the 4th line in the file
    Edit it to read

    Code: Select all

    ComportName=/dev/ttyUSB0
    Ctrl-X to save
    Then try running CumulusMX.

    If that doesn't work, there are possibly other inconsistencies in Cumulus.ini
    Suggest you delete it (or rename it so it doesn't get accessed, if you are experimenting).
    Then CumulusMX will create a new file when you next run itr.
    You'll need to enter all you settings in the webinterface / Settings / Station settings

    Post Reply