Welcome to the Cumulus Support forum.

Latest Cumulus MX release 3.6.6 (build 3082) - 1 June 2020 (please see important announcement regarding releases since 3.5.0)
Legacy Cumulus 1 release v1.9.4 (build 1099) - 28 November 2014 (a patch is available for 1.9.4 build 1099 that extends the date range of the NOAA report and Snow Index drop-down menus to 2030)

See the Wiki to download the software or click on the Downloads link in the Forum Banner.

_wapi_connect: error looking up socket handle 0x11

From build 3044 the development baton passed to Mark Crossley. Mark has been responsible for all the Builds since. He has made the code available on GitHub. It is Mark's hope that others will join in this development, but at the very least he welcomes your ideas for future developments (see Cumulus MX Development suggestions).

Moderator: mcrossley

Post Reply
Chapel
Posts: 86
Joined: Mon 30 Jul 2018 10:23 am
Weather Station: Instromet
Operating System: Raspbian
Location: Binbrook UK
Contact:

_wapi_connect: error looking up socket handle 0x11

Post by Chapel »

I noticed the following error on the MX console this morning. Despite this everything was running as expected and I have now restarted CuMX as a precaution. The box is a Raspberry Pi3B+

Reading archive data from 17/06/2019 09:10:31 - please wait
Normal running
_wapi_connect: error looking up socket handle 0x11

Has anyone else experienced this?

User avatar
mcrossley
Posts: 6490
Joined: Thu 07 Jan 2010 9:44 pm
Weather Station: Davis VP2
Operating System: Buster Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: _wapi_connect: error looking up socket handle 0x11

Post by mcrossley »

Not seen it before, but it looks like a transitory error doing a HTTP call, was there anything in the diags log at that time?

Chapel
Posts: 86
Joined: Mon 30 Jul 2018 10:23 am
Weather Station: Instromet
Operating System: Raspbian
Location: Binbrook UK
Contact:

Re: _wapi_connect: error looking up socket handle 0x11

Post by Chapel »

Nothing in the logs related to this event, in fact all I do see is the usual "WU update: Error getting response stream (ReadDone2): ReceiveFailure"

User avatar
mcrossley
Posts: 6490
Joined: Thu 07 Jan 2010 9:44 pm
Weather Station: Davis VP2
Operating System: Buster Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: _wapi_connect: error looking up socket handle 0x11

Post by mcrossley »

From what I have read the error is coming direct from Mono, but it isn't severe enough to cause raise an exception back to the application.

Post Reply