Welcome to the Cumulus Support forum.

Latest Cumulus MX release v3.0.0 build 3050 - 1 May 2019.
Legacy Cumulus 1 release v1.9.4 (build 1099) - 28 November 2014

See the Wiki for downloading either version.

Data not uploading

Discussion of version 3 of Cumulus, which runs on Windows, Linux, and OS X. All Cumulus MX queries in here, please.

Moderator: mcrossley

Post Reply
Doncaster
Posts: 11
Joined: Tue 21 Oct 2014 10:51 am
Weather Station: WH1080
Operating System: Windows 10
Location: Doncaster

Data not uploading

Post by Doncaster » Wed 26 Jun 2019 2:46 pm

My weather station has been ticking over nicely for a long time now until a couple of days ago when the webpages appear to have stopped uploading.

I activated FTP logging and keep seeing the following error message crop up.

STOR /www/weather/realtime.txttmp
425 Could not open data connection to port 50xxx: Connection refused

Any thoughts?

Doncaster
Posts: 11
Joined: Tue 21 Oct 2014 10:51 am
Weather Station: WH1080
Operating System: Windows 10
Location: Doncaster

Re: Data not uploading

Post by Doncaster » Thu 04 Jul 2019 2:27 pm

Something else - the port number increases by 1 each time it fails

User avatar
PaulMy
Posts: 1891
Joined: Sun 28 Sep 2008 11:54 pm
Weather Station: Davis Vantage Pro 2+ w/Envoy USB
Operating System: Windows-8
Location: Komoka, ON Canada
Contact:

Re: Data not uploading

Post by PaulMy » Thu 04 Jul 2019 3:09 pm

No other suggestions so far, so I'll throw in my inexperienced 2 cents worth...

Looks like it stopped about June 24th. Anything happened at that time?
Try Use active FTP mode in internet settings.

Enjoy,
Paul

Doncaster
Posts: 11
Joined: Tue 21 Oct 2014 10:51 am
Weather Station: WH1080
Operating System: Windows 10
Location: Doncaster

Re: Data not uploading

Post by Doncaster » Thu 04 Jul 2019 3:37 pm

Cheers. Active FTP mode is already selected :(

User avatar
PaulMy
Posts: 1891
Joined: Sun 28 Sep 2008 11:54 pm
Weather Station: Davis Vantage Pro 2+ w/Envoy USB
Operating System: Windows-8
Location: Komoka, ON Canada
Contact:

Re: Data not uploading

Post by PaulMy » Thu 04 Jul 2019 4:44 pm

Sorry, can't come up with any other suggestions, and presume you've also tried without Active mode.

Enjoy,
Paul

User avatar
mcrossley
Posts: 5581
Joined: Thu 07 Jan 2010 9:44 pm
Weather Station: Davis VP2
Operating System: Stretch Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: Data not uploading

Post by mcrossley » Mon 08 Jul 2019 3:44 pm

The server is refusing your connection, presumably because FTP isn't listening, your ISP hasn't switched to FTPS have they?

Doncaster
Posts: 11
Joined: Tue 21 Oct 2014 10:51 am
Weather Station: WH1080
Operating System: Windows 10
Location: Doncaster

Re: Data not uploading

Post by Doncaster » Mon 08 Jul 2019 4:40 pm

They say no changes have been made. I've tried the FTPS option though and it's still the same.

Doncaster
Posts: 11
Joined: Tue 21 Oct 2014 10:51 am
Weather Station: WH1080
Operating System: Windows 10
Location: Doncaster

Re: Data not uploading

Post by Doncaster » Mon 08 Jul 2019 5:16 pm

Right - I've reset the password on the server, had a fiddle and have ended up with deselecting Active FTP and FTPS and it's working again - but not the gauges.

User avatar
mcrossley
Posts: 5581
Joined: Thu 07 Jan 2010 9:44 pm
Weather Station: Davis VP2
Operating System: Stretch Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: Data not uploading

Post by mcrossley » Tue 09 Jul 2019 2:28 pm

That's good, the gauges sound like a different issue, FTP path maybe?

Post Reply