Welcome to the Cumulus Support forum.

Latest Cumulus MX release v3.0.0 build 3048 - 02 March 2019.
Legacy Cumulus 1 release v1.9.4 (build 1099) - 28 November 2014

See the Wiki for downloading either version.

JSON Error

Discussion of version 3 of Cumulus, which runs on Windows, Linux, and OS X. All Cumulus MX queries in here, please.

Moderator: mcrossley

Post Reply
JandJCoops
Posts: 13
Joined: Thu 26 Oct 2017 1:40 pm
Weather Station: WS3083
Operating System: Windows 7

JSON Error

Post by JandJCoops » Fri 01 Feb 2019 2:52 pm

Hello again - I've recently installed CumulusMX and I am getting the error table id=dataid - Invalid JSON response. I've searched the boards and found Steve's reply to someone who had the same error and Steve thought at the time that it was because the dayfile was empty. My dayfile isn't empty.

I then went to the website as directed in the error message http://datatables.net/tn/1 but it seems to only show how to alter the script using Chrome on an Apple, neither of which I have now. Is there another way I could correct it please?

By the way Alleycat, the new Sun Pod you suggested I buy works beautifully. Sunshine hours don't show on the graph yet but it doesn't really matter at the moment as it is snowing, a lot.

Any help would be appreciated.
You do not have the required permissions to view the files attached to this post.

User avatar
mcrossley
Posts: 5450
Joined: Thu 07 Jan 2010 9:44 pm
Weather Station: Davis VP2
Operating System: Stretch Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: JSON Error

Post by mcrossley » Fri 01 Feb 2019 6:44 pm

You could launch the dev tools (F12) and look at the response in the network tab? The contents of that may give us a clue.

JandJCoops
Posts: 13
Joined: Thu 26 Oct 2017 1:40 pm
Weather Station: WS3083
Operating System: Windows 7

Re: JSON Error

Post by JandJCoops » Sat 02 Feb 2019 7:16 am

Thanks for this. I launched, see attached. I strongly suspected McAfee as being protective so I ended the processes of 3 of the 4 McAfee .exes but as soon as I try to end uihost.exe McAfeeWebAdvisor it pops right back up again and when you run MX again I get the same error.

By the way, how can I donate please?
You do not have the required permissions to view the files attached to this post.

User avatar
mcrossley
Posts: 5450
Joined: Thu 07 Jan 2010 9:44 pm
Weather Station: Davis VP2
Operating System: Stretch Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: JSON Error

Post by mcrossley » Sat 02 Feb 2019 5:09 pm

Yep, looks like McAfee is being over zealous - can't help with that I'm afraid. Though if you cannot disable it (or set an exception) from the user interface, then setting the service to disabled and rebooting may work?

JandJCoops
Posts: 13
Joined: Thu 26 Oct 2017 1:40 pm
Weather Station: WS3083
Operating System: Windows 7

Re: JSON Error

Post by JandJCoops » Fri 08 Feb 2019 3:05 pm

Hello Mark,

I'd like to ask again, how can I donate to you guys?

I've been unable to disable McAfee; I can stop all the services but one which disappears for one second but then pops back. It is the Module Core Service. I've got McAfee until September so I will just live without the dayfile, a shame but not deal breaking.

Thanks for your help

Jen

User avatar
mcrossley
Posts: 5450
Joined: Thu 07 Jan 2010 9:44 pm
Weather Station: Davis VP2
Operating System: Stretch Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: JSON Error

Post by mcrossley » Fri 08 Feb 2019 3:42 pm

Though you mainly see me making updates to Cumulus MX at the moment, someone else is beavering away at it behind the scenes, however we will not see the fruits of that work for a while. What I am saying is that MX is now open source and a (small - very small at the moment :lol: ) community effort, so it wouldn't feel right any one person accepting donations.

If you ever set my SS gauges up on your web site and want to contribute to those, then there is a donation link at the top of the SS gauges thread.

JandJCoops
Posts: 13
Joined: Thu 26 Oct 2017 1:40 pm
Weather Station: WS3083
Operating System: Windows 7

Re: JSON Error

Post by JandJCoops » Sat 09 Feb 2019 7:17 am

OK. Best of luck with everything you're doing :clap: .

Post Reply