Welcome to the new home of the Cumulus Support forum.

Latest Cumulus release v1.9.4 (build 1099) - Nov 28 2014
Latest Cumulus MX release - v3.0.0 build 3044 7 December 2018. See the Wiki for download

MX Randomly "stops" on Pi3

Discussion of version 3 of Cumulus, which runs on Windows, Linux, and OS X. All Cumulus MX queries in here, please.

Moderator: mcrossley

Post Reply
Big Daddy
Posts: 65
Joined: Tue 10 Sep 2013 8:40 pm
Weather Station: Maplin N96FY
Operating System: Windows 8
Location: Freiston, Lincolnshire, UK

MX Randomly "stops" on Pi3

Post by Big Daddy » Sat 24 Nov 2018 9:22 pm

Hi All,
A couple of times in the last few weeks Cumulus appears to have "stopped" and the only way to recover is to re-boot the Pi. I am not sure if its just not uploading to my website or if stopped completely. I am currently working away from home so dont have as much acces as I would like to the Pi and Cumulus.

I did manage to get hold of the MX diags file and see this at the end of them from when I believe the issue occurred. Its only just started happening recently so am trying to understand why. I have a Fineoffset weather station and dont seem to suffer from the known USB issues. Everything before this in the diags file seems normal

Any help appreciated. Here is the error:

2018-11-23 09:40:39.773 System.Net.Sockets.SocketException: The socket is not connected
at System.Net.Sockets.Socket.get_RemoteEndPoint () [0x00000] in <filename unknown>:0
at Alchemy.Classes.Context..ctor (Alchemy.WebSocketServer server, System.Net.Sockets.TcpClient connection) [0x00000] in <filename unknown>:0
at Alchemy.WebSocketServer.OnRunClient (System.Object data) [0x00000] in <filename unknown>:0
2018-11-23 09:40:39.967 System.ObjectDisposedException: The object was used after being disposed.
at System.IO.FileStream.Write (System.Byte[] array, Int32 offset, Int32 count) [0x00000] in <filename unknown>:0
at System.IO.StreamWriter.FlushBytes () [0x00000] in <filename unknown>:0
at System.IO.StreamWriter.FlushCore () [0x00000] in <filename unknown>:0
at System.IO.StreamWriter.Flush () [0x00000] in <filename unknown>:0
at System.Diagnostics.TextWriterTraceListener.Flush () [0x00000] in <filename unknown>:0
at System.Net.FtpClient.FtpTrace.Write (System.String message) [0x00000] in <filename unknown>:0
at System.Net.FtpClient.FtpTrace.WriteLine (System.String message) [0x00000] in <filename unknown>:0
at System.Net.FtpClient.FtpClient.Dispose () [0x00000] in <filename unknown>:0
at System.Net.FtpClient.FtpClient.Finalize () [0x00000] in <filename unknown>:0

Thanks
Andy

User avatar
mcrossley
Posts: 5231
Joined: Thu 07 Jan 2010 9:44 pm
Weather Station: Davis VP2
Operating System: Stretch Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: MX Randomly "stops" on Pi3

Post by mcrossley » Sun 25 Nov 2018 5:41 pm

The WebSocket component is used to drive the "Admin" interface for MX. Are you leaving a browser connected this interface?

Big Daddy
Posts: 65
Joined: Tue 10 Sep 2013 8:40 pm
Weather Station: Maplin N96FY
Operating System: Windows 8
Location: Freiston, Lincolnshire, UK

Re: MX Randomly "stops" on Pi3

Post by Big Daddy » Thu 29 Nov 2018 9:28 am

Hi Mark,
Thanks for the reply and apologies in the delay getting back.

I rarely use the interface of MX (I assume you mean logging into the local MX on port 8998) and the last time it occurred I was actually away and didnt have access to it.

It hasnt happened again since, so I will just monitor it for the time being and avoid accessing MX directly and see what happens.

Andy

Post Reply