Welcome to the new home of the Cumulus Support forum.

Latest Cumulus release v1.9.4 (build 1099) - Nov 28 2014
Latest Cumulus MX release - v3.0.0 build 3043 Jan 20 2017. See the Wiki for download

am i missing somthing or what?

Discussion of version 3 of Cumulus, which runs on Windows, Linux, and OS X. All Cumulus MX queries in here, please.
Post Reply
User avatar
dazza1223
Posts: 414
Joined: Sun 25 Jan 2015 8:41 pm
Weather Station: Davis Vantage Vue
Operating System: raspberry pi 3 +
Location: worthing
Contact:

am i missing somthing or what?

Post by dazza1223 » Sat 01 Sep 2018 2:22 pm

ive just fix all my monthly logs but im stuck on Days Since Last Dry Day it saying 38 days but it meant to be 45 ive edit monthlyalltime.ini i saw in there... and ive update month201807 two but when i re open cumulus 1 to up date it it all ways stay the same 38 days plus when i rebuild the day file it stay the same
have fun and keep learning

dazza :D

User avatar
steve
Cumulus Author
Posts: 26714
Joined: Mon 02 Jun 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: am i missing somthing or what?

Post by steve » Sat 01 Sep 2018 5:44 pm

http://wiki.sandaysoft.com/a/Today.ini

ConsecutiveDryDays

I think you mean "Days since it last rained", not "Days since last dry day", unless you've had a completely different summer there to everyone else in Europe.
Steve

User avatar
dazza1223
Posts: 414
Joined: Sun 25 Jan 2015 8:41 pm
Weather Station: Davis Vantage Vue
Operating System: raspberry pi 3 +
Location: worthing
Contact:

Re: am i missing somthing or what?

Post by dazza1223 » Sat 01 Sep 2018 5:47 pm

Sorry yh that what i mean that one u said sorry it been a long day so is there any think I'm missing :|
have fun and keep learning

dazza :D

User avatar
steve
Cumulus Author
Posts: 26714
Joined: Mon 02 Jun 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: am i missing somthing or what?

Post by steve » Sat 01 Sep 2018 6:10 pm

Which figure exactly are you trying to alter?
Steve

User avatar
dazza1223
Posts: 414
Joined: Sun 25 Jan 2015 8:41 pm
Weather Station: Davis Vantage Vue
Operating System: raspberry pi 3 +
Location: worthing
Contact:

Re: am i missing somthing or what?

Post by dazza1223 » Sat 01 Sep 2018 6:14 pm

The day it last rained it saying 35 days but it bent to be 45
have fun and keep learning

dazza :D

User avatar
steve
Cumulus Author
Posts: 26714
Joined: Mon 02 Jun 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: am i missing somthing or what?

Post by steve » Sat 01 Sep 2018 6:18 pm

The current figure for the number of days since it last rained before today (consecutive dry days) is held in today.ini as I posted above.
Steve

User avatar
dazza1223
Posts: 414
Joined: Sun 25 Jan 2015 8:41 pm
Weather Station: Davis Vantage Vue
Operating System: raspberry pi 3 +
Location: worthing
Contact:

Re: am i missing somthing or what?

Post by dazza1223 » Sat 01 Sep 2018 6:21 pm

Yh and every time I update that and rebuild the dayfile it over right it and this was back in my 2018
have fun and keep learning

dazza :D

User avatar
steve
Cumulus Author
Posts: 26714
Joined: Mon 02 Jun 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: am i missing somthing or what?

Post by steve » Sat 01 Sep 2018 6:26 pm

You don't need to rebuild the dayfile to correct the current number of days since it last rained, and rebuilding dayfile.txt definitely doesn't overwrite today.ini, so I have no idea what you're doing wrong. What do you mean by "this was back in my 2018"?
Steve

User avatar
dazza1223
Posts: 414
Joined: Sun 25 Jan 2015 8:41 pm
Weather Station: Davis Vantage Vue
Operating System: raspberry pi 3 +
Location: worthing
Contact:

Re: am i missing somthing or what?

Post by dazza1223 » Sat 01 Sep 2018 7:54 pm

it was in may 2018 where we had a long spell off dry weather and my wetherer st only recocd 35 day then that when i found out i had load off data missing so i dont all the missing data and now im stuck on this one ive just up dated the today.ini and shit the same stev
have fun and keep learning

dazza :D

sfws
Posts: 461
Joined: Fri 27 Jul 2012 11:29 am
Weather Station: Customised mix of Fine Offset
Operating System: Tempermental Win. 10 PC
Location: UK

Re: am i missing somthing or what?

Post by sfws » Sun 02 Sep 2018 7:00 am

Your earliest post in this thread says
dazza1223 wrote:im stuck on Days Since Last Dry Day it saying 38 days but it meant to be 45
Where is it saying this? Is it on the extremes for May in all years? Attach a screenshot of the screen where it is showing the wrong figure if you cannot explain which screen it is. Do you mean May 2018, because you say you have edited July 2018...
dazza1223 wrote:ive update month201807
I am guessing that like me you had rain towards end of May, then none until July. I had 49 consecutive days by July.

Your earliest post in this thread says you have edited the relevant files, but Cumulus is not showing updated figure.
dazza1223 wrote:ive edit monthlyalltime.ini i saw in there
Attach your monthlyalltime.ini file to a new post if you want someone to check you have edited it correctly.

If you are seeing the wrong figure for all-time ... Did you also edit alltime.ini?

I believe Steve has mentioned before to you that correcting rainfall is covered extensively in the FAQ. I am assuming you are talking about correcting the all-time or monthly all-time Longest Dry Period figure for May, June, and July 2018? If so then http://wiki.sandaysoft.com/a/FAQ#.28Inv ... e_extremes is the most appropriate bit of FAQ.

I don't use MX so can't quote the relevant screen on the interface, but when you restart Cumulus MX it can only get the numbers it shows by reading the ini files, so the only way it can pick up wrong figure is if you have made a mistake with your editing.
(Editing today.ini is only relevant to current days since last rain figure. It seems this thread has had some confusing in-between posts.)

User avatar
dazza1223
Posts: 414
Joined: Sun 25 Jan 2015 8:41 pm
Weather Station: Davis Vantage Vue
Operating System: raspberry pi 3 +
Location: worthing
Contact:

Re: am i missing somthing or what?

Post by dazza1223 » Sun 02 Sep 2018 11:40 am

hi thank you for all that info so ive done some more digging in about this

right so if i open monthlyalltime.ini and update

[Rain07]
highrainratevalue=155.6
highrainratetime=2017-07-19T01:09:19
highdailyrainvalue=127.2
highdailyraintime=2016-07-22T09:37:28
highhourlyrainvalue=22.5
highhourlyraintime=2015-01-07T00:16:00
highmonthlyrainvalue=127.2
highmonthlyraintime=2016-07-22T09:37:28
longestdryperiodvalue=38
longestdryperiodtime=2018-07-26T00:00:00
longestwetperiodvalue=6
longestwetperiodtime=2017-07-24T00:00:00

and then open up cumulus 1 and go to edit monthly records and click fetch dayfile data it show 35 days so i dont understand y the dayfile still show that days as ive rebult th dayfile after up dating monthlyalltime.ini so it mush be getting the dater from somewhere else ive look in Jul18log
have fun and keep learning

dazza :D

User avatar
steve
Cumulus Author
Posts: 26714
Joined: Mon 02 Jun 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: am i missing somthing or what?

Post by steve » Sun 02 Sep 2018 11:58 am

You said it was May and you're editing July?

The point of editing the ini file is so you don't have to use the data logs for that figure. Editing the ini file and then using the editor is not sensible. Your data is clearly incorrect somewhere. If you are updating that record from the dayfile data then clearly it's the data in dayfile.txt which is erroneous. It can only update that record correctly if the data elsewhere is correct and complete.
Steve

User avatar
dazza1223
Posts: 414
Joined: Sun 25 Jan 2015 8:41 pm
Weather Station: Davis Vantage Vue
Operating System: raspberry pi 3 +
Location: worthing
Contact:

Re: am i missing somthing or what?

Post by dazza1223 » Sun 02 Sep 2018 12:06 pm

hi Steve yh it was Jul18log not may!!! sorry my bad so you saying the data it rong some where else ive look and i cant see any thing?

so you saying the dayfile reads the logs and count how meany days with out rain
have fun and keep learning

dazza :D

User avatar
steve
Cumulus Author
Posts: 26714
Joined: Mon 02 Jun 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: am i missing somthing or what?

Post by steve » Sun 02 Sep 2018 12:45 pm

The dayfile editor takes the last rain value for each day in the monthly log file and uses that for the total for that day.

The monthly record editor uses the daily totals in dayfile.txt to determine the runs of wet or dry days, adding one to the appropriate count for each day that it finds in the file, and resetting the count to zero when it detects a change from wet to dry and vice versa.
Steve

User avatar
dazza1223
Posts: 414
Joined: Sun 25 Jan 2015 8:41 pm
Weather Station: Davis Vantage Vue
Operating System: raspberry pi 3 +
Location: worthing
Contact:

Re: am i missing somthing or what?

Post by dazza1223 » Sun 02 Sep 2018 12:48 pm

bingo steve ive done it mate thare was missing data in Jul18log lucky i had backup and i restored them and re done it and it all right just WANT TO SAY A BIG THANKS FOR YOU ALL HELPING ME :D
have fun and keep learning

dazza :D

Post Reply