Welcome to the new home of the Cumulus Support forum.

Latest Cumulus release v1.9.4 (build 1099) - Nov 28 2014
Latest Cumulus MX release - v3.0.0 build 3044 7 December 2018. See the Wiki for download

USB stop responding

Discussion of version 3 of Cumulus, which runs on Windows, Linux, and OS X. All Cumulus MX queries in here, please.

Moderator: mcrossley

stef942
Posts: 15
Joined: Mon 19 Oct 2009 8:17 pm
Weather Station: WMR200
Operating System: raspi3
Location: France-oise

USB stop responding

Post by stef942 » Fri 27 Jul 2018 11:08 am

Hi,

My WMR200 stops sending data to my pi3 several times every day or the pi doesnt received data from the station i dont know but i have to reboot it 2.3.4 times a day. what can i do to find the problem?

thanks for your help
My weather station at Ver sur Launette - France (live) : http://stef942.free.fr/CumulusMX/gauges.htm

User avatar
ConligWX
Posts: 736
Joined: Mon 19 May 2014 10:45 pm
Weather Station: Davis Vantage Pro2 Plus
Operating System: MeteoBridge Nano SD
Location: Bangor, NI
Contact:

Re: USB stop responding

Post by ConligWX » Fri 27 Jul 2018 11:25 am

I'm not sure if the same thing applies to the WMR200 but I know fine Offset devices lock up from time to time. some fixes are to either add Ferrite cores to the ends of the USB console cable, or to plug in a Powered USB Hub between the Rasbpi and your Weather Station Console. Also using a shielded USB cable can help too.

are you sharing the USB port on the Rasbpi with anything else?
Regards Simon

https://www.conligwx.org
https://twitter.com/conligwx
Davis Vantage Pro2 Plus - Meteobrige Nano SD + Saratoga/PWS Templates

stef942
Posts: 15
Joined: Mon 19 Oct 2009 8:17 pm
Weather Station: WMR200
Operating System: raspi3
Location: France-oise

Re: USB stop responding

Post by stef942 » Fri 27 Jul 2018 2:42 pm

thanks for your reply, there is nothing else connected to the pi only the station, the usb cable has ferrite cores on both ends, i will try an usb hub to see if it change something .
My weather station at Ver sur Launette - France (live) : http://stef942.free.fr/CumulusMX/gauges.htm

sutne
Posts: 12
Joined: Sun 14 Oct 2012 4:23 pm
Weather Station: Oregon Scientific WMR100
Operating System: Raspbian Jessie
Location: Mjølfjell, Voss, Norway

Re: USB stop responding

Post by sutne » Sun 29 Jul 2018 7:38 pm

I had problems with the USBconnection between my WMR100 and the Raspberry3.
After I installed a powered hub between them last year, I have had no problems.

stef942
Posts: 15
Joined: Mon 19 Oct 2009 8:17 pm
Weather Station: WMR200
Operating System: raspi3
Location: France-oise

Re: USB stop responding

Post by stef942 » Fri 03 Aug 2018 8:27 pm

hi, so 1 week later, i use now this hub :

Image

and it's really better but not perfect as i still have some cut around once a day.
My weather station at Ver sur Launette - France (live) : http://stef942.free.fr/CumulusMX/gauges.htm

User avatar
ConligWX
Posts: 736
Joined: Mon 19 May 2014 10:45 pm
Weather Station: Davis Vantage Pro2 Plus
Operating System: MeteoBridge Nano SD
Location: Bangor, NI
Contact:

Re: USB stop responding

Post by ConligWX » Fri 03 Aug 2018 9:42 pm

stef942 wrote:hi, so 1 week later, i use now this hub :

Image

and it's really better but not perfect as i still have some cut around once a day.
and is it powered by mains electric?
Regards Simon

https://www.conligwx.org
https://twitter.com/conligwx
Davis Vantage Pro2 Plus - Meteobrige Nano SD + Saratoga/PWS Templates

water01
Posts: 1486
Joined: Sat 13 Aug 2011 9:33 am
Weather Station: WH1081
Operating System: Windows 7 64bit HP SP1
Location: Somewhere in the USA
Contact:

Re: USB stop responding

Post by water01 » Sat 04 Aug 2018 2:13 am

I can answer for him since I have one yes it is.

stef942
Posts: 15
Joined: Mon 19 Oct 2009 8:17 pm
Weather Station: WMR200
Operating System: raspi3
Location: France-oise

Re: USB stop responding

Post by stef942 » Mon 20 Aug 2018 7:18 am

despite hub, i still have random cuts several times a day :roll:

i have this error in mxdiag report :

Code: Select all

2018-08-20 09:11:08.359 09:11:08 Calling Read
2018-08-20 09:11:08.359 09:11:08 numBytes = 9
2018-08-20 09:11:08.359 09:11:08 01 0B 60 01 00 00 00 00
2018-08-20 09:11:08.359 Data read loop: Array index is out of range.
2018-08-20 09:11:08.359 09:11:08 Calling Read
2018-08-20 09:11:08.359 09:11:08 numBytes = 9
2018-08-20 09:11:08.359 09:11:08 01 09 60 01 00 00 00 00
2018-08-20 09:11:08.360 Data read loop: Array index is out of range.
2018-08-20 09:11:08.360 09:11:08 Calling Read
2018-08-20 09:11:08.360 09:11:08 numBytes = 9
2018-08-20 09:11:08.360 09:11:08 01 14 60 01 00 00 00 00
2018-08-20 09:11:08.360 Data read loop: Array index is out of range.
2018-08-20 09:11:08.361 09:11:08 Calling Read
2018-08-20 09:11:08.361 09:11:08 numBytes = 9
2018-08-20 09:11:08.361 09:11:08 01 08 60 01 00 00 00 00
2018-08-20 09:11:08.361 Data read loop: Array index is out of range.
2018-08-20 09:11:08.361 09:11:08 Calling Read
2018-08-20 09:11:08.361 09:11:08 numBytes = 9
2018-08-20 09:11:08.361 09:11:08 01 12 60 01 00 00 00 00
2018-08-20 09:11:08.362 Data read loop: Array index is out of range.
2018-08-20 09:11:08.362 09:11:08 Calling Read
2018-08-20 09:11:08.362 09:11:08 numBytes = 9
2018-08-20 09:11:08.362 09:11:08 01 00 60 01 00 00 00 00
2018-08-20 09:11:08.362 Data read loop: Array index is out of range.
2018-08-20 09:11:08.362 09:11:08 Calling Read
2018-08-20 09:11:08.362 09:11:08 numBytes = 9
2018-08-20 09:11:08.363 09:11:08 01 E8 60 01 00 00 00 00
2018-08-20 09:11:08.363 Data read loop: Array index is out of range.
2018-08-20 09:11:08.363 09:11:08 Calling Read
2018-08-20 09:11:08.363 09:11:08 numBytes = 9
2018-08-20 09:11:08.363 09:11:08 01 00 60 01 00 00 00 00
2018-08-20 09:11:08.363 Data read loop: Array index is out of range.
2018-08-20 09:11:08.364 09:11:08 Calling Read
2018-08-20 09:11:08.364 09:11:08 numBytes = 9
2018-08-20 09:11:08.364 09:11:08 01 3B 60 01 00 00 00 00
2018-08-20 09:11:08.364 Data read loop: Array index is out of range.
2018-08-20 09:11:08.364 09:11:08 Calling Read
2018-08-20 09:11:08.364 09:11:08 numBytes = 9
2018-08-20 09:11:08.365 09:11:08 01 96 60 01 00 00 00 00
2018-08-20 09:11:08.365 Data read loop: Array index is out of range.
2018-08-20 09:11:08.365 09:11:08 Calling Read
2018-08-20 09:11:08.365 09:11:08 numBytes = 9
2018-08-20 09:11:08.365 09:11:08 01 00 60 01 00 00 00 00
2018-08-20 09:11:08.365 Data read loop: Array index is out of range.
2018-08-20 09:11:08.365 09:11:08 Calling Read
2018-08-20 09:11:08.366 09:11:08 numBytes = 9
2018-08-20 09:11:08.366 09:11:08 01 00 60 01 00 00 00 00
2018-08-20 09:11:08.366 Data read loop: Array index is out of range.
2018-08-20 09:11:08.366 09:11:08 Calling Read
2018-08-20 09:11:08.366 09:11:08 numBytes = 9
2018-08-20 09:11:08.366 09:11:08 01 E2 60 01 00 00 00 00
2018-08-20 09:11:08.366 Data read loop: Array index is out of range.
2018-08-20 09:11:08.367 09:11:08 Calling Read
2018-08-20 09:11:08.367 09:11:08 numBytes = 9
2018-08-20 09:11:08.367 09:11:08 01 02 60 01 00 00 00 00
2018-08-20 09:11:08.367 Data read loop: Array index is out of range.
2018-08-20 09:11:08.367 09:11:08 Calling Read
2018-08-20 09:11:11.367 Data read loop: The operation has timed-out.
etc....
:roll:
My weather station at Ver sur Launette - France (live) : http://stef942.free.fr/CumulusMX/gauges.htm

User avatar
steve
Cumulus Author
Posts: 26714
Joined: Mon 02 Jun 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: USB stop responding

Post by steve » Mon 20 Aug 2018 9:54 am

You'll always get lots of messages of that kind while reading data from this type of station because of the way MX reads the data; they are not indications of a problem and don't help with diagnosing the problem, unfortunately.
Steve

ExperiMentor
Posts: 50
Joined: Tue 24 Nov 2015 11:30 pm
Weather Station: Fine Offset
Operating System: Windows 7; Linux
Location: Switzerland

Re: USB stop responding

Post by ExperiMentor » Tue 21 Aug 2018 8:06 am

I don't have the same equipment, but here are some thoughts.

Can you tell if either the Pi or Weather Station is 'crashing' & rebooting? or do both stay running with failed data collection?

There are suggestions that adding USB hub helps some people. The hub should not do much except ensure that the weather station receives sufficient power all the time (certainly Fine Offset stations take power from the USB port [ie Raspberry Pi] once plugged in, rather than using their internal batteries. And Raspberry Pi's are known to need a sturdy power supply especially if you have powered devices attached to their USB hub. So make sure the Pi's PSU is a good one, especially if you are using a Pi3 or 2 rather than a Pi Zero W.

While on subject of power, have you checked that your weather station has good batteries?

And I see you live in France. Is it rural? Do you suffer the typical French momentary power glitches? You could try adding a USB power pack between the Pi's PSU and the Pi (to act as a UPS - uninterruptible power supply - power pack permanently on charge and available to power the Pi during any glitches).

At least those are the kinds of things I'd be checking up on ...

stef942
Posts: 15
Joined: Mon 19 Oct 2009 8:17 pm
Weather Station: WMR200
Operating System: raspi3
Location: France-oise

Re: USB stop responding

Post by stef942 » Tue 21 Aug 2018 12:32 pm

Hello, thanks for your help

1/ station and pi keep running but data are not send/received, i don't know

2/ the station is powered with adequate power supply and batteries are fine, usb hub is powered too.

3/ typical French momentary power glitches ? :lol:
My weather station at Ver sur Launette - France (live) : http://stef942.free.fr/CumulusMX/gauges.htm

hillyjd
Posts: 26
Joined: Sun 23 Apr 2017 2:42 pm
Weather Station: Davis Vantage Vue
Operating System: Linux

Re: USB stop responding

Post by hillyjd » Sat 25 Aug 2018 2:48 pm

I've been having a similar problem with increasing frequency. CumulusMX locks up and I get this error in the diagnostics file:

System.IO.IOException: Input/output error
at System.IO.Ports.SerialPortStream.ThrowIOException () [0x00000] in <filename unknown>:0
at System.IO.Ports.SerialPortStream.DiscardInBuffer () [0x00000] in <filename unknown>:0
at System.IO.Ports.SerialPort.DiscardInBuffer () [0x00000] in <filename unknown>:0
at (wrapper remoting-invoke-with-check) System.IO.Ports.SerialPort:DiscardInBuffer ()
at CumulusMX.DavisStation.SendLoopCommand (System.IO.Ports.SerialPort serialPort, System.String commandString) [0x00000] in <filename unknown>:0
at CumulusMX.DavisStation.Start () [0x00000] in <filename unknown>:0
at System.Threading.Thread.StartInternal () [0x00000] in <filename unknown>:0
**** An error has occurred - please zip up the MXdiags folder and post it in the forum ****
Press Enter to terminate

Any ideas?

r/
Jim

hillyjd
Posts: 26
Joined: Sun 23 Apr 2017 2:42 pm
Weather Station: Davis Vantage Vue
Operating System: Linux

Re: USB stop responding

Post by hillyjd » Sat 25 Aug 2018 2:53 pm

One other thing I should mention. When Cumulus hangs up and I get the error and I hit "Enter" to terminate the program, it will not restart. When I type in the commands, I get a "Cannot connect to station" error. I must reboot the system entirely to get it to work again. Not sure it's related, but it's a feature.

r/
Jim

User avatar
ConligWX
Posts: 736
Joined: Mon 19 May 2014 10:45 pm
Weather Station: Davis Vantage Pro2 Plus
Operating System: MeteoBridge Nano SD
Location: Bangor, NI
Contact:

Re: USB stop responding

Post by ConligWX » Sun 26 Aug 2018 8:48 am

hillyjd wrote:**** An error has occurred - please zip up the MXdiags folder and post it in the forum ****
Press Enter to terminate

Any ideas?

r/
Jim
Did you attach the MXDiags folder to your post? Sorry but I don't see it.
Regards Simon

https://www.conligwx.org
https://twitter.com/conligwx
Davis Vantage Pro2 Plus - Meteobrige Nano SD + Saratoga/PWS Templates

hillyjd
Posts: 26
Joined: Sun 23 Apr 2017 2:42 pm
Weather Station: Davis Vantage Vue
Operating System: Linux

Re: USB stop responding

Post by hillyjd » Mon 27 Aug 2018 1:33 pm

No, I just posted the error text from the diagnostics. Here's the entire file. This is actually the diagnostic file from latest lockup from yesterday.

r/
Jim
You do not have the required permissions to view the files attached to this post.

Post Reply