Welcome to the new home of the Cumulus Support forum.

Latest Cumulus release v1.9.4 (build 1099) - Nov 28 2014
Latest Cumulus MX release - v3.0.0 build 3043 Jan 20 2017. See the Wiki for download

Monthly High/Low webtags not updating

Discussion of version 3 of Cumulus, which runs on Windows, Linux, and OS X. All Cumulus MX queries in here, please.
forestedge
Posts: 49
Joined: Sun 29 Jul 2012 11:46 am
Weather Station: Davis Vantage Pro2 Plus
Operating System: Windows 10 64 bit
Location: Ashurst Bridge, Hampshire UK
Contact:

Monthly High/Low webtags not updating

Post by forestedge » Tue 06 Feb 2018 7:53 pm

I have noticed that the month highs and lows on the standard Cumulus page on my website do not all change with the new month for some reason.
For the first 3 days of Feb they continued to show all January dates and now show a few Feb figures!

I have not altered the webtags for this page at all, any help appreciated. :)

Here is today's page:

Temperature and Humidity
Highest Temperature 13.3 °C 11:58 on 28 January
Lowest Temperature -4.1 °C 03:15 on 06 February
Highest Dew Point 12.4 °C 22:51 on 02 January
Lowest Dew Point -4.9 °C 03:15 on 06 February
Highest Apparent Temperature 12.5 °C 12:38 on 28 January
Lowest Apparent Temperature -6.6 °C 03:15 on 06 February
Lowest Wind Chill Temperature -4.1 °C 03:15 on 06 February
Highest Heat Index 13.3 °C 11:58 on 28 January
Highest Minimum 10.5 °C 23 January
Lowest Maximum 4.9 °C 09 January
Highest Humidity 99 % 10:25 on 10 January
Lowest Humidity 58 % 14:27 on 01 February
Highest Daily Range 16.1 °C 30 January
Lowest Daily Range 0.9 °C 09 January
Rainfall
Highest Rain Rate 30.6 mm/hr 13:49 on 18 January
Highest Hourly Rainfall 4.8 mm 10:10 on 15 January
Highest Daily Rainfall 13.6 mm 24 January
Longest Dry Period 3 days to 09 January
Longest Wet Period 13 days to 26 January
Wind
Highest Wind Gust 37.0 mph 04:28 on 18 January
Highest Wind Speed 10-minute Average 14.0 mph 03:37 on 18 January
Highest Daily Wind Run 170.4 miles 17 January
Pressure
Lowest Pressure (sl) 990.25 mb 22:49 on 02 January
Highest Pressure (sl) 1032.54 mb 11:13 on 28 January
:now:gauges:today:yesterday:this month::this year::records:monthly records:trends:climate reports:forum::webcam:


Page updated 06/02/2018 19:45:00
powered by Cumulus v

User avatar
steve
Cumulus Author
Posts: 26714
Joined: Mon 02 Jun 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: Monthly High/Low webtags not updating

Post by steve » Tue 06 Feb 2018 7:59 pm

The most likely reason I can think of is that the end of day rollover didn’t take place on Jan 31st, and hence neither did the end of month rollover. Your January NOAA report is missing the 31st, which points to the same cause. Are you allowing the computer to sleep while Cumulus is running? Do you still have the MXdiags file current at the end of January?
Steve

forestedge
Posts: 49
Joined: Sun 29 Jul 2012 11:46 am
Weather Station: Davis Vantage Pro2 Plus
Operating System: Windows 10 64 bit
Location: Ashurst Bridge, Hampshire UK
Contact:

Re: Monthly High/Low webtags not updating

Post by forestedge » Wed 07 Feb 2018 11:14 am

I have checked the data logs and there is no break in the record at end of month but NOAA is a day short as you say! The pc is running 24/7 with no auto updates.

The last diags file was in December 2017. This starts as below with 1.9.4, is this correct?

9/12/2017 14:04:35.285 : Cumulus 1.9.4 Build 1099 startup
09/12/2017 14:04:35.285 : "C:\CumulusMX\cumulus.exe"
09/12/2017 14:04:35.285 : Appdir = C:\CumulusMX\
09/12/2017 14:04:35.285 : Working directory = C:\CumulusMX

User avatar
steve
Cumulus Author
Posts: 26714
Joined: Mon 02 Jun 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: Monthly High/Low webtags not updating

Post by steve » Wed 07 Feb 2018 2:51 pm

The diags files for MX are in a directory named MXdiags
Steve

forestedge
Posts: 49
Joined: Sun 29 Jul 2012 11:46 am
Weather Station: Davis Vantage Pro2 Plus
Operating System: Windows 10 64 bit
Location: Ashurst Bridge, Hampshire UK
Contact:

Re: Monthly High/Low webtags not updating

Post by forestedge » Wed 07 Feb 2018 4:46 pm

Oops! Here is the MX Diags file for Jan.
20180101-182618.zip
You do not have the required permissions to view the files attached to this post.

User avatar
steve
Cumulus Author
Posts: 26714
Joined: Mon 02 Jun 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: Monthly High/Low webtags not updating

Post by steve » Wed 07 Feb 2018 5:06 pm

I can see where it started to do the end of month rollover at 0900 on Feb 1st, but there are no signs of any error messages related to any of the other tasks it should have done at that time. I can’t remember what other messages normally get logged at end of month, but I’m pretty sure there are more than the ones in your log. Any errors that were reported to Cumulus should have been logged, so I can only think that some kind of system error occurred (while writing to a file, for example) which caused the thread to terminate silently.

The easiest way to recover from this, if you want to attempt it, would be to locate the backup files from just before the end of the month, and copy them to the data folder (delete your current February log file). Then start Cumulus and it should download the data from the logger to catch up, and this time hopefully complete the end of month actions. This assumes your logger data goes back far enough.
Steve

forestedge
Posts: 49
Joined: Sun 29 Jul 2012 11:46 am
Weather Station: Davis Vantage Pro2 Plus
Operating System: Windows 10 64 bit
Location: Ashurst Bridge, Hampshire UK
Contact:

Re: Monthly High/Low webtags not updating

Post by forestedge » Wed 07 Feb 2018 5:27 pm

Hi Steve,
Thanks very much for that. I assume you mean just the month and year back up files created on 1/02/18?

User avatar
steve
Cumulus Author
Posts: 26714
Joined: Mon 02 Jun 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: Monthly High/Low webtags not updating

Post by steve » Wed 07 Feb 2018 7:29 pm

All of the files from the backup folder created on 1st Feb at 0900
Steve

forestedge
Posts: 49
Joined: Sun 29 Jul 2012 11:46 am
Weather Station: Davis Vantage Pro2 Plus
Operating System: Windows 10 64 bit
Location: Ashurst Bridge, Hampshire UK
Contact:

Re: Monthly High/Low webtags not updating

Post by forestedge » Wed 07 Feb 2018 8:48 pm

I copied the data files and deleted the Feb log file. Reconnected Cumulus ok and downloaded but nothing seems to have changed :(

User avatar
steve
Cumulus Author
Posts: 26714
Joined: Mon 02 Jun 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: Monthly High/Low webtags not updating

Post by steve » Thu 08 Feb 2018 8:23 am

The MXdiags file from that run should show what happened.
Steve

forestedge
Posts: 49
Joined: Sun 29 Jul 2012 11:46 am
Weather Station: Davis Vantage Pro2 Plus
Operating System: Windows 10 64 bit
Location: Ashurst Bridge, Hampshire UK
Contact:

Re: Monthly High/Low webtags not updating

Post by forestedge » Thu 08 Feb 2018 3:45 pm

Here is the MXdiags from the restart last night.
20180207-193938.zip
You do not have the required permissions to view the files attached to this post.

richard_newberry
Posts: 283
Joined: Tue 12 Apr 2011 10:23 pm
Weather Station: Watson W-8186
Operating System: Debian Stretch (VMWARE Esxi 6.5)
Location: Leicester
Contact:

Re: Monthly High/Low webtags not updating

Post by richard_newberry » Thu 08 Feb 2018 6:08 pm

mine missed out 31st January to. i think CumulusMX do 1 days ago on NOAA reports but if it does 30th of january when its 31st january it wouldnt record 31st january when its the next month February. is this a bug or is it what steve created?
Desford Weather
http://www.desford-weather.co.uk
http://desford-weather.co.uk
Also on Desford weather underground.
Looking forward to cumulus on Linux platform it'll rock!!

User avatar
steve
Cumulus Author
Posts: 26714
Joined: Mon 02 Jun 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: Monthly High/Low webtags not updating

Post by steve » Thu 08 Feb 2018 6:38 pm

forestedge wrote:Here is the MXdiags from the restart last night.
20180207-193938.zip
That has a previous closedown time stamp of 1730 on 1st Feb, so it looks like you used the wrong backup set, that one is after the end of month rollover at 0900, it needs to be the one from 0900 from the daily backups.
Steve

forestedge
Posts: 49
Joined: Sun 29 Jul 2012 11:46 am
Weather Station: Davis Vantage Pro2 Plus
Operating System: Windows 10 64 bit
Location: Ashurst Bridge, Hampshire UK
Contact:

Re: Monthly High/Low webtags not updating

Post by forestedge » Thu 08 Feb 2018 8:04 pm

There does not appear to be a daily backup. There is this one from 1st Feb and the previous one is dated 1st Jan.
20180201175126.zip
You do not have the required permissions to view the files attached to this post.

User avatar
steve
Cumulus Author
Posts: 26714
Joined: Mon 02 Jun 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: Monthly High/Low webtags not updating

Post by steve » Thu 08 Feb 2018 9:06 pm

It’s possible that it didn’t manage to take a daily backup due to whatever the failure was (but I think it’s the first thing it does). But there should at least be one from the day before. What files do you have in the backup\daily folder?

The folder you’ve attached is not a daily backup, so presumably it didn’t come from the backup\daily folder.
Steve

Post Reply