Welcome to the new home of the Cumulus Support forum.

Latest Cumulus release v1.9.4 (build 1099) - Nov 28 2014
Latest Cumulus MX release - v3.0.0 build 3044 7 December 2018. See the Wiki for download

CumulusMX dist.3043 mono 4.6.2.7+dfsg-1 no work

Discussion of version 3 of Cumulus, which runs on Windows, Linux, and OS X. All Cumulus MX queries in here, please.

Moderator: mcrossley

Post Reply
paologambal
Posts: 3
Joined: Mon 15 Jan 2018 9:27 pm
Weather Station: oregon wmr928
Operating System: raspian raspberry p2

CumulusMX dist.3043 mono 4.6.2.7+dfsg-1 no work

Post by paologambal » Tue 30 Jan 2018 9:06 pm

I installed CumulusMx dist.3043 but when I start it with mono not work.I attach log of MXdiags.Thanks.
You do not have the required permissions to view the files attached to this post.

User avatar
steve
Cumulus Author
Posts: 26714
Joined: Mon 02 Jun 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: CumulusMX dist.3043 mono 4.6.2.7+dfsg-1 no work

Post by steve » Tue 30 Jan 2018 9:17 pm

You have told it to use port 8002 for the web interface, so when it tries to open the web socket port, which is 8002, the system correctly says that port is already in use.
Steve

paologambal
Posts: 3
Joined: Mon 15 Jan 2018 9:27 pm
Weather Station: oregon wmr928
Operating System: raspian raspberry p2

Re: CumulusMX dist.3043 mono 4.6.2.7+dfsg-1 no work

Post by paologambal » Wed 31 Jan 2018 11:53 am

I apologize, but I cannot understand:as never part the program of CumulusMx with mono before you connect to the web?What am I doing wrong?After CumulusMx launched is right that to see the station on the monitor should I charge http://IP_del_raspberry:8002?.I attack file txt when I launch CumulusMX.Thanks for the collaboration.
You do not have the required permissions to view the files attached to this post.

User avatar
steve
Cumulus Author
Posts: 26714
Joined: Mon 02 Jun 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: CumulusMX dist.3043 mono 4.6.2.7+dfsg-1 no work

Post by steve » Wed 31 Jan 2018 12:39 pm

You are telling Cumulus to use port 8002 for its user interface when you start it, by supplying the port parameter

Command line: /home/pi/Scaricati/CumulusMX/CumulusMX.exe -port 8002

I have no idea why you are doing this, it can never work because port 8002 is used for the gauges etc to read their data using the ‘web sockets’ protocol.

The default port for the user interface is 8998 and this rarely needs to be changed.
Steve

paologambal
Posts: 3
Joined: Mon 15 Jan 2018 9:27 pm
Weather Station: oregon wmr928
Operating System: raspian raspberry p2

Re: CumulusMX dist.3043 mono 4.6.2.7+dfsg-1 no work

Post by paologambal » Wed 31 Jan 2018 9:31 pm

I apologize again; I can explain myself better: I used the port 8002 because i can't get with the port 8998 as from txt file that I enclose.
Ports on my router are loaded.What can I do?.Thanks again .
You do not have the required permissions to view the files attached to this post.

User avatar
steve
Cumulus Author
Posts: 26714
Joined: Mon 02 Jun 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: CumulusMX dist.3043 mono 4.6.2.7+dfsg-1 no work

Post by steve » Wed 31 Jan 2018 9:41 pm

If you can’t get the MX display to appear in a browser on a PC on the same network using the IP address of the raspberry pi and port 8998 (I.e. http://a.b.c.d:8998) then you have some kind of firewall issue and using a different port number won’t help and you have just been wasting your time and mine.
Steve

Post Reply