Welcome to the new home of the Cumulus Support forum.

Latest Cumulus release v1.9.4 (build 1099) - Nov 28 2014
Latest Cumulus MX release - v3.0.0 build 3044 7 December 2018. See the Wiki for download

New issue with updated file not reflecting on webpage (solved)

Discussion of version 3 of Cumulus, which runs on Windows, Linux, and OS X. All Cumulus MX queries in here, please.

Moderator: mcrossley

Post Reply
dilly
Posts: 3
Joined: Tue 22 Jul 2014 8:50 pm
Weather Station: Davis Pro 2
Operating System: Win 7
Location: USA

New issue with updated file not reflecting on webpage (solved)

Post by dilly » Tue 23 Jan 2018 3:17 pm

Hi everyone,

I noticed today that it appears my webpage upload of realtime.txt data isnt updating. Still seeing Dec 29 data on the webpage.

Using CumulusMX 3043 on a Rasp Pi3
website is particularlynastyweather.com

I can log into my ftp and upload files without issue so I am thinking it is something else maybe. This same Cumulus setup has worked for a long time (up until 29DEC17 that is).

when I look at particularynastyweather.com/realtime.txt I am seeing the 29DEC data. Any ideas?
Do you think it is an uploading issue or is Cumulus not generating a new updated realtime.txt file?
Or something else I am missing. Uploads to WeatherUnderground of current data is working so my thought is it was an FTP issue

I have a number of .json files when looking at the server side via ftp that appear to have not been updated since on this same 29DEC17 date (dailytemp.json, sunhours.json, dailyrai.json, etc.).

Open to any ideas or paths to troubleshoot you might have. Accessing the Cumulus GUI appears to work just fine and is showing updated current conditions.

Thanks so much!
Last edited by dilly on Tue 23 Jan 2018 4:14 pm, edited 1 time in total.

User avatar
steve
Cumulus Author
Posts: 26714
Joined: Mon 02 Jun 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: New issue with updated file not reflecting on webpage

Post by steve » Tue 23 Jan 2018 3:21 pm

Turn on ftp logging and see if the ftplog.txt file has any obvious problems logged.
Steve

dilly
Posts: 3
Joined: Tue 22 Jul 2014 8:50 pm
Weather Station: Davis Pro 2
Operating System: Win 7
Location: USA

Re: New issue with updated file not reflecting on webpage

Post by dilly » Tue 23 Jan 2018 3:29 pm

Thanks Steve. Was going to add the logfile but have been unsuccessfully trying to make it even somewhat readable the last 30 minutes. I will attach it.

Seems to be an umber of "No such file or directory" issues. But I am not sure how to correct. As I said it has worked for a long time without my intervention
Last edited by dilly on Tue 23 Jan 2018 3:59 pm, edited 1 time in total.

User avatar
steve
Cumulus Author
Posts: 26714
Joined: Mon 02 Jun 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: New issue with updated file not reflecting on webpage

Post by steve » Tue 23 Jan 2018 3:39 pm

Those “no such file” messages can be ignored. You are using active ftp mode, normally passive (the default) is better. Perhaps something changed somewhere (a firewall somewhere) such that active mode no longer works for you.
Steve

dilly
Posts: 3
Joined: Tue 22 Jul 2014 8:50 pm
Weather Station: Davis Pro 2
Operating System: Win 7
Location: USA

Re: New issue with updated file not reflecting on webpage

Post by dilly » Tue 23 Jan 2018 3:43 pm

Yes! Just got pfsense going as my router/firewall. So that is likely exactly the issue.

Let me see if turning off active ftp mode helps...

Yes! that took care of it. Thanks Steve for your help!

Post Reply