Welcome to the new home of the Cumulus Support forum.

Latest Cumulus release v1.9.4 (build 1099) - Nov 28 2014
Latest Cumulus MX release - v3.0.0 build 3044 7 December 2018. See the Wiki for download

RealtimeGaugesTxtFTP bug

Discussion of version 3 of Cumulus, which runs on Windows, Linux, and OS X. All Cumulus MX queries in here, please.

Moderator: mcrossley

Post Reply
User avatar
Mapantz
Posts: 525
Joined: Sat 17 Dec 2011 11:55 am
Weather Station: Davis Vantage Pro2
Operating System: Windows 10 x64 - A beast.
Location: Wareham, Dorset - UK
Contact:

RealtimeGaugesTxtFTP bug

Post by Mapantz » Sat 13 Jan 2018 10:52 pm

I've just noticed, whenever I change a setting in "Internet settings" and click save, RealtimeGaugesTxtFTP changes to 0. I have to close CMX, change it back to 1 and start CMX, then the gauges start working again.
Image
Image

jnstllng
Posts: 14
Joined: Sun 15 Jan 2017 10:10 pm
Weather Station: WH1080
Operating System: Raspian, Windows 7, Windows 10

Re: RealtimeGaugesTxtFTP bug

Post by jnstllng » Sun 14 Jan 2018 12:02 pm

I also came across this. It also happens that RealtimeGaugesTxtFTP is set automatically to 0 whenever I restart and in the same moment I am looking at localhost:8998 in a web browser.

User avatar
steve
Cumulus Author
Posts: 26714
Joined: Mon 02 Jun 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: RealtimeGaugesTxtFTP bug

Post by steve » Fri 19 Jan 2018 8:31 pm

I can't reproduce this with the latest code. It's possible that I have fixed it since build 3043, but diff is not showing up any changes that would affect this. I'd have thought that lots of people would have reported this problem if it was a straightforward bug in MX.

Did you update these files from build 3042 or 3043:

interface/json/InternetOptions.json
interface/json/InternetSchema.json
Steve

User avatar
ConligWX
Posts: 736
Joined: Mon 19 May 2014 10:45 pm
Weather Station: Davis Vantage Pro2 Plus
Operating System: MeteoBridge Nano SD
Location: Bangor, NI
Contact:

Re: RealtimeGaugesTxtFTP bug

Post by ConligWX » Fri 19 Jan 2018 9:53 pm

checked on mine, and that value never changes so cannot replicate it at all.
Regards Simon

https://www.conligwx.org
https://twitter.com/conligwx
Davis Vantage Pro2 Plus - Meteobrige Nano SD + Saratoga/PWS Templates

User avatar
Mapantz
Posts: 525
Joined: Sat 17 Dec 2011 11:55 am
Weather Station: Davis Vantage Pro2
Operating System: Windows 10 x64 - A beast.
Location: Wareham, Dorset - UK
Contact:

Re: RealtimeGaugesTxtFTP bug

Post by Mapantz » Sat 27 Jan 2018 4:14 pm

Hi

Just saw the replies, I do apologise.

Yes Steve, I have those files up to date, but it still does it. I literally have to change one setting ie untick a box and click save, and then RealtimeGaugesTxtFTP becomes 0.

Weird, I know.
Image
Image

User avatar
steve
Cumulus Author
Posts: 26714
Joined: Mon 02 Jun 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: RealtimeGaugesTxtFTP bug

Post by steve » Sat 27 Jan 2018 4:29 pm

What does the realtimegauges ftp setting in the MX interface look like before and after you make the change?
Steve

Post Reply