Welcome to the new home of the Cumulus Support forum.

Latest Cumulus release v1.9.4 (build 1099) - Nov 28 2014
Latest Cumulus MX release - v3.0.0 build 3043 Jan 20 2017. See the Wiki for download

<#CurrentSolarMax> error?

Discussion of version 3 of Cumulus, which runs on Windows, Linux, and OS X. All Cumulus MX queries in here, please.
Post Reply
philpugh
Posts: 123
Joined: Tue 24 May 2011 8:34 am
Weather Station: DAVIS VantageVue
Operating System: Debian Jessie
Location: Antrobus, Cheshire
Contact:

<#CurrentSolarMax> error?

Post by philpugh » Sat 25 Nov 2017 4:18 pm

Running CMX 3043 under Debian.

Just noticed that the webtag <#CurrentSolarMax> seems to be returning 0 all the time.

I don't know when this started happening. Tried reboot - same issue.

Other webtags seem ok.

Internal calculation for solar radiation is working as it is showing the correct looking curve and times on the Dashboard graphs for solar.

Anyone else having the same issue?

Thanks
Phil Pugh
Davis Vantage Vue Raspberry Pi 2B Stretch-Lite MySQL 128Gb SSD
http://goosegate.plus.com/

User avatar
steve
Cumulus Author
Posts: 26714
Joined: Mon 02 Jun 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: <#CurrentSolarMax> error?

Post by steve » Sat 25 Nov 2017 4:33 pm

To clarify - do you mean that it is apparently calculating the theoretical max correctly but it’s just the web tag that isn’t getting the value put into it? Any error messages in the diags file which look related?
Steve

philpugh
Posts: 123
Joined: Tue 24 May 2011 8:34 am
Weather Station: DAVIS VantageVue
Operating System: Debian Jessie
Location: Antrobus, Cheshire
Contact:

Re: <#CurrentSolarMax> error?

Post by philpugh » Sun 26 Nov 2017 9:54 am

Steve,

That is correct - the theoretical value is being calculated but the webtag is returning 0.

The normal diagnostic file is not showing anything. I'll turn on debug for a while and take a look.
Phil Pugh
Davis Vantage Vue Raspberry Pi 2B Stretch-Lite MySQL 128Gb SSD
http://goosegate.plus.com/

User avatar
mcrossley
Posts: 5209
Joined: Thu 07 Jan 2010 9:44 pm
Weather Station: Davis VP2
Operating System: Stretch Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: <#CurrentSolarMax> error?

Post by mcrossley » Sun 26 Nov 2017 10:31 am

The tag is still working for me Phil.

User avatar
Mapantz
Posts: 520
Joined: Sat 17 Dec 2011 11:55 am
Weather Station: Davis Vantage Pro2
Operating System: Windows 10 x64 - A beast.
Location: Wareham, Dorset - UK
Contact:

Re: <#CurrentSolarMax> error?

Post by Mapantz » Sun 26 Nov 2017 12:46 pm

I decided to check this out, and it's working fine for me too.

Do you have a valid number set for transmission factor in the solar settings? ie mine is set to 0.86
Image
Image

User avatar
steve
Cumulus Author
Posts: 26714
Joined: Mon 02 Jun 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: <#CurrentSolarMax> error?

Post by steve » Sun 26 Nov 2017 2:22 pm

I see that you have a non-zero value showing on your web site at the moment, so presumably you fixed the problem or it just went away?
Steve

philpugh
Posts: 123
Joined: Tue 24 May 2011 8:34 am
Weather Station: DAVIS VantageVue
Operating System: Debian Jessie
Location: Antrobus, Cheshire
Contact:

Re: <#CurrentSolarMax> error?

Post by philpugh » Mon 27 Nov 2017 3:22 pm

Sorry - thought I had posted a reply yesterday :oops:

On a second reboot - it came back working!

Been 0 for about 8 days according to MySQL database. Will keep an eye on it.
Phil Pugh
Davis Vantage Vue Raspberry Pi 2B Stretch-Lite MySQL 128Gb SSD
http://goosegate.plus.com/

Post Reply