Welcome to the new home of the Cumulus Support forum.

Latest Cumulus release v1.9.4 (build 1099) - Nov 28 2014
Latest Cumulus MX release - v3.0.0 build 3043 Jan 20 2017. See the Wiki for download

cumulusmx lost contact to weatherstation

Discussion of version 3 of Cumulus, which runs on Windows, Linux, and OS X. All Cumulus MX queries in here, please.
Post Reply
maddinthebrain
Posts: 33
Joined: Mon 07 Aug 2017 12:15 pm
Weather Station: WH1080
Operating System: Raspbian Jessie

cumulusmx lost contact to weatherstation

Post by maddinthebrain » Fri 01 Sep 2017 8:49 pm

Help!

CumulusMX lost contact to my WH1080. Before it work perfectly for 2 weeks. Suddently the reading from the station stopped and the last read value was uploaded for days. I was on holiday. A restart of the raspi ended with that there are not any value is read and uploaded. How can I find out what is the problem? Btw. with win7 and Cumulus 1 it works normally, but it is not my prefered solution...

Thanks in advance.

User avatar
ConligWX
Posts: 728
Joined: Mon 19 May 2014 10:45 pm
Weather Station: Davis Vantage Pro2 Plus
Operating System: Debian 9.5 Stretch
Location: Bangor, NI
Contact:

Re: cumulusmx lost contact to weatherstation

Post by ConligWX » Fri 01 Sep 2017 8:57 pm

zip your mxdiags folder up and post your zip file here. Steve or one of the gurus can then take a look.
Regards Simon

https://www.conligwx.org
https://twitter.com/conligwx
Davis Vantage Pro2 Plus - CumulusMX v3.0.0 (build 3043) + Saratoga/PWS Templates

maddinthebrain
Posts: 33
Joined: Mon 07 Aug 2017 12:15 pm
Weather Station: WH1080
Operating System: Raspbian Jessie

Re: cumulusmx lost contact to weatherstation

Post by maddinthebrain » Sat 02 Sep 2017 6:58 am

OK, here it is. Its some kind of weird. On August, 27th the station wasn't found. Later on it was but it still doesn't work...
You do not have the required permissions to view the files attached to this post.

User avatar
steve
Cumulus Author
Posts: 26714
Joined: Mon 02 Jun 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: cumulusmx lost contact to weatherstation

Post by steve » Sat 02 Sep 2017 8:19 am

Yes, it looks a bit odd, You have had issues with reading data from the station, but it also seems to be reading logger data sometimes but it's not processing it for some reason. I'm on my iPad so it's not easy to look in detail, but I'll try to have a look again the next time I'm on my PC. Someone else may be able to spot what's going on in the meanwhile.
Steve

User avatar
ConligWX
Posts: 728
Joined: Mon 19 May 2014 10:45 pm
Weather Station: Davis Vantage Pro2 Plus
Operating System: Debian 9.5 Stretch
Location: Bangor, NI
Contact:

Re: cumulusmx lost contact to weatherstation

Post by ConligWX » Sat 02 Sep 2017 8:21 am

firstly your ftp connection to your web server is being refused

Code: Select all

2017-09-01 22:29:55.328 Error connecting ftp - Connection refused
2017-09-01 22:29:59.787 Error uploading web/realtimegauges.txt to realtimegauges.txt : Connection refused
2017-09-01 22:30:25.137 Error connecting ftp - Connection refused
2017-09-01 22:30:25.192 Error uploading web/realtimegauges.txt to realtimegauges.txt : Connection refused
2017-09-01 22:30:55.711 Error connecting ftp - Connection refused
2017-09-01 22:30:55.787 Error uploading web/realtimegauges.txt to realtimegauges.txt : Connection refused
2017-09-01 22:31:25.137 Error connecting ftp - Connection refused
2017-09-01 22:31:25.185 Error uploading web/realtimegauges.txt to realtimegauges.txt : Connection refused
2017-09-01 22:31:54.914 Error connecting ftp - Connection refused
2017-09-01 22:31:56.270 Error uploading web/realtimegauges.txt to realtimegauges.txt : Connection refused
2017-09-01 22:32:25.143 Error connecting ftp - Connection refused
2017-09-01 22:32:25.195 Error uploading web/realtimegauges.txt to realtimegauges.txt : Connection refused
2017-09-01 22:32:32.875 Cumulus closing
are you using passive of active ftp perhaps? SFTP or FTP or password perhaps? can you ftp into you web server yourself using an ftp client?

also noticed a file misssing:

Code: Select all

2017-09-01 22:09:27.365 System.IO.FileNotFoundException: Could not find file "/home/pi/CumulusMX/data/Sep17log.txt".
File name: '/home/pi/CumulusMX/data/Sep17log.txt'
the other thing is your using Mono version: 4.0.2 (Debian 4.0.2.5+dfsg-2~rpi1) on a WH1080 afaik this can cause issues and is recommeneded you downgrad the version of mono to 3.x (i think) plenty of talk about that here on the forums with Fine Offset Weatherstations
Regards Simon

https://www.conligwx.org
https://twitter.com/conligwx
Davis Vantage Pro2 Plus - CumulusMX v3.0.0 (build 3043) + Saratoga/PWS Templates

maddinthebrain
Posts: 33
Joined: Mon 07 Aug 2017 12:15 pm
Weather Station: WH1080
Operating System: Raspbian Jessie

Re: cumulusmx lost contact to weatherstation

Post by maddinthebrain » Sat 02 Sep 2017 8:50 am

I don't use the ftp at the moment as there is no need to. It is not configured.

I tried the Mono 3.1.8 version at the beginning, but without success. There was an issue with the language. I don'tknow what was the problem exactly why it didn't work. With Mono 4 there where no problems. Installed it and cumulusmx ran fine until now...

maddinthebrain
Posts: 33
Joined: Mon 07 Aug 2017 12:15 pm
Weather Station: WH1080
Operating System: Raspbian Jessie

Re: cumulusmx lost contact to weatherstation

Post by maddinthebrain » Sat 02 Sep 2017 9:18 am

Ok it works now again. It was because of Sep17log.txt missing! I created an empty file and it returned working. But why it was not created automatically?

Cheers Martin

User avatar
steve
Cumulus Author
Posts: 26714
Joined: Mon 02 Jun 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: cumulusmx lost contact to weatherstation

Post by steve » Sat 02 Sep 2017 2:33 pm

maddinthebrain wrote:I don't use the ftp at the moment as there is no need to. It is not configured.
Turn off the realtimegauges.txt upload, it is unintentionally set by default.
Steve

User avatar
steve
Cumulus Author
Posts: 26714
Joined: Mon 02 Jun 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: cumulusmx lost contact to weatherstation

Post by steve » Sat 02 Sep 2017 2:34 pm

maddinthebrain wrote:Ok it works now again. It was because of Sep17log.txt missing! I created an empty file and it returned working. But why it was not created automatically?

Cheers Martin
I don't know, normally it would be.
Steve

Post Reply