Welcome to the new home of the Cumulus Support forum.

Latest Cumulus release v1.9.4 (build 1099) - Nov 28 2014
Latest Cumulus MX release - v3.0.0 build 3043 Jan 20 2017. See the Wiki for download

WMR200 station not found!

Discussion of version 3 of Cumulus, which runs on Windows, Linux, and OS X. All Cumulus MX queries in here, please.
richard_newberry
Posts: 283
Joined: Tue 12 Apr 2011 10:23 pm
Weather Station: Watson W-8186
Operating System: Debian Stretch (VMWARE Esxi 6.5)
Location: Leicester
Contact:

Re: WMR200 station not found!

Post by richard_newberry » Sat 02 Jan 2016 7:34 pm

Does any of these work?

sudo updatedb
sudo apt-get autoclean
sudo apt-get clean
Desford Weather
http://www.desford-weather.co.uk
http://desford-weather.co.uk
Also on Desford weather underground.
Looking forward to cumulus on Linux platform it'll rock!!

WetCoast
Posts: 21
Joined: Tue 12 May 2015 6:00 am
Weather Station: WS-2095
Operating System: Vista (Debian Linux)
Location: Surrey, BC, Canada

Re: WMR200 station not found!

Post by WetCoast » Sat 02 Jan 2016 7:56 pm

All those commands work, no errors, but I still seem to have mono version 4.2.1 installed.

Perhaps I'll try Steve's advice and remove all of mono... all 155 packages... wish me luck!! :shock:

WetCoast
Posts: 21
Joined: Tue 12 May 2015 6:00 am
Weather Station: WS-2095
Operating System: Vista (Debian Linux)
Location: Surrey, BC, Canada

Re: WMR200 station not found!

Post by WetCoast » Sat 02 Jan 2016 9:15 pm

Good news and bad news...
first the good news,
after much fighting I've managed to get this:
Mono JIT compiler version 4.0.5 (Stable 4.0.5.1/1d8d582 Thu Nov 12 12:03:50 UTC 2015)

now the bad news,
When I try to run mono CumulusMX.exe I get:
[ERROR] FATAL UNHANDLED EXCEPTION: System.TypeInitializationException: An exception was thrown by the type initializer for CumulusMX.Cumulus ---> System.TypeLoadException: Could not load type 'System.Net.Http.HttpClientHandler' from assembly 'System.Net.Http, Version=1.5.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a'.
--- End of inner exception stack trace ---
at .Main (System.String[] args) [0x00000] in <filename unknown>:0

I suspect that I don't have part of mono installed correctly but if I try to install mono-complete I end up in "dependency hell". For some strange reason it keeps saying there are dependencies, but when I satisfy that dependency it show more dependencies for the dependent, ETC...

Any suggestions?

WetCoast
Posts: 21
Joined: Tue 12 May 2015 6:00 am
Weather Station: WS-2095
Operating System: Vista (Debian Linux)
Location: Surrey, BC, Canada

Re: WMR200 station not found!

Post by WetCoast » Sat 02 Jan 2016 11:49 pm

I can't seem to beat it into submission... I can not seem to get the older version on mono completely installed. It keeps complaining about dependencies and even if I try manually to install the dependencies (there are a LOT and I have no idea why it's forcing me to do that) it still seems to install, at some point, the 4.2.1 version of mono, or some of that version's dependent files.

Is there any estimate as to when CumulusMX will work with mono version 4.2.1 and the Fine Offset station?

User avatar
steve
Cumulus Author
Posts: 26714
Joined: Mon 02 Jun 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: WMR200 station not found!

Post by steve » Sun 03 Jan 2016 9:19 am

WetCoast wrote:Is there any estimate as to when CumulusMX will work with mono version 4.2.1 and the Fine Offset station?
I'm afraid I don't know; I need to find time to install it myself and investigate. I'll see if I can do it later today. I'm still not sure I know how to install 4.2.1 on Raspbian Jessie. I get 3.2.8 by default, and it's currently running 4.0.2 with

deb http://plugwash.raspbian.org/mono4 jessie-mono4 main


added to /etc/apt/sources.list
Steve

richard_newberry
Posts: 283
Joined: Tue 12 Apr 2011 10:23 pm
Weather Station: Watson W-8186
Operating System: Debian Stretch (VMWARE Esxi 6.5)
Location: Leicester
Contact:

Re: WMR200 station not found!

Post by richard_newberry » Sun 03 Jan 2016 12:00 pm

If mono 3.2.8 works, why do you need to update it?

Debian packages are updated for security fixes. Shouldn't need updating unless Steve says it needs to be updated.

'If it isn't broke dont touch it.' As the saying goes been a IT Technician for 15 years now. My mate taught me Debian in an evening. Updating packages and then downgrading is a bad idea, can stop other packages from working.
Desford Weather
http://www.desford-weather.co.uk
http://desford-weather.co.uk
Also on Desford weather underground.
Looking forward to cumulus on Linux platform it'll rock!!

User avatar
frankben
Posts: 13
Joined: Thu 07 May 2015 7:03 pm
Weather Station: Oregon WMR 200
Operating System: win 7
Location: Maarkedal - Belgium
Contact:

Re: WMR200 station not found!

Post by frankben » Sun 03 Jan 2016 2:25 pm

Hi,

I had the same problem with latest mono version.

I uninstalled it en then I followd this procedure: https://neildanson.wordpress.com/2013/1 ... ard-float/

follow procedure to line 6, I did not do 7 and the rest, then all was working fine

I have now mono version 4.0.5

I relay do hope the fix this problem in the next version! It is always disappointing when you have to downgrade a version :(

User avatar
steve
Cumulus Author
Posts: 26714
Joined: Mon 02 Jun 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: WMR200 station not found!

Post by steve » Sun 03 Jan 2016 2:47 pm

frankben wrote:I relay do hope the fix this problem in the next version! It is always disappointing when you have to downgrade a version :(
It's not clear where the problem is, it may not actually be a bug in mono. I will need to investigate, but as I said above, it's not at all clear to me what the official upgrade path is that causes 4.2.1 to be installed.
Steve

richard_newberry
Posts: 283
Joined: Tue 12 Apr 2011 10:23 pm
Weather Station: Watson W-8186
Operating System: Debian Stretch (VMWARE Esxi 6.5)
Location: Leicester
Contact:

Re: WMR200 station not found!

Post by richard_newberry » Sun 03 Jan 2016 2:56 pm

Why is it essential to upgrade to the latest mono?

I dont understand what benefits itll be.
Desford Weather
http://www.desford-weather.co.uk
http://desford-weather.co.uk
Also on Desford weather underground.
Looking forward to cumulus on Linux platform it'll rock!!

water01
Posts: 1477
Joined: Sat 13 Aug 2011 9:33 am
Weather Station: WH1081
Operating System: Windows 7 64bit HP SP1
Location: Somewhere in the USA
Contact:

Re: WMR200 station not found!

Post by water01 » Sun 03 Jan 2016 4:26 pm

You don't have to since you are in the UK but the problem with the locales that use the comma as the decimal delimiter was supposed to have been fixed in the later versions, but they also appear to have broken something else at the same time.

User avatar
frankben
Posts: 13
Joined: Thu 07 May 2015 7:03 pm
Weather Station: Oregon WMR 200
Operating System: win 7
Location: Maarkedal - Belgium
Contact:

Re: WMR200 station not found!

Post by frankben » Sun 03 Jan 2016 6:10 pm

Why is it essential to upgrade to the latest mono?
Hi richard_newberry

I think updates are there to improve the software and system running. For me It's always disappointing when updates don't do any more what the previous version was doing so well.

But as Steve mentioned we have to be patient so they can figure it out where the problem is.

My PI 2 is running great for the moment with CmX but I ordered a second PI 2 just to experiment with it. I also ordered two Rasclock Pi Real Time Clock Module V4.0, just to be sure the time is always right.

Solutions will come! ;)

Nice to meet you guy's

Frank

stars
Posts: 1
Joined: Tue 10 Jun 2014 7:47 pm
Weather Station: WMR200
Operating System: Windows XP pro
Location: Styrsö

Re: WMR200 station not found!

Post by stars » Wed 27 Apr 2016 8:18 pm

Hi, I got my Raspberry PI 3 B 3 days ago and the learning curve
have been pretty steep. But I have got it working now....

Downloaded the NOOBS file an unzipped it and
copied the files to a SD-card (16GB, Class 10). Which had the FAT32 format.

Installed the Raspian OS.
After some time I understood that the MONO run-times was needed.
And that I had to get used to a so called (DOS) environment.

My weather station is a WMR 200 with usb connection.
So when I got MONO V4.2.x the weather station was not recognized.
How to downgrade to an earlier MONO version ???
Finally I got hold of this info. May bee not big news but it worked very fine.
---------------------
First Mono needs to be completely removed from the system which is done by running the following commands.

sudo apt-get remove mono-complete
sudo apt-get purge mono-complete
sudo apt-get autoremove

Then update the source list with the version you wish to install by running the following command (replace x.x.x of the code snippet below with the version number you wish to install - in my case it was 4.0.5).

echo "deb http://download.mono-project.com/repo/debian wheezy/snapshots/x.x.x main" | sudo tee /etc/apt/sources.list.d/mono-xamarin.list

Finally run update and install the mono packages as shown below.

sudo apt-get update
sudo apt-get install mono-devel
sudo apt-get install mono-complete

Hope this helps...
cheers stars ;)

harrym1byt
Posts: 260
Joined: Fri 15 Aug 2008 5:22 pm
Weather Station: WH 1081 (EasyWeather type)
Location: Garforth, W. Yorks, UK
Contact:

Re: WMR200 station not found!

Post by harrym1byt » Tue 03 Jul 2018 8:45 pm

Could someone please give me a few clues how to download mono, to work with a FO USB station?

I am struggling to make sense of the download process on the R Pi, in particular, this bit...

"Then update the source list with the version you wish to install by running the following command (replace x.x.x of the code snippet below with the version number you wish to install - in my case it was 4.0.5).

echo "deb http://download.mono-project.com/repo/debian wheezy/snapshots/x.x.x main" | sudo tee /etc/apt/sources.list.d/mono-xamarin.list

Finally run update and install the mono packages as shown below."

User avatar
ConligWX
Posts: 728
Joined: Mon 19 May 2014 10:45 pm
Weather Station: Davis Vantage Pro2 Plus
Operating System: Debian 9.5 Stretch
Location: Bangor, NI
Contact:

Re: WMR200 station not found!

Post by ConligWX » Wed 04 Jul 2018 8:03 am

harrym1byt wrote:Could someone please give me a few clues how to download mono, to work with a FO USB station?

I am struggling to make sense of the download process on the R Pi, in particular, this bit...

"Then update the source list with the version you wish to install by running the following command (replace x.x.x of the code snippet below with the version number you wish to install - in my case it was 4.0.5).

echo "deb http://download.mono-project.com/repo/debian wheezy/snapshots/x.x.x main" | sudo tee /etc/apt/sources.list.d/mono-xamarin.list

Finally run update and install the mono packages as shown below."
I maybe mistaken however pretty sure that Mono for FO stations needs to be no higher than version 3.x and has been mentioned numerous times on these forums. you will need to point your sources.list to an older mono distro afaik. then you run apt-get update and apt-get upgrade to install the correct one. whatever version of Mono you have at present should be uninstalled first of all.

you may want to look at "other" threads since this was initially for the Oregon Scientific WMR200 and not Fine OffSet stations.
Regards Simon

https://www.conligwx.org
https://twitter.com/conligwx
Davis Vantage Pro2 Plus - CumulusMX v3.0.0 (build 3043) + Saratoga/PWS Templates

harrym1byt
Posts: 260
Joined: Fri 15 Aug 2008 5:22 pm
Weather Station: WH 1081 (EasyWeather type)
Location: Garforth, W. Yorks, UK
Contact:

Re: WMR200 station not found!

Post by harrym1byt » Wed 04 Jul 2018 7:58 pm

I am very new to the Pi and to Linux, but so far I have managed to get my Pi working, installed CMX on it, got that working, plus can access the Pi from my laptop using VMC and can get CMX working, can browse its web page. I am just stuck at the moment, with the Pi not seeming to connect to the stations usb...

I have also worked out how to remove the latest mono, where I am struggling is finding an older copy of mono and maybe the instruction as to how to install it, when I do manage to get hold of a suitable version.

Post Reply