Welcome to the Cumulus Support forum.

Latest Cumulus MX release v3.2.0 build 3056 - 19 November 2019.
Legacy Cumulus 1 release v1.9.4 (build 1099) - 28 November 2014

See the Wiki for downloading either version.

Setting up Raspberry Pi; do I need libx11?

Discussion of version 3 of Cumulus, which runs on Windows, Linux, and OS X. All Cumulus MX queries in here, please.

Moderator: mcrossley

Post Reply
User avatar
GlueGuy2
Posts: 27
Joined: Fri 16 Jan 2015 5:39 pm
Weather Station: Davis Vantage Pro2
Operating System: Windows 8.1
Location: US - California

Setting up Raspberry Pi; do I need libx11?

Post by GlueGuy2 » Thu 24 Sep 2015 5:51 pm

It's not clear to me what kind of interface culumus needs in a linux environment. Does the UI run in a libx11 environment?

I'm planning on setting up the pi in a headless setup, so I'm looking at the minimum setup I need. The only thing attached will be power and ethernet. No mouse, no keyboard, no monitor.

TIA!

--
bp
bp

User avatar
steve
Cumulus Author
Posts: 26717
Joined: Mon 02 Jun 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: Setting up Raspberry Pi; do I need libx11?

Post by steve » Thu 24 Sep 2015 5:56 pm

The 'engine' is just a console application, it runs from a command line. The GUI runs in a browser, which can be on a different machine. So you don't need a GUI on the Pi.
Steve

User avatar
GlueGuy2
Posts: 27
Joined: Fri 16 Jan 2015 5:39 pm
Weather Station: Davis Vantage Pro2
Operating System: Windows 8.1
Location: US - California

Re: Setting up Raspberry Pi; do I need libx11?

Post by GlueGuy2 » Thu 24 Sep 2015 5:58 pm

Excellent! Thanks for the almost instantaneous response Steve!
bp

philpugh
Posts: 132
Joined: Tue 24 May 2011 8:34 am
Weather Station: DAVIS VantageVue
Operating System: Debian Stretch Lite
Location: Antrobus, Cheshire
Contact:

Re: Setting up Raspberry Pi; do I need libx11?

Post by philpugh » Thu 24 Sep 2015 10:13 pm

The standard debian wheezy installation will work well - I run a couple of them here - one with CumulusMX on it. It runs headless, writes to a MySQL database on my NAS server and hosts the web server. The second one is trying to be a webcam with the R-Pi camera - which is a really nice piece of kit.
Phil Pugh
Davis Vantage Vue Raspberry Pi Zero W Stretch-Lite
Using TCP/IP connection to Meteobridge
http://goosegate.plus.com/

User avatar
GlueGuy2
Posts: 27
Joined: Fri 16 Jan 2015 5:39 pm
Weather Station: Davis Vantage Pro2
Operating System: Windows 8.1
Location: US - California

Re: Setting up Raspberry Pi; do I need libx11?

Post by GlueGuy2 » Mon 28 Sep 2015 3:01 pm

I started up my pi with a 4GB SD card. The stock installation uses just a little over 52% of the available space.

I then installed webmin, as I like using it for many maintenance tasks. That increased my usage to ~~ 53%. Not bad.

I then did an update on all the outdated packages, and this increased used space up to 67%. Whew! Starting to feel tight.

Then I did a remove/purge on all X11 packages, and the used space is back to 52%.

It's also running headless now, and I will start installing MX this morning.

Hopefully, running MX on the pi, and running (old) cumulus on the same weather station will not interfere with each other!

--
bp
bp

User avatar
steve
Cumulus Author
Posts: 26717
Joined: Mon 02 Jun 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: Setting up Raspberry Pi; do I need libx11?

Post by steve » Mon 28 Sep 2015 3:15 pm

GlueGuy2 wrote:Hopefully, running MX on the pi, and running (old) cumulus on the same weather station will not interfere with each other!
If you run them at the same time, they will (interfere), unless you use Virtual VP.
Steve

User avatar
GlueGuy2
Posts: 27
Joined: Fri 16 Jan 2015 5:39 pm
Weather Station: Davis Vantage Pro2
Operating System: Windows 8.1
Location: US - California

Re: Setting up Raspberry Pi; do I need libx11?

Post by GlueGuy2 » Mon 28 Sep 2015 6:56 pm

steve wrote:
GlueGuy2 wrote:Hopefully, running MX on the pi, and running (old) cumulus on the same weather station will not interfere with each other!
If you run them at the same time, they will (interfere), unless you use Virtual VP.
I guess I don't know how to do that. Got a link?
It seems to be mostly running now.

After I removed X11, disk usage went down to 52%. When I added mono, it went back up to 67%. Adding cumulus and my data brought the total up to 69%. As long as it doesn't grow too substantially, I think I will be OK.

The web interface works, but I don't seem to be getting any data from the VP2. I suppose this is from the two cumuli interfering with each other? Below is the contents of the MXdiags:

Code: Select all

cat 20150928-114141.txt
2015-09-28 11:41:42.866  ========================== Cumulus MX starting ==========================
2015-09-28 11:41:42.909 Command line: /home/cumulus/CumulusMX/CumulusMX.exe
2015-09-28 11:41:42.913 Cumulus MX v.3.0.0 build 3031
2015-09-28 11:41:42.938 Platform: Unix
2015-09-28 11:41:42.944 OS version: Unix 3.6.11.0
2015-09-28 11:41:42.945 Current culture: English (United States)
2015-09-28 11:41:42.950 Directory separator=/ Decimal separator=. List separator=,
2015-09-28 11:41:42.952 Date separator=/ Time separator=:
2015-09-28 11:41:42.953 Standard time zone name:   PST
2015-09-28 11:41:42.954 Daylight saving time name: PDT
2015-09-28 11:41:42.956 Daylight saving time? True
2015-09-28 11:41:42.963 9/28/2015 11:41:42 AM
2015-09-28 11:41:42.971 Data path = data/
2015-09-28 11:41:42.993 Creating backup folder backup/20150928114142/
2015-09-28 11:41:43.230 Reading Cumulus.ini file
2015-09-28 11:41:43.443 ASM=10 AST=00:10:00
2015-09-28 11:41:43.466 Cumulus start date: 1/29/2011
2015-09-28 11:41:43.558 Debug logging is disabled
2015-09-28 11:41:43.559 Data logging is disabled
2015-09-28 11:41:43.559 Logging interval = 5
2015-09-28 11:41:44.154 Calculating sunrise and sunset times
2015-09-28 11:41:44.270 Sunrise: 07:01:29
2015-09-28 11:41:44.270 Sunset : 18:56:36
2015-09-28 11:41:44.274 Tomorrow sunrise: 07:02:21
2015-09-28 11:41:44.274 Tomorrow sunset : 18:55:04
2015-09-28 11:41:44.377 Station type: Davis Vantage Pro2
2015-09-28 11:41:44.383 WindUnit=mph RainUnit=in TempUnit=°F PressureUnit=in
2015-09-28 11:41:44.400 YTDRain=0.020 Year=2011
2015-09-28 11:41:44.401 RainDayThreshold=-1.000
2015-09-28 11:41:44.401 Offsets and Multipliers:
2015-09-28 11:41:44.403 PO=0.000 TO=0.000 HO=0 WDO=0 ITO=0.000 UVO=0.000
2015-09-28 11:41:44.405 WSM=1.000 WGM=1.000 TM=1.000 TM2=1.000 HM=1.000 RM=2.300 UVM=1.000
2015-09-28 11:41:44.405 Spike removal:
2015-09-28 11:41:44.406 TD=999.000 GD=999.000 WD=999.000 HD=999.000 PD=999.000
2015-09-28 11:41:44.407 MR=999.000 MH=999.000
2015-09-28 11:41:44.408 Cumulus Starting
2015-09-28 11:41:44.413 Opening station
2015-09-28 11:41:44.722 Last update time from today.ini: 1/15/2015 6:50:00 AM
2015-09-28 11:41:44.724 Read today file: Date = 1/15/2015, LastUpdateTime = 1/15/2015 6:50:00 AM, Month = 1
2015-09-28 11:41:44.732 ET not initialised
2015-09-28 11:41:44.753 ReadTodayfile: set notraininit false
/home/cumulus/CumulusMX/data/alltime.ini
Alltime.ini file read
MonthlyAlltime.ini file read
2015-09-28 11:41:45.249 Finding raintoday from logfile data/Jan15log.txt
2015-09-28 11:41:45.249 Expecting listsep=, decimal=.
Midnight rain found in the following entry:
15/01/15,00:00,51.5,66,40.3,0.2,3.0,153,0.00,0.00,30.250,10.95,67.2,35,0.0,51.5,51.5,0.0,0
Setting raintoday from logfile = 0
Calculating rain counter = 10.9499998092651
Midnight rain found = 10.95
Getting rain totals, rain season start = 1
2015-09-28 11:41:47.834 Rainthismonth from dayfile.txt: 0
2015-09-28 11:41:47.834 Rainthisyear from dayfile.txt: 0
2015-09-28 11:41:48.280 Station type = Davis
2015-09-28 11:41:48.358 LOOP2 enabled
2015-09-28 11:41:48.359 IP address = 192.168.222.108 Port = 22222
2015-09-28 11:41:48.359 periodic disconnect = 0
2015-09-28 11:41:48.716 Connected OK
2015-09-28 11:41:48.721 Flushing input stream
2015-09-28 11:41:48.947 Received 0x0A
2015-09-28 11:41:49.148 Received 0x0D
2015-09-28 11:41:49.359 Reading firmware version
2015-09-28 11:41:51.376 FW version = 1.90
2015-09-28 11:41:51.377 Last update time = 1/15/2015 6:50:00 AM
2015-09-28 11:41:51.391 Setting console time
2015-09-28 11:41:54.906 Reading console time
2015-09-28 11:41:55.910 Start reading archive data
2015-09-28 11:41:55.917 Reading archive data
2015-09-28 11:41:55.920 Loading last N hour data from data logs: 1/15/2015 6:50:00 AM
2015-09-28 11:41:57.416 Loaded 13 entries to last hour data list
2015-09-28 11:41:58.924 Loaded 37 entries to last 3 hour data list
2015-09-28 11:42:00.374 Error at line 3727 of data/Jan15log.txt : Argument is out of range.
Parameter name: index
2015-09-28 11:42:00.438 Please edit the file to correct the error
2015-09-28 11:42:00.439 Loaded 0 entries to graph data list
2015-09-28 11:42:01.222 Error at line 1999 of data/Jan15log.txt : Argument is out of range.
Parameter name: index
2015-09-28 11:42:01.223 Please edit the file to correct the error
2015-09-28 11:42:01.224 Loaded 0 entries to recent data list
2015-09-28 11:42:01.779 Loaded 0 entries to daily data list
2015-09-28 11:42:02.040 Get Archive Data
2015-09-28 11:42:02.043 Rollover hour = 0
2015-09-28 11:42:02.045 Last Archive Date: 1/15/2015 6:50:00 AM
2015-09-28 11:42:02.046 Date: 7727
2015-09-28 11:42:02.046 Time: 650
2015-09-28 11:42:02.180 Updating highs and lows
2015-09-28 11:42:02.202 Day reset required
2015-09-28 11:42:02.215 Start normal reading loop
System.IO.IOException: Write failure ---> System.Net.Sockets.SocketException: The socket has been shut down
  at System.Net.Sockets.Socket.Send (System.Byte[] buf, Int32 offset, Int32 size, SocketFlags flags) [0x00000] in <filename unknown>:0
  at System.Net.Sockets.NetworkStream.Write (System.Byte[] buffer, Int32 offset, Int32 size) [0x00000] in <filename unknown>:0
  --- End of inner exception stack trace ---
  at System.Net.Sockets.NetworkStream.Write (System.Byte[] buffer, Int32 offset, Int32 size) [0x00000] in <filename unknown>:0
  at . (System.Net.Sockets.TcpClient , System.String ) [0x00000] in <filename unknown>:0
  at . () [0x00000] in <filename unknown>:0
  at System.Threading.Thread.StartInternal () [0x00000] in <filename unknown>:0
2015-09-28 11:42:02.520 === Day reset, today = 28
2015-09-28 11:42:02.521 === Day reset for 9/28/2015 12:00:00 AM
2015-09-28 11:42:02.812 Dayfile.txt entry:
2015-09-28 11:42:02.813 27/09/15,9.0,151,01:36,51.2,00:10,54.6,02:31,30.233,04:56,30.259,02:49,0.00,00:00,0.00,53.1,6.2,2.9,01:42,100,00:00,0,00:00,0.000,0.0,-999.0,00:00,-999.0,00:00,999.0,00:00,0.00,00:00,999.0,00:00,-999.0,00:00,999.0,00:00,0,0.0,0.0,0,00:00,0.0,00:00
2015-09-28 11:42:02.814 Dayfile.txt opened for writing
2015-09-28 11:42:02.815 Writing entry to dayfile.txt
2015-09-28 11:42:02.833 Raincounter = 10.9499998092651 Raindaystart = 10.9499998092651
2015-09-28 11:42:02.833 Rainyesterday (calibrated) set to 0
2015-09-28 11:42:02.873 RainDayThreshold = -1
2015-09-28 11:42:02.873 rdt1000=10 ry1000=0
2015-09-28 11:42:02.874 Yesterday was a dry day
2015-09-28 11:42:02.874 Consecutive dry days = 1
2015-09-28 11:42:03.125 625 web tags initialised
New monthly record, month = 9: 2015-09-28 10:42 1.000 "Longest dry period" 2015-09-28 11:41 0.000
2015-09-28 11:42:03.280 HTML root path = /home/cumulus/CumulusMX/interface
New monthly record, month = 9: 2015-09-27 02:31 54.600 "Lowest maximum temp" 2015-09-28 11:41 999.000
New monthly record, month = 9: 2015-09-27 00:10 51.200 "Highest minimum temp" 2015-09-28 11:41 -999.000
New monthly record, month = 9: 2015-09-28 10:42 3.400 "High daily temp range" 2015-09-28 11:41 0.000
2015-09-28 11:42:04.439 Starting web socket server on port 8002
New monthly record, month = 9: 2015-09-28 10:42 3.400 "Low daily temp range" 2015-09-28 11:41 999.000
Raindaystart set to 10.9499998092651
2015-09-28 11:42:04.774 StartofdayET set to 0
2015-09-28 11:42:04.864 Writing today.ini, LastUpdateTime = 1/15/2015 6:50:00 AM raindaystart = 10.9499998092651 rain counter = 10.9499998092651
2015-09-28 11:42:04.907 === Day reset complete
2015-09-28 11:42:04.908 Now recording data for day=28 month=9 year=2015
Midnight rain reset, count = 10.9499998092651 time = 11:42 AM
Reset sunshine hours, yesterday = 0
2015-09-28 11:42:05.031 Start Timers
2015-09-28 11:42:05.031 Starting 1-minute timer
2015-09-28 11:42:05.047 Realtime not enabled
bp

User avatar
steve
Cumulus Author
Posts: 26717
Joined: Mon 02 Jun 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: Setting up Raspberry Pi; do I need libx11?

Post by steve » Mon 28 Sep 2015 7:22 pm

GlueGuy2 wrote:The web interface works, but I don't seem to be getting any data from the VP2. I suppose this is from the two cumuli interfering with each other?
Yes.

Virtual VP is here - http://www.softwx.com/weather/virtualvp.html - but note that you may have issues with it, it's currently free because of compatibility problems.

If you use it, you will need to disable LOOP2 in MX as in the instructions.
Steve

User avatar
GlueGuy2
Posts: 27
Joined: Fri 16 Jan 2015 5:39 pm
Weather Station: Davis Vantage Pro2
Operating System: Windows 8.1
Location: US - California

Re: Setting up Raspberry Pi; do I need libx11?

Post by GlueGuy2 » Mon 28 Sep 2015 10:00 pm

A little more involved getting the pi to connect to the VP2. Stopping cumulus 1 was not enough to allow MX to connect to the station. I had (1) Stop cumulus 1, and (2) power-cycle the VP2 to get it to connect.

It's connected now, but is still not displaying any data on the web GUI. There are a bunch of "loop data not received" at the end of MXdiags.

Code: Select all

2015-09-28 14:50:30.296  ========================== Cumulus MX starting ==========================
2015-09-28 14:50:30.348 Command line: /home/cumulus/CumulusMX/CumulusMX.exe
2015-09-28 14:50:30.352 Cumulus MX v.3.0.0 build 3031
2015-09-28 14:50:30.378 Platform: Unix
2015-09-28 14:50:30.384 OS version: Unix 3.6.11.0
2015-09-28 14:50:30.384 Current culture: English (United States)
2015-09-28 14:50:30.390 Directory separator=/ Decimal separator=. List separator=,
2015-09-28 14:50:30.392 Date separator=/ Time separator=:
2015-09-28 14:50:30.393 Standard time zone name:   PST
2015-09-28 14:50:30.394 Daylight saving time name: PDT
2015-09-28 14:50:30.395 Daylight saving time? True
2015-09-28 14:50:30.403 9/28/2015 2:50:30 PM
2015-09-28 14:50:30.411 Data path = data/
2015-09-28 14:50:30.434 Creating backup folder backup/20150928145030/
2015-09-28 14:50:30.673 Reading Cumulus.ini file
2015-09-28 14:50:30.936 ASM=10 AST=00:10:00
2015-09-28 14:50:30.960 Cumulus start date: 1/29/2011
2015-09-28 14:50:31.054 Debug logging is disabled
2015-09-28 14:50:31.055 Data logging is disabled
2015-09-28 14:50:31.055 Logging interval = 5
2015-09-28 14:50:31.654 Calculating sunrise and sunset times
2015-09-28 14:50:31.769 Sunrise: 07:01:29
2015-09-28 14:50:31.770 Sunset : 18:56:36
2015-09-28 14:50:31.773 Tomorrow sunrise: 07:02:21
2015-09-28 14:50:31.774 Tomorrow sunset : 18:55:04
2015-09-28 14:50:31.877 Station type: Davis Vantage Pro2
2015-09-28 14:50:31.884 WindUnit=mph RainUnit=in TempUnit=°F PressureUnit=in
2015-09-28 14:50:31.901 YTDRain=0.020 Year=2011
2015-09-28 14:50:31.902 RainDayThreshold=-1.000
2015-09-28 14:50:31.902 Offsets and Multipliers:
2015-09-28 14:50:31.904 PO=0.000 TO=0.000 HO=0 WDO=0 ITO=0.000 UVO=0.000
2015-09-28 14:50:31.906 WSM=1.000 WGM=1.000 TM=1.000 TM2=1.000 HM=1.000 RM=2.300 UVM=1.000
2015-09-28 14:50:31.906 Spike removal:
2015-09-28 14:50:31.908 TD=999.000 GD=999.000 WD=999.000 HD=999.000 PD=999.000
2015-09-28 14:50:31.908 MR=999.000 MH=999.000
2015-09-28 14:50:31.909 Cumulus Starting
2015-09-28 14:50:31.914 Opening station
2015-09-28 14:50:32.228 Last update time from today.ini: 1/15/2015 6:50:00 AM
2015-09-28 14:50:32.230 Read today file: Date = 9/28/2015, LastUpdateTime = 1/15/2015 6:50:00 AM, Month = 1
2015-09-28 14:50:32.260 ReadTodayfile: set notraininit false
/home/cumulus/CumulusMX/data/alltime.ini
Alltime.ini file read
MonthlyAlltime.ini file read
Month.ini file read
Year.ini file read
2015-09-28 14:50:32.890 Finding raintoday from logfile data/Jan15log.txt
2015-09-28 14:50:32.891 Expecting listsep=, decimal=.
Midnight rain found in the following entry:
15/01/15,00:00,51.5,66,40.3,0.2,3.0,153,0.00,0.00,30.250,10.95,67.2,35,0.0,51.5,51.5,0.0,0
Setting raintoday from logfile = 0
Calculating rain counter = 10.9499998092651
Midnight rain found = 10.95
Getting rain totals, rain season start = 1
2015-09-28 14:50:35.411 Rainthismonth from dayfile.txt: 0
2015-09-28 14:50:35.416 Rainthisyear from dayfile.txt: 0
2015-09-28 14:50:35.865 Station type = Davis
2015-09-28 14:50:35.866 LOOP2 enabled
2015-09-28 14:50:35.866 IP address = 192.168.222.108 Port = 22222
2015-09-28 14:50:35.867 periodic disconnect = 0
2015-09-28 14:50:36.224 Connected OK
2015-09-28 14:50:36.230 Flushing input stream
2015-09-28 14:50:36.457 Reading firmware version
2015-09-28 14:50:38.482 FW version = 1.90
2015-09-28 14:50:38.483 Last update time = 1/15/2015 6:50:00 AM
2015-09-28 14:50:38.498 Setting console time
2015-09-28 14:50:40.500 Received 0x06
2015-09-28 14:50:40.503 ACK received
2015-09-28 14:50:41.508 Received 0x06
2015-09-28 14:50:41.509 ACK received
2015-09-28 14:50:41.521 Reading console time
2015-09-28 14:50:43.523 Received 0x06
2015-09-28 14:50:43.524 ACK received
2015-09-28 14:50:43.524 2A-32-0E-1C-09-73-9B-53
2015-09-28 14:50:43.525 Console clock: 9/28/2015 2:50:42 PM
2015-09-28 14:50:43.525 Start reading archive data
2015-09-28 14:50:43.532 Reading archive data
2015-09-28 14:50:43.535 Loading last N hour data from data logs: 1/15/2015 6:50:00 AM
2015-09-28 14:50:44.983 Loaded 13 entries to last hour data list
2015-09-28 14:50:46.448 Loaded 37 entries to last 3 hour data list
2015-09-28 14:50:47.828 Error at line 3727 of data/Jan15log.txt : Argument is out of range.
Parameter name: index
2015-09-28 14:50:47.829 Please edit the file to correct the error
2015-09-28 14:50:47.831 Loaded 0 entries to graph data list
2015-09-28 14:50:48.579 Error at line 1999 of data/Jan15log.txt : Argument is out of range.
Parameter name: index
2015-09-28 14:50:48.580 Please edit the file to correct the error
2015-09-28 14:50:48.581 Loaded 0 entries to recent data list
2015-09-28 14:50:49.122 Loaded 1 entries to daily data list
2015-09-28 14:50:49.374 Get Archive Data
2015-09-28 14:50:49.388 Rollover hour = 0
2015-09-28 14:50:49.390 Last Archive Date: 1/15/2015 6:50:00 AM
2015-09-28 14:50:49.391 Date: 7727
2015-09-28 14:50:49.391 Time: 650
2015-09-28 14:50:49.836 625 web tags initialised
2015-09-28 14:50:49.906 HTML root path = /home/cumulus/CumulusMX/interface
2015-09-28 14:50:50.531 Starting web socket server on port 8002
2015-09-28 14:50:51.393 Received response to DMPAFT, sending date and time
2015-09-28 14:50:51.394 2F-1E-8A-02-6F-D3
2015-09-28 14:50:52.395 No ACK
2015-09-28 14:50:52.395 Get Archive Data
2015-09-28 14:50:52.397 Rollover hour = 0
2015-09-28 14:50:52.398 Last Archive Date: 1/15/2015 6:50:00 AM
2015-09-28 14:50:52.398 Date: 7727
2015-09-28 14:50:52.399 Time: 650
2015-09-28 14:50:56.401 Received response to DMPAFT, sending date and time
2015-09-28 14:50:56.402 2F-1E-8A-02-6F-D3
2015-09-28 14:50:57.402 No ACK
2015-09-28 14:50:57.478 Updating highs and lows
2015-09-28 14:50:57.492 Day reset required
2015-09-28 14:50:57.502 Start normal reading loop
2015-09-28 14:50:57.602 === Day reset, today = 28
2015-09-28 14:50:57.603 === Day reset for 9/28/2015 12:00:00 AM
2015-09-28 14:50:57.714 Dayfile.txt entry:
2015-09-28 14:50:57.715 27/09/15,0.0,0,11:42,0.0,11:42,0.0,11:42,0.000,11:42,0.000,11:42,0.00,11:42,0.00,0.0,0.0,0.0,11:42,0,11:42,0,11:42,0.000,0.0,0.0,11:42,0.0,11:42,0.0,11:42,0
.00,11:42,0.0,11:42,0.0,11:42,0.0,11:42,0,0.0,0.0,0,11:42,0.0,11:42
2015-09-28 14:50:57.716 Dayfile.txt opened for writing
2015-09-28 14:50:57.716 Writing entry to dayfile.txt
2015-09-28 14:50:57.725 Raincounter = 10.9499998092651 Raindaystart = 10.9499998092651
2015-09-28 14:50:57.725 Rainyesterday (calibrated) set to 0
2015-09-28 14:50:57.734 RainDayThreshold = -1
2015-09-28 14:50:57.735 rdt1000=10 ry1000=0
2015-09-28 14:50:57.735 Yesterday was a dry day
2015-09-28 14:50:57.736 Consecutive dry days = 2
New monthly record, month = 9: 2015-09-28 13:50 2.000 "Longest dry period" 2015-09-28 10:42 1.000
New monthly record, month = 9: 2015-09-27 11:42 0.000 "Lowest maximum temp" 2015-09-27 02:31 54.600
New monthly record, month = 9: 2015-09-28 13:50 0.000 "Low daily temp range" 2015-09-28 10:42 3.400
Raindaystart set to 10.9499998092651
2015-09-28 14:50:58.480 StartofdayET set to 0
2015-09-28 14:50:58.553 Writing today.ini, LastUpdateTime = 1/15/2015 6:50:00 AM raindaystart = 10.9499998092651 rain counter = 10.9499998092651
2015-09-28 14:50:58.601 === Day reset complete
2015-09-28 14:50:58.602 Now recording data for day=28 month=9 year=2015
Midnight rain reset, count = 10.9499998092651 time = 2:50 PM
Reset sunshine hours, yesterday = 0
2015-09-28 14:50:58.718 Start Timers
2015-09-28 14:50:58.719 Starting 1-minute timer
2015-09-28 14:50:58.734 Realtime not enabled
 ****Rain reset? First chance: raindaystart = 10.9499998092651, Raincounter = 0.11
Leaving counter at 10.9499998092651
New monthly record, month = 9: 2015-09-28 14:51 -7.200 "High apparent temp" 2015-09-28 11:41 -999.000
New monthly record, month = 9: 2015-09-28 14:51 -7.200 "Low apparent temp" 2015-09-28 11:41 999.000
2015-09-28 14:51:21.067 !!! loop data not received
 ****Rain counter reset confirmed: raindaystart = 10.9499998092651, Raincounter = 0.11
Setting raindaystart to 0.11
2015-09-28 14:51:42.893 !!! loop data not received
2015-09-28 14:52:04.709 !!! loop data not received
2015-09-28 14:52:26.525 !!! loop data not received
2015-09-28 14:52:48.340 !!! loop data not received
2015-09-28 14:53:10.155 !!! loop data not received
2015-09-28 14:53:31.975 !!! loop data not received
2015-09-28 14:53:53.792 !!! loop data not received
2015-09-28 14:54:15.607 !!! loop data not received
bp

User avatar
steve
Cumulus Author
Posts: 26717
Joined: Mon 02 Jun 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: Setting up Raspberry Pi; do I need libx11?

Post by steve » Tue 29 Sep 2015 6:35 am

Please turn on debug logging and data logging in Cumulus.ini, and then zip up and attach the MX diags file and attach it to a reply in this thread.

Is your WLIP uploading to weatherlink.com?
Steve

User avatar
GlueGuy2
Posts: 27
Joined: Fri 16 Jan 2015 5:39 pm
Weather Station: Davis Vantage Pro2
Operating System: Windows 8.1
Location: US - California

Re: Setting up Raspberry Pi; do I need libx11?

Post by GlueGuy2 » Tue 29 Sep 2015 4:30 pm

steve wrote:Please turn on debug logging and data logging in Cumulus.ini, and then zip up and attach the MX diags file and attach it to a reply in this thread.

Is your WLIP uploading to weatherlink.com?
I'll be able to try that tomorrow.

I don't use weatherlink or weatherlink.com.

I'm currently using C1, and upload data to Wunderground. That is working famously.
bp

User avatar
GlueGuy2
Posts: 27
Joined: Fri 16 Jan 2015 5:39 pm
Weather Station: Davis Vantage Pro2
Operating System: Windows 8.1
Location: US - California

<<SOLVED!!>> Re: Setting up Raspberry Pi; do I need libx11?

Post by GlueGuy2 » Wed 30 Sep 2015 7:09 pm

I set up debug and data logging, and I think I figured out the problem.

In order to get MX working, I needed to (1) Stop C1, (2) Reboot the VP2 (pulled plug/replugged), (3) Start MX, and (4) Wait 10 minutes for the VP2 to get its knickers on straight.

#4 was what I wasn't doing before. Our VP2 displays a blank screen on reboot for about 10 minutes. During that time, all that MX was logging was "loop data not received".

It all seems to be working now, including sending data to Wunderground!

Thank you Steve!
bp

User avatar
steve
Cumulus Author
Posts: 26717
Joined: Mon 02 Jun 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: Setting up Raspberry Pi; do I need libx11?

Post by steve » Sat 10 Oct 2015 10:15 am

It seems odd that you have to do that - I have switched between C1 (on a Windows 10 PC) and MX (on an RP2) with my WLIP a few times, and didn't have to do that. When I get caught up and have a few minutes, I'll give it another try.
Steve

User avatar
GlueGuy2
Posts: 27
Joined: Fri 16 Jan 2015 5:39 pm
Weather Station: Davis Vantage Pro2
Operating System: Windows 8.1
Location: US - California

Re: Setting up Raspberry Pi; do I need libx11?

Post by GlueGuy2 » Thu 15 Oct 2015 4:44 pm

Happened again yesterday. I accidentally started CM1 on my windows machine, and CMX stopped.

So I rebooted my VP2, and restarted CMX. That is the recovery mode for me. Our VP2 takes about 10 minutes before it will start sending data.

I've removed easy access to CM1 on my windows machine to prevent this from happening again.
bp

Post Reply