Welcome to the new home of the Cumulus Support forum.

Latest Cumulus release v1.9.4 (build 1099) - Nov 28 2014
Latest Cumulus MX release - v3.0.0 build 3043 Jan 20 2017. See the Wiki for download

few bugs/issues with CMX

Discussion of version 3 of Cumulus, which runs on Windows, Linux, and OS X. All Cumulus MX queries in here, please.
Post Reply
TgT
Posts: 127
Joined: Thu Jun 26, 2008 5:51 am
Weather Station: Davis VP2 + Solar
Operating System: A20 TV box + CumulusMX
Location: Slov.Konjice, Slovenia
Contact:

few bugs/issues with CMX

Post by TgT » Wed Sep 23, 2015 7:27 pm

It was time to switch from my old win2k system...
So, lets start

I never used pages that came along with Cumulus.
Same goes for CumulusMX... I got few issues
Setup first, X is ticked
  • Auto update X
    Include standard files
    Include graph data files X
*I deleted xxxT.htm files from web and i get this into a console

Code: Select all

System.NullReferenceException: Object reference not set to an instance of an object
  at CumulusMX.Cumulus. () [0x00000] in <filename unknown>:0
  at CumulusMX.Cumulus.DoHTMLFiles () [0x00000] in <filename unknown>:0
  at System.Threading.Thread.StartInternal () [0x00000] in <filename unknown>:0
* If i enable Include standard files, blank html files are uploaded even if they do not exist.
* Graphs data are not being generated nor uploaded ( they should have been, since 'Include graph data files' is checked )
* NOAA reports are created but not UPLOADed on Auto Update interval ( Log says nothing about this )

Code: Select all

2015-09-23 00:00:00.788 === Day reset for 9/22/2015 12:00:00 AM
2015-09-23 00:00:00.789
NOAA reports will be uploaded at next web update
2015-09-23 00:00:00.834 Dayfile.txt entry:
2015-09-23 00:00:00.834 22/09/15,14.5,73,11:44,7.4,06:48,19.8,15:04,1007.18,23:58,1015.58,00:00,0.0,00:00,0.0,13.2,21.3,4.8,04:00,52,12:27,87,06:44,1.78,4.6,19.8,15:04$
2015-09-23 00:00:00.835 Dayfile.txt opened for writing
2015-09-23 00:00:00.835 Writing entry to dayfile.txt
2015-09-23 00:00:00.837 Raincounter = 623.8 Raindaystart = 623.8
2015-09-23 00:00:00.841 Rainyesterday (calibrated) set to 1.13686837721616E-13
2015-09-23 00:00:00.845 RainDayThreshold = -1
2015-09-23 00:00:00.845 rdt1000=200 ry1000=0
2015-09-23 00:00:00.846 Yesterday was a dry day
2015-09-23 00:00:00.846 Consecutive dry days = 2
Raindaystart set to 623.8
2015-09-23 00:00:00.847 StartofdayET set to 612.775
2015-09-23 00:00:00.851 Writing today.ini, LastUpdateTime = 9/22/2015 11:59:00 PM raindaystart = 623.8 rain counter = 623.8
2015-09-23 00:00:00.867 Creating NOAA monthly report for Tuesday, September 22, 2015
2015-09-23 00:00:09.523 Saving monthly report as Reports/NOAAMO0915.txt
2015-09-23 00:00:09.526 Creating NOAA yearly report
2015-09-23 00:01:02.907 Writing log entry for 9/23/2015 12:01:02 AM
2015-09-23 00:01:02.909 Written log entry for 9/23/2015 12:01:02 AM
2015-09-23 00:01:02.913 Writing today.ini, LastUpdateTime = 9/23/2015 12:01:02 AM raindaystart = 623.8 rain counter = 623.8
2015-09-23 00:01:15.980 Reading reception stats
2015-09-23 00:01:20.260 Saving yearly report as Reports/NOAAYR2015.txt

Code: Select all

cat ftplog.txt | grep NOAA 
or

Code: Select all

cat ftplog.txt | grep noaa
Gives nothing.

Using latest 3031
Image

User avatar
steve
Cumulus Author
Posts: 26713
Joined: Mon Jun 02, 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: few bugs/issues with CMX

Post by steve » Wed Sep 23, 2015 8:58 pm

All of the other issues are because of the first exception, it stops processing after that. The exception is presumably because you've deleted the files, but I can't tell exactly why the exception occurs because mono doesn't give me line numbers - I will have to try to reproduce it.

So the only issue is that it doesn't cope with the standard templates being deleted. It does check for the files not existing, so it's not immediately obvious what the problem is. Presumably if you don't break it by deleting the files, everything works as expected?
Steve

User avatar
steve
Cumulus Author
Posts: 26713
Joined: Mon Jun 02, 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: few bugs/issues with CMX

Post by steve » Thu Sep 24, 2015 8:08 am

I tried deleting the standard template files, and I don't get an exception. Please make sure you have debug logging turned on in Cumulus.ini, then attach the MXdiags file after the exception occurs. I will also need to see your Cumulus.ini file (with passwords removed), please.

It would also be helpful if you could try it on a Windows system, so that I get a better stack trace from the exception. What platform are you running on currently?
Steve

TgT
Posts: 127
Joined: Thu Jun 26, 2008 5:51 am
Weather Station: Davis VP2 + Solar
Operating System: A20 TV box + CumulusMX
Location: Slov.Konjice, Slovenia
Contact:

Re: few bugs/issues with CMX

Post by TgT » Fri Sep 25, 2015 11:07 am

I cant try it on Windows.. Im using LInux, Debian.

Today, somehow my dashboard aint working after program restart :o Everything else working, NOAA files were uploaded, but before that error occured, as you said already.

Cumulus.ini
MXdiags.zip
You do not have the required permissions to view the files attached to this post.
Image

User avatar
steve
Cumulus Author
Posts: 26713
Joined: Mon Jun 02, 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: few bugs/issues with CMX

Post by steve » Fri Sep 25, 2015 11:25 am

I asked you to remove the passwords, but there are no ftp details configured at all. Is this how you are running, or have you also removed those?
Steve

TgT
Posts: 127
Joined: Thu Jun 26, 2008 5:51 am
Weather Station: Davis VP2 + Solar
Operating System: A20 TV box + CumulusMX
Location: Slov.Konjice, Slovenia
Contact:

Re: few bugs/issues with CMX

Post by TgT » Fri Sep 25, 2015 11:26 am

Removed
Image

User avatar
steve
Cumulus Author
Posts: 26713
Joined: Mon Jun 02, 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: few bugs/issues with CMX

Post by steve » Fri Sep 25, 2015 11:43 am

This needs correcting:

ExtraLocal4=/www/CumulusMX/web//monthlyrecordT.htm

and these look odd (different from the others, at least):

ExtraLocal5=/www/CumulusMX/realtime.txt
ExtraRemote5=/www/www/realtime.txt

How does realtime.txt get into the /www/CumulusMX directory when that isn't where MX is running? Or is /www/ mapped to /mnt/sd/? You clearly have an unusual setup, and it's hard for me to diagnose unless you explain very clearly exactly what you are doing.

Does it not create the graph data files at all - not even once? Is it processing (even just once) any of your extra files - are there processed files created locally ending in 'tmp' for any of them?
Steve

TgT
Posts: 127
Joined: Thu Jun 26, 2008 5:51 am
Weather Station: Davis VP2 + Solar
Operating System: A20 TV box + CumulusMX
Location: Slov.Konjice, Slovenia
Contact:

Re: few bugs/issues with CMX

Post by TgT » Fri Sep 25, 2015 11:57 am

the first /www/ is symbolic link, real path its /mnt/sd/
CumulusMX is running in /mnt/sd/CumulusMX and local web page is at /mnt/sd/www/

monthlyrecordT.htm is odd cause it a totally different script/page than yours, could this be a prob? nah

Realtime.txt is a created in CumulusMX dir and just moved to local http server.
Image

User avatar
steve
Cumulus Author
Posts: 26713
Joined: Mon Jun 02, 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: few bugs/issues with CMX

Post by steve » Fri Sep 25, 2015 12:00 pm

I think the exception may be occurring during the ftp - could you attach the ftplog.txt file, please? And answer the other questions that I've asked?
Steve

TgT
Posts: 127
Joined: Thu Jun 26, 2008 5:51 am
Weather Station: Davis VP2 + Solar
Operating System: A20 TV box + CumulusMX
Location: Slov.Konjice, Slovenia
Contact:

Re: few bugs/issues with CMX

Post by TgT » Fri Sep 25, 2015 12:22 pm

Does it not create the graph data files at all - not even once?

Code: Select all

-rwxr-xr-x 1 root root    637 Sep 25 00:25 dailyrain.json
-rwxr-xr-x 1 root root   1981 Sep 25 00:25 dailytemp.json
-rwxr-xr-x 1 root root    186 Sep 25 00:25 graphconfig.json
-rwxr-xr-x 1 root root 109460 Sep 25 00:25 humdata.json
-rwxr-xr-x 1 root root  69132 Sep 25 00:25 pressdata.json
-rwxr-xr-x 1 root root 115225 Sep 25 00:25 raindata.json
-rwxr-xr-x 1 root root 165500 Sep 25 00:25 solardata.json
-rwxr-xr-x 1 root root    635 Sep 25 00:25 sunhours.json
-rwxr-xr-x 1 root root 299973 Sep 25 00:25 tempdata.json
-rwxr-xr-x 1 root root 112582 Sep 25 00:25 wdirdata.json
-rwxr-xr-x 1 root root 115417 Sep 25 00:25 winddata.json
Is it processing (even just once) any of your extra files - are there processed files created locally ending in 'tmp' for any of them?
hm, this monthlyrecord file is odd

Code: Select all

-rwxr-xr-x 1 root root   340 Sep  9 12:39 awekasT.txt
-rwxr-xr-x 1 root root   269 Sep 25 14:20 awekasT.txttmp
-rwxr-xr-x 1 root root  2486 Sep 20 01:23 cu_dashT.txt
-rwxr-xr-x 1 root root  1685 Sep 25 14:20 cu_dashT.txttmp
-rwxr-xr-x 1 root root   780 Sep 20 01:20 mobi_ver.txt
-rwxr-xr-x 1 root root   569 Sep 25 14:20 mobi_ver.txttmp
-rwxr-xr-x 1 root root 25603 Sep 25 00:25 monthlyrecord.htm
-rwxr-xr-x 1 root root 33444 Sep 20 00:51 monthlyrecordT.htm
-rwxr-xr-x 1 root root 25603 Sep 25 00:25 monthlyrecordT.htmtmp
-rwxr-xr-x 1 root root  2090 Mar  3  2015 realtimegaugesT.txt
ftplog.txt
You do not have the required permissions to view the files attached to this post.
Image

TgT
Posts: 127
Joined: Thu Jun 26, 2008 5:51 am
Weather Station: Davis VP2 + Solar
Operating System: A20 TV box + CumulusMX
Location: Slov.Konjice, Slovenia
Contact:

Re: few bugs/issues with CMX

Post by TgT » Fri Sep 25, 2015 12:50 pm

I removed those monthlyrecord* files and restarded CumulusMX, it appears to be updating *.json files on interval 5min.
Maybe the naming was the problem? not sure.

But I still got no data on dashboard/now/gagues tabs in Chrome/Win7, this should be some other problem not related to CumulusMX, since its normal on Phone/Tablet/LinuxMint platforms ;)
Image

User avatar
steve
Cumulus Author
Posts: 26713
Joined: Mon Jun 02, 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: few bugs/issues with CMX

Post by steve » Fri Sep 25, 2015 1:03 pm

TgT wrote:I removed those monthlyrecord* files and restarded CumulusMX, it appears to be updating *.json files on interval 5min.
Maybe the naming was the problem? not sure.
Perhaps the double slash in the file name was causing a problem somewhere. but I'm not sure exactly where.
But I still got no data on dashboard/now/gagues tabs in Chrome/Win7, this should be some other problem not related to CumulusMX, since its normal on Phone/Tablet/LinuxMint platforms ;)
Those pages use web sockets - Chrome supports that, so perhaps it's a firewall problem? Any errors in the F12 developer console in Chrome?
Steve

TgT
Posts: 127
Joined: Thu Jun 26, 2008 5:51 am
Weather Station: Davis VP2 + Solar
Operating System: A20 TV box + CumulusMX
Location: Slov.Konjice, Slovenia
Contact:

Re: few bugs/issues with CMX

Post by TgT » Tue Sep 29, 2015 6:00 pm

It is all good. Working fine, got no issues :D
Image

Post Reply