Welcome to the Cumulus Support forum.

Latest Cumulus MX release v3.4.6 (build 3070) - 23 March 2020
Legacy Cumulus 1 release v1.9.4 (build 1099) - 28 November 2014

See the Wiki for downloading either version.

Later version of mono for Raspberry Pi 2

From build 3044 the development baton passed to Mark Crossley. Mark has been responsible for all the Builds since. He has made the code available on GitHub. It is Mark's hope that others will join in this development, but at the very least he welcomes your ideas for future developments (see Cumulus MX Development suggestions).

Moderator: mcrossley

jank
Posts: 216
Joined: Sat 13 Jun 2015 5:57 pm
Weather Station: weatherstation
Operating System: Debian Wheezy
Location: Germany

Re: Later version of mono for Raspberry Pi 2

Post by jank » Mon 28 Dec 2015 12:52 pm

Hi
I have: lsb_release -a

Distributor ID: Raspbian
Description: Raspbian GNU/Linux 8.0 (jessie)
Release: 8.0
Codename: jessie


mono -V
Mono JIT compiler version 4.0.5 (Stable 4.0.5.1/1d8d582 Thu Nov 12 12:22:41 UTC 2015)

First Lines in MXDiags Logs show locale
2015-12-23 19:32:55.705 Current culture: German (Germany)
2015-12-23 19:32:55.706 Directory separator=/ Decimal separator=, List separator=;
2015-12-23 19:32:55.707 Date separator=. Time separator=:


My /etc/apt/sources.list
deb http://mirrordirector.raspbian.org/raspbian/ jessie main contrib non-free rpi

/etc/apt//sources.list.d/

collabora.list
deb http://raspberrypi.collabora.com wheezy rpi
mono-xamarin.list
deb http://download.mono-project.com/repo/debian wheezy main
raspi.list
deb http://archive.raspberrypi.org/debian/ jessie main

But, when I try to upgrade (sudo apt-get upgrade I am getting this

The following packages have been kept back:
.........
libmono-system-web-http-webhost4.0-cil libmono-system-web-http4.0-cil libmono-system-web-mvc3.0-cil
libmono-system-web-razor2.0-cil libmono-system-web-routing4.0-cil libmono-system-web-services4.0-cil
libmono-system-web-webpages-deployment2.0-cil libmono-system-web-webpages-razor2.0-cil libmono-system-web-webpages2.0-cil
libmono-system-web4.0-cil libmono-system-windows-forms-datavisualization4.0a-cil libmono-system-windows-forms4.0-cil
libmono-system-windows4.0-cil libmono-system-xaml4.0-cil libmono-system-xml-linq4.0-cil
libmono-system-xml-serialization4.0-cil libmono-system-xml4.0-cil libmono-system4.0-cil libmono-tasklets4.0-cil
libmono-webbrowser4.0-cil libmono-webmatrix-data4.0-cil libmono-windowsbase4.0-cil libmono-xbuild-tasks4.0-cil
libmonoboehm-2.0-1 libmonoboehm-2.0-dev libwebkit2gtk-4.0-37 libwebkitgtk-3.0-0 mono-4.0-gac mono-4.0-service mono-complete
mono-csharp-shell mono-devel mono-gac mono-jay mono-mcs mono-runtime mono-runtime-common mono-runtime-sgen mono-utils
mono-xbuild monodoc-base monodoc-manual nuscratch raspberrypi-ui-mods sonic-pi
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 158 not updated.


When disabling mono-xamarin.list the "kept back" Mono Packages are not bein displayed anymore and also a further update is not being offered.
Want to see your Station values on SSH? Cumulusnow http://sandaysoft.com/forum/viewtopic.php?f=27&t=14062
Want a Start|Stop|Restart Script for CumulusMX on RaspberryPi? cumulusmx.sh http://sandaysoft.com/forum/viewtopic.php?f=27&t=13767

rogerthn
Posts: 161
Joined: Thu 11 Apr 2013 6:31 pm
Weather Station: Oregon Scientific WMR88
Operating System: Raspbian GNU/Linux 8
Location: Trollhättan Sweden
Contact:

Re: Later version of mono for Raspberry Pi 2

Post by rogerthn » Mon 28 Dec 2015 2:38 pm

steve wrote:Yes, but if you restart Cumulus, what do your graphs look like immediately afterwards?
Graphs as those on the Charts page?
Seems to be OK after 1 minute stop and then start again.
Image

User avatar
steve
Cumulus Author
Posts: 26704
Joined: Mon 02 Jun 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: Later version of mono for Raspberry Pi 2

Post by steve » Mon 28 Dec 2015 2:53 pm

rogerthn wrote:Graphs as those on the Charts page?
Seems to be OK after 1 minute stop and then start again.
Yes. Very odd. Perhaps I changed the code to work around the mono problem...

Edit: No, I didn't, so I don't know how that's working for you.
Steve

rogerthn
Posts: 161
Joined: Thu 11 Apr 2013 6:31 pm
Weather Station: Oregon Scientific WMR88
Operating System: Raspbian GNU/Linux 8
Location: Trollhättan Sweden
Contact:

Re: Later version of mono for Raspberry Pi 2

Post by rogerthn » Mon 28 Dec 2015 3:03 pm

The tooltips on the Charts page has decimal point but that is not an issue!
The issue is that with mono 4 I get log files as Dec15log.txt when it should be dec15log.txt.
Image

willyweather
Posts: 54
Joined: Tue 15 May 2012 8:50 pm
Weather Station: WH 1080
Operating System: Windows 8.1 and Raspbian
Location: Assling

Re: Later version of mono for Raspberry Pi 2

Post by willyweather » Mon 28 Dec 2015 7:24 pm

steve wrote:
willyweather wrote:It turned out to be not so easy to get a mono version other than the latest stable one.
In this thread, the user got version 4.0.2 fairly easily: http://sandaysoft.com/forum/viewtopic.p ... 5&p=113229

Does that not get you 4.0.2 now?

Edit: I tried adding deb http://plugwash.raspbian.org/mono4 jessie-mono4 main to my sources.list, installed mono-complete, and got mono 4.0.2, which detected my Fine Offset station.
I'm working on it ... currently I got a PGP issue (?) with this additional line in /etc/apt/sources.list ... ;)
Without this additional line I am still getting mono 3.2.8 ...

But thanks for the hints .. didn't fall over the other thread before ... :)

Wilfried

richard_newberry
Posts: 270
Joined: Tue 12 Apr 2011 10:23 pm
Weather Station: Watson W-8186
Operating System: Debian Buster
Location: Leicester
Contact:

Re: Later version of mono for Raspberry Pi 2

Post by richard_newberry » Thu 31 Dec 2015 11:53 am

As the saying goes, mono version 3.2.8 which comes with jessie works dont f*** with it. It works! No need to update it.
Desford Weather
http://www.desford-weather.co.uk
http://desford-weather.co.uk
Also on Desford weather underground.
Looking forward to cumulus on Linux platform it'll rock!!

willyweather
Posts: 54
Joined: Tue 15 May 2012 8:50 pm
Weather Station: WH 1080
Operating System: Windows 8.1 and Raspbian
Location: Assling

Re: Later version of mono for Raspberry Pi 2

Post by willyweather » Sat 02 Jan 2016 4:07 pm

Hmm, is the content of the software package Mono 3.2.8 different in Wheezy and Jessie ?
If not, then I'm doubting, that Mono 3.2.8 will work for the users of non english locales ...
I had may experiences in spring 2015 (using Wheezy, though) ...

rogerthn
Posts: 161
Joined: Thu 11 Apr 2013 6:31 pm
Weather Station: Oregon Scientific WMR88
Operating System: Raspbian GNU/Linux 8
Location: Trollhättan Sweden
Contact:

Re: Later version of mono for Raspberry Pi 2

Post by rogerthn » Sat 02 Jan 2016 5:36 pm

I am running with Mono 3.2.8 on Wheezy with Swedish locale

Code: Select all

sudo mono CumulusMX.exe -lang sv-SE
About to try on Jessie shortly.
Image

rogerthn
Posts: 161
Joined: Thu 11 Apr 2013 6:31 pm
Weather Station: Oregon Scientific WMR88
Operating System: Raspbian GNU/Linux 8
Location: Trollhättan Sweden
Contact:

Re: Later version of mono for Raspberry Pi 2

Post by rogerthn » Wed 13 Jan 2016 7:31 pm

Mono 3.2.8 on Jessie with Swedish locale is also OK 8-)
Image

bigmacd
Posts: 15
Joined: Sun 29 Mar 2015 8:49 pm
Weather Station: Fineoffset
Operating System: Windows 10
Location: UK, Hereford

Re: Later version of mono for Raspberry Pi 2

Post by bigmacd » Thu 29 Sep 2016 10:23 am

I upgraded to PIXEL - the latest Raspberry Pi offering https://www.raspberrypi.org/blog/.

So far not much luck with CumulusMX.

Code: Select all

pi@raspberrypi:~/Documents/CumulusMX $ sudo mono CumulusMX.exe
Current culture: English (United Kingdom)
[ERROR] FATAL UNHANDLED EXCEPTION: System.TypeInitializationException: An exception was thrown by the type initializer for CumulusMX.Cumulus ---> System.TypeLoadException: Could not load type 'System.Net.Http.HttpClientHandler' from assembly 'System.Net.Http, Version=1.5.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a'.
  --- End of inner exception stack trace ---
  at .Main (System.String[] args) [0x00000] in <filename unknown>:0 
I'm sure you are all going to tell me to downgrade MONO...

Code: Select all

Mono JIT compiler version 4.0.2 (Debian 4.0.2.5+dfsg-2~rpi1)
Copyright (C) 2002-2014 Novell, Inc, Xamarin Inc and Contributors. http://www.mono-project.com
	TLS:           __thread
	SIGSEGV:       normal
	Notifications: epoll
	Architecture:  armel,vfp+hard
	Disabled:      none
	Misc:          softdebug 
	LLVM:          supported, not enabled.
	GC:            sgen

User avatar
steve
Cumulus Author
Posts: 26704
Joined: Mon 02 Jun 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: Later version of mono for Raspberry Pi 2

Post by steve » Thu 29 Sep 2016 10:31 am

Apart from 3.2.8, which seems to be completely bulletproof, 4.0.x appears to be quite a good version of Mono as far as MX is concerned. Do you have the full mono-complete package installed?
Steve

bigmacd
Posts: 15
Joined: Sun 29 Mar 2015 8:49 pm
Weather Station: Fineoffset
Operating System: Windows 10
Location: UK, Hereford

Re: Later version of mono for Raspberry Pi 2

Post by bigmacd » Thu 29 Sep 2016 10:40 am

Hi Steve - it is as delivered by the Raspberry pi PIXEL upgrade instructions.

I'm just about to download a new NOOBS and start fresh.

User avatar
steve
Cumulus Author
Posts: 26704
Joined: Mon 02 Jun 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: Later version of mono for Raspberry Pi 2

Post by steve » Thu 29 Sep 2016 10:46 am

A standard installation may not include the full Mono distribution (i.e. the mono-complete package) as required by MX.
Steve

bigmacd
Posts: 15
Joined: Sun 29 Mar 2015 8:49 pm
Weather Station: Fineoffset
Operating System: Windows 10
Location: UK, Hereford

Re: Later version of mono for Raspberry Pi 2

Post by bigmacd » Thu 29 Sep 2016 10:57 am

Thanks for the warning!

BigOkie
Posts: 205
Joined: Tue 28 May 2013 1:06 am
Weather Station: Davis VP2
Operating System: Raspian Jessie
Location: Tulsa, OK

Re: Later version of mono for Raspberry Pi 2

Post by BigOkie » Thu 29 Sep 2016 4:10 pm

bigmacd wrote:Thanks for the warning!
I use 4.0.5 on mine and it's been running now for nearly three weeks straight.

Post Reply