Welcome to the new home of the Cumulus Support forum.

Latest Cumulus release v1.9.4 (build 1099) - Nov 28 2014
Latest Cumulus MX release - v3.0.0 build 3044 7 December 2018. See the Wiki for download

Wind rose on the gauges page

Discussion of version 3 of Cumulus, which runs on Windows, Linux, and OS X. All Cumulus MX queries in here, please.

Moderator: mcrossley

Post Reply
User avatar
jpsc
Posts: 163
Joined: Tue 23 Aug 2011 6:06 pm
Weather Station: Davis Vantage Vue, belfryboy USB
Operating System: Raspbian Jessie
Location: Wye valley, Herefordshire, UK
Contact:

Wind rose on the gauges page

Post by jpsc » Sun 25 Jan 2015 11:13 pm

Is the wind rose 180 degrees out, or is wind rose defined as where it is blowing to? How far back does the aggregation go?
John Cooper

Cumulus MX on RPi3 with SSD

http://weather.mountpleasanthouse.uk

Image

Adrian Hudson
Posts: 215
Joined: Mon 03 Jan 2011 4:27 pm
Weather Station: Davis Vantage Pro2
Operating System: Win 7
Location: Willand, mid Devon.
Contact:

Re: Wind rose on the gauges page

Post by Adrian Hudson » Sun 25 Jan 2015 11:35 pm

Err, no. The wind rose works normally, i.e. where the wind is coming from. Aggregation appears to be the last 10 minutes. Steve will correct me if I am wrong on that last.

water01
Posts: 1488
Joined: Sat 13 Aug 2011 9:33 am
Weather Station: WH1081
Operating System: Windows 7 64bit HP SP1
Location: Somewhere in the USA
Contact:

Re: Wind rose on the gauges page

Post by water01 » Sun 25 Jan 2015 11:47 pm

I think I would be majorly concerned we needed an Ark soon looking at your rainfall figures!!

Highest Rain Rate 683.0 mm/hr at 10:14 on 10 January 2015
Highest Hourly Rainfall 158.7 mm at 17:24 on 09 January 2015
Highest Daily Rainfall 399.0 mm on 10 January 2015

15 inches of rain in a day at a rate of 27 inches an hour is biblical!!

User avatar
dane
Posts: 410
Joined: Wed 10 Sep 2008 2:15 pm
Weather Station: Rosenborg 68700
Operating System: Win10 Ult., 64-bit, RaspberryPi
Location: Gilleleje, Denmark

Re: Wind rose on the gauges page

Post by dane » Mon 26 Jan 2015 12:46 am

I, too, have difficulties understanding the wind roses :?:
In my case, they show East as the dominant wind direction:
windrose.JPG
but according to my wind direction chart, wind from East has been registered only once :?:
winddir.JPG
Ib

User avatar
steve
Cumulus Author
Posts: 26714
Joined: Mon 02 Jun 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: Wind rose on the gauges page

Post by steve » Mon 26 Jan 2015 8:27 am

The wind rose is the standard one from Mark's SteelSeries gauges. That's not to say that if it is displaying incorrect data it is Mark's fault. It uses the <#WindRoseData> web tag, which is a set of total speed values for each of 16 compass directions (or 8, if you have configured Cumulus to use 8 if your station tends to only supply 8 as Fine Offset often do) accumulated over the last (up to) 3600 wind readings, starting from when you last started Cumulus. The period this covers thus depends on how often a wind reading is received and depends on the station type. On Fine Offset this is therefore about 10 hours, and on Davis it is about 2 or 3 hours (assuming Cumulus has been running that long). This is an inconsistency in both Cumulus 1 and MX that I will hopefully get around to addressing one day.

Note from the above that the calculation takes into account the wind speed, and on the FO stations the wind speed used is the 'gust' value; this is something else that I may look at changing, as it's possibly not a very useful way of doing it. Then again, the other speed provided by the FO isn't a great deal better for this purpose; it probably just about edges the gust value, though.
Steve

User avatar
mcrossley
Posts: 5236
Joined: Thu 07 Jan 2010 9:44 pm
Weather Station: Davis VP2
Operating System: Stretch Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: Wind rose on the gauges page

Post by mcrossley » Mon 26 Jan 2015 9:13 am

dane wrote:I, too, have difficulties understanding the wind roses :?:
In my case, they show East as the dominant wind direction:
windrose.JPG
but according to my wind direction chart, wind from East has been registered only once :?:
winddir.JPG
On your public web site the rose is showing East as the dominant direction (though it is also reporting remote sensor contact lost), your trends graph shows that it should be SE. The data in the realitmegauges.txt file does show East as the dominant direction though.
[0, 0, 35.7, 714, 1469.7, 65.7, 7.7, 47.9, 0, 0, 0, 0, 0, 0, 0, 0]

User avatar
steve
Cumulus Author
Posts: 26714
Joined: Mon 02 Jun 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: Wind rose on the gauges page

Post by steve » Mon 26 Jan 2015 10:03 am

I'm reasonably convinced that it's working correctly. Here's my graph data for the last couple of hours (with a VP, so that's the period covered by the wind rose):
2015-01-26 09_52_04-Sanday weather.png
Here's my wind rose:
2015-01-26 09_54_24-Sanday weather.png
Here's the data that the wind rose is using:

"WindRoseData":[0,0,0,0,0,0,0,0,0,0,0,73,32565,33428,1674,0]

That corresponds to WSW=11 W=32565 WNW=33428 NW=1674

Bear in mind that not every wind reading is plotted on the graph, and with FO stations the wind vane can flap around considerably.
You do not have the required permissions to view the files attached to this post.
Steve

User avatar
dane
Posts: 410
Joined: Wed 10 Sep 2008 2:15 pm
Weather Station: Rosenborg 68700
Operating System: Win10 Ult., 64-bit, RaspberryPi
Location: Gilleleje, Denmark

Re: Wind rose on the gauges page

Post by dane » Mon 26 Jan 2015 12:10 pm

Still do not see how these 2 gauges make sense, taken together:
wind.JPG
All other directions than East have been plotted more frequently, according to the wind direction graph.
Ib

User avatar
steve
Cumulus Author
Posts: 26714
Joined: Mon 02 Jun 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: Wind rose on the gauges page

Post by steve » Mon 26 Jan 2015 12:54 pm

Have you set the number of wind rose points to 8? I suspect that the code which creates the wind rose data web tag is using the wrong variable and always sending 16 values. Your values are all bunched together in the first 8 values and the rest are zero:

"WindRoseData":[13.7,6.2,61.7,303.9,1661.7,276.8,72.6,70.2,0.0,0.0,0.0,0.0,0.0,0.0,0.0,0.0]

In other words, your large value is actually South.
Steve

User avatar
dane
Posts: 410
Joined: Wed 10 Sep 2008 2:15 pm
Weather Station: Rosenborg 68700
Operating System: Win10 Ult., 64-bit, RaspberryPi
Location: Gilleleje, Denmark

Re: Wind rose on the gauges page

Post by dane » Mon 26 Jan 2015 1:09 pm

Yes - I have set the number of wind rose points to 8 in my Cumulus.ini.
I did that as suggested, because the wind rose lines on the internet gauges page were thin, black lines.
Ib

Birger
Posts: 9
Joined: Thu 05 Sep 2013 6:25 pm
Weather Station: FineOffset WH1080
Operating System: Windows 7 + Raspberry Pi
Location: Aarhus N, Denmark

Re: Wind rose on the gauges page

Post by Birger » Mon 26 Jan 2015 4:08 pm

Odd Wind Rose.jpg
I experience the same strange mirroring.
The station is an WH1080. Windrose is changed to 8 points Cumulus.ini.
Cumulus b3013 running stable on a Raspberry Pi.

/ Birger
You do not have the required permissions to view the files attached to this post.

User avatar
steve
Cumulus Author
Posts: 26714
Joined: Mon 02 Jun 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: Wind rose on the gauges page

Post by steve » Mon 26 Jan 2015 4:33 pm

Birger wrote:The station is an WH1080. Windrose is changed to 8 points Cumulus.ini.
Explanation in my previous post.
Steve

Birger
Posts: 9
Joined: Thu 05 Sep 2013 6:25 pm
Weather Station: FineOffset WH1080
Operating System: Windows 7 + Raspberry Pi
Location: Aarhus N, Denmark

Re: Wind rose on the gauges page

Post by Birger » Mon 26 Jan 2015 9:31 pm

Wind Rose.jpg
Looks right now ;)
WH1080 on RaspberryPi with build b3015.

/Birger
You do not have the required permissions to view the files attached to this post.

User avatar
steve
Cumulus Author
Posts: 26714
Joined: Mon 02 Jun 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: Wind rose on the gauges page

Post by steve » Mon 26 Jan 2015 9:32 pm

Thanks.
Steve

User avatar
jpsc
Posts: 163
Joined: Tue 23 Aug 2011 6:06 pm
Weather Station: Davis Vantage Vue, belfryboy USB
Operating System: Raspbian Jessie
Location: Wye valley, Herefordshire, UK
Contact:

Re: Wind rose on the gauges page

Post by jpsc » Mon 26 Jan 2015 9:40 pm

Have been away from the forums for a bit

Yes, I have 8 wind directions selected for my FO station, so that's the explanation.

The rain issue is due to the mast the sensors is on being a rather flimsy B&Q cranked aluminium aerial mast and is rather affected by vibration, in high winds this trips the buckets. When I find a more substantial steel mast I'll fit it. Issue is probably something to do with resonant frequency of the mast and that of the buckets, I could probably improve things by adding some mass.
John Cooper

Cumulus MX on RPi3 with SSD

http://weather.mountpleasanthouse.uk

Image

Post Reply