Welcome to the new home of the Cumulus Support forum.

Latest Cumulus release v1.9.4 (build 1099) - Nov 28 2014
Latest Cumulus MX release - v3.0.0 build 3043 Jan 20 2017. See the Wiki for download

Gauges not being displayed correctly on website

Discussion of version 3 of Cumulus, which runs on Windows, Linux, and OS X. All Cumulus MX queries in here, please.
Safety
Posts: 26
Joined: Fri Apr 09, 2010 7:32 pm
Weather Station: Davis Pro
Operating System: win xp

Gauges not being displayed correctly on website

Post by Safety » Fri Jan 09, 2015 7:10 pm

Hi
Could some kind person take a look at http://www.dfweather.co.uk/CumulusMX/gauges.htm and point me to why I am not displaying the gauges correctly.

User avatar
steve
Cumulus Author
Posts: 26713
Joined: Mon Jun 02, 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: Gauges not being displayed correctly on website

Post by steve » Fri Jan 09, 2015 7:43 pm

There are two problems. The first is that there are missing instructions; I had assumed that people would be familiar with setting up the SteelSeries gauges, clearly this isn't true for everyone. There is a file called realtimegaugesT.txt in the supplied web folder. You need to add it to the 'extra files' configuration to get Cumulus to process it and upload it.
Local = <path to the CumulusMX web folder>\realtimegaugesT.txt
Remote = <path on your ftp server to where your web pages are/realtimegauges.txt
and select Process, Realtime and FTP.

The second problem is that you are missing a CSS file on your site: css/gauges-ss.css - you should find this in the Cumulus MX distribution in the webfiles folder.

You are also missing the CSS file for the graphs.
Steve

Safety
Posts: 26
Joined: Fri Apr 09, 2010 7:32 pm
Weather Station: Davis Pro
Operating System: win xp

Re: Gauges not being displayed correctly on website

Post by Safety » Fri Jan 09, 2015 8:25 pm

Thank you for the feedback . I have attached a screen dump regarding missing file on my site as you can see it was uploaded unless i am missing something. Also your comment regarding missing the css file for the graphs could you elaborate what file?

I will work through the realtime...upload issue now.

Thank you , and thank you for all the work you have undertaken for all of us.
You do not have the required permissions to view the files attached to this post.

User avatar
duke
Posts: 840
Joined: Sun Jul 03, 2011 6:23 pm
Weather Station: Davis VP2 Plus - 24hr FARS
Operating System: Windows 10 - 64 bit
Location: Eastleigh, Hampshire, UK
Contact:

Re: Gauges not being displayed correctly on website

Post by duke » Fri Jan 09, 2015 9:37 pm

The 'css directory you have created needs to be 'css' and not 'CSS' - case sensitive.
Duke

Nightingale Weather
Eastleigh, Hampshire, UK
------------------------------------------------------
Validate your pages - often!

Safety
Posts: 26
Joined: Fri Apr 09, 2010 7:32 pm
Weather Station: Davis Pro
Operating System: win xp

Re: Gauges not being displayed correctly on website

Post by Safety » Fri Jan 09, 2015 10:58 pm

Thank you for the replay. From your advice one step nearer , as you can see now need to work out what else needs to be corrected.

Safety
Posts: 26
Joined: Fri Apr 09, 2010 7:32 pm
Weather Station: Davis Pro
Operating System: win xp

Re: Gauges not being displayed correctly on website

Post by Safety » Sat Jan 10, 2015 10:37 am

As you can see I still have not been able to get this working, If a file called realtimeguages.txt should be in the same file area of my website as gauges.htm it is not anywhere to be seen. I have attached some screen dumps of my setting configurations. Note I cannot see a save button on the "extra files" tab
You do not have the required permissions to view the files attached to this post.

User avatar
steve
Cumulus Author
Posts: 26713
Joined: Mon Jun 02, 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: Gauges not being displayed correctly on website

Post by steve » Sat Jan 10, 2015 11:36 am

You appear to be using free hosting. It is likely that they don't support .txt files. To get around this, you could use a different (supported) extension for the file in the remote box, and modify the gauges.js file on the web site to look for the new file name. Change this line:

realTimeURL_Cumulus: 'realtimegauges.txt', //*** Cumulus Users: Change to your location of the realtime file ***
Steve

Safety
Posts: 26
Joined: Fri Apr 09, 2010 7:32 pm
Weather Station: Davis Pro
Operating System: win xp

Re: Gauges not being displayed correctly on website

Post by Safety » Sat Jan 10, 2015 2:42 pm

Just for the record I use http://www.freevirtualservers.com/lite-web-hosting

Could you confirm this was your intention?
By using the xx.jpg extension I can now see the file in the same website area as the gauges.htm file.
I have attached a screen dump of the file path of my updated remote file path.
You also required me to modify
// The realtime files should be absolute paths, "/xxx.txt" refers to the public root of your web server
realTimeURL_Cumulus: "/public_html/CumulusMX/realtimegauges.jpg", //*** Cumulus Users: Change to your location of the realtime file ***

in the Scripts/gauges.js file
Have I understood you correctly?
You do not have the required permissions to view the files attached to this post.

User avatar
steve
Cumulus Author
Posts: 26713
Joined: Mon Jun 02, 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: Gauges not being displayed correctly on website

Post by steve » Sat Jan 10, 2015 3:29 pm

Yes, that's right. You might need to experiment with the file extension, .jpg might cause the server to send it in a way that the javascript doesn't like. Mark might be able to offer advice.
Steve

User avatar
mcrossley
Posts: 5206
Joined: Thu Jan 07, 2010 9:44 pm
Weather Station: Davis VP2
Operating System: Stretch Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: Gauges not being displayed correctly on website

Post by mcrossley » Sat Jan 10, 2015 9:29 pm

The first thing I would try is actually the correct file extension to use, ".json" That should have a mime type of "application/json" on your server.

Safety
Posts: 26
Joined: Fri Apr 09, 2010 7:32 pm
Weather Station: Davis Pro
Operating System: win xp

Re: Gauges not being displayed correctly on website

Post by Safety » Sun Jan 11, 2015 12:27 pm

Thank you Mark for your feedback.
I have updated the remote file path thus /public_html/CumulusMX/realtimegauges.json and can be seen within the website.

Updated the gauge file to reflect the path as a string "/public_html/CumulusMX/realtimegauges.json"

However as you can still see I have a problems still ** Text file download corrupted retrying ** looking at the file that has been exported it states 1.4kb and you can see the modified time-stamp altering.
What am I over looking?

User avatar
steve
Cumulus Author
Posts: 26713
Joined: Mon Jun 02, 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: Gauges not being displayed correctly on website

Post by steve » Sun Jan 11, 2015 12:43 pm

Your gauges.js is still looking for the original filename.

http://www.dfweather.co.uk/CumulusMX/scripts/gauges.js

realTimeURL_Cumulus: 'realtimegauges.txt', //*** Cumulus Users: Change to your location of the realtime file ***
Steve

Safety
Posts: 26
Joined: Fri Apr 09, 2010 7:32 pm
Weather Station: Davis Pro
Operating System: win xp

Re: Gauges not being displayed correctly on website

Post by Safety » Sun Jan 11, 2015 1:53 pm

Thank you for getting back.

Obviously got confused as I updated the gauges.js in the /media/usb/CumulusMXDist/webfiles/scrips/

I have now updated the gauges.js file as per **realTimeURL_Cumulus: "/public_html/CumulusMX/realtimegauges.json", ** in the public_html/CumulusMX/scripts.

However as you can see now get HTTP request Failed error not found

User avatar
steve
Cumulus Author
Posts: 26713
Joined: Mon Jun 02, 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: Gauges not being displayed correctly on website

Post by steve » Sun Jan 11, 2015 2:01 pm

realTimeURL_Cumulus: "/public_html/CumulusMX/realtimegauges.json", //*** Cumulus Users: Change to your location of the realtime file ***

Instead of just changing the extension from txt to json, i.e,

realTimeURL_Cumulus: 'realtimegauges.json', //*** Cumulus Users: Change to your location of the realtime file ***

you have replaced the whole thing with a path in the filesystem on the server. JavaScript runs in the browser, not on the server, and any references you put in a script have to be to something that a browser can retrieve using http. The browser doesn't know anything about the setup of your filestore, e.g. the public_html directory. The change you have made means that a browser will now try to load http://www.dfweather.co.uk/public_html/ ... auges.json, which (correctly) gives a 'not found'.
Steve

Safety
Posts: 26
Joined: Fri Apr 09, 2010 7:32 pm
Weather Station: Davis Pro
Operating System: win xp

Re: Gauges not being displayed correctly on website

Post by Safety » Sun Jan 11, 2015 2:15 pm

Thank you , thank you for all the help.
I had tried different centext but just could not get it to work, so just copied and pasted the whole line that you sent and it all worked.

:D

Post Reply