Welcome to the Cumulus Support forum.

Latest Cumulus MX release 3.6.6 (build 3082) - 1 June 2020 (please see important announcement regarding releases since 3.5.0)
Legacy Cumulus 1 release v1.9.4 (build 1099) - 28 November 2014 (a patch is available for 1.9.4 build 1099 that extends the date range of the NOAA report and Snow Index drop-down menus to 2030)

See the Wiki to download the software or click on the Downloads link in the Forum Banner.

Can't Find Extra Web Files

From build 3044 the development baton passed to Mark Crossley. Mark has been responsible for all the Builds since. He has made the code available on GitHub. It is Mark's hope that others will join in this development, but at the very least he welcomes your ideas for future developments (see Cumulus MX Development suggestions).

Moderator: mcrossley

User avatar
mcrossley
Posts: 6487
Joined: Thu 07 Jan 2010 9:44 pm
Weather Station: Davis VP2
Operating System: Buster Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: Can't Find Extra Web Files

Post by mcrossley »

On my pi it is /dev/ttyUSB0

It should be whatever you have configured in Cumulus.

ronwright418
Posts: 88
Joined: Thu 06 Sep 2012 7:08 pm
Weather Station: Davis Vantage Pro2
Operating System: Raspberry Pi 2
Location: Chesapeake, VA
Contact:

Re: Can't Find Extra Web Files

Post by ronwright418 »

Thanks Mark, mine is /dev/tty/USB0 also. However, when I log in I can't type anything. Using /dev/ttyUSB0 9600 serial. If I use a faster speed like 19200 I can't open the port. What's next? :groan: Does this have anything to do with using the 3rd party logger?
Ron
Ron Wright (ronwright418)
Image

User avatar
mcrossley
Posts: 6487
Joined: Thu 07 Jan 2010 9:44 pm
Weather Station: Davis VP2
Operating System: Buster Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: Can't Find Extra Web Files

Post by mcrossley »

When putty connects, your keystrokes will not be echoed back on screen (unless you configure putty to locally echo), so just hit <cr> a couple of times to make sure the console is awake and type "SETPER 10", you should get an OK message back (iirc).

ronwright418
Posts: 88
Joined: Thu 06 Sep 2012 7:08 pm
Weather Station: Davis Vantage Pro2
Operating System: Raspberry Pi 2
Location: Chesapeake, VA
Contact:

Re: Can't Find Extra Web Files

Post by ronwright418 »

Don't remember having no echo back with putty before, but it has been several years. Getting no response with '<cr>...+<cr> SETPER 10' . Also tried 'TEST ^j' as Steve suggestd in a different thread. Doing this with Cumulus turned off. With Cumulus turned on I get apparent responses from the console as soon as I start putty (which I cannot type over or break), so I'm sure the console is actively communicating.
Ron Wright (ronwright418)
Image

Post Reply