Welcome to the new home of the Cumulus Support forum.

Latest Cumulus release v1.9.4 (build 1099) - Nov 28 2014
Latest Cumulus MX release - v3.0.0 build 3044 7 December 2018. See the Wiki for download

System information page is showing wrong os

Discussion of Jacques DesRoches's web site templates

Moderator: JacquesD

Post Reply
M1DUL
Posts: 260
Joined: Wed 31 Dec 2008 1:56 pm
Weather Station: W-8681 Solar Weather Station
Operating System: Windows 10 Pro 64bit Build 10586
Location: Poole, Dorset UK
Contact:

System information page is showing wrong os

Post by M1DUL » Sun 13 Dec 2015 7:01 pm

Hi Folks,
I am using Weather Blues version 2 Template. I have noticed on my website that in the About System information page, in the system configuration box, it says that I'm using Windows version 8 x 64 build 9200,
but I am using Windows 10 operating system.

Please does anyone know how to rectify this.

Also in the Station status box the station type name is going outside of the box, is there a way of rectifying this?

My webpage I am talking about it is at http://branksomeweather.co.uk/system.php

Kind Regards
Michael

User avatar
steve
Cumulus Author
Posts: 26714
Joined: Mon 02 Jun 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: System information page is showing wrong os

Post by steve » Mon 14 Dec 2015 8:15 am

M1DUL wrote: it says that I'm using Windows version 8 x 64 build 9200,
but I am using Windows 10 operating system.
It's presumably using the <#OsVersion> web tag in some way? The component which supplies that to Cumulus doesn't know about Windows 10. You will need to edit it to either manually correct it, or remove it. I can't help with how you do that as I don't know how it all works - if it uses a PHP include file of web tags, the best way, if you want to correct it rather than remove it, would probably be to edit the template for that.
Steve

M1DUL
Posts: 260
Joined: Wed 31 Dec 2008 1:56 pm
Weather Station: W-8681 Solar Weather Station
Operating System: Windows 10 Pro 64bit Build 10586
Location: Poole, Dorset UK
Contact:

Re: System information page is showing wrong os

Post by M1DUL » Mon 14 Dec 2015 6:51 pm

steve wrote:It's presumably using the <#OsVersion> web tag in some way? The component which supplies that to Cumulus doesn't know about Windows 10. You will need to edit it to either manually correct it, or remove it. I can't help with how you do that as I don't know how it all works - if it uses a PHP include file of web tags, the best way, if you want to correct it rather than remove it, would probably be to edit the template for that.
Hi Steve,
Thank you for the reply to my message. Yes it is using the <#OsVersion> web tag, it is also using the php code script.

I will have a go at editing the template etc.

Many Thanks
Regards
Mike

User avatar
JacquesD
Posts: 605
Joined: Tue 27 Jul 2010 3:51 am
Weather Station: National Geographic 265nc
Operating System: XP SP3
Location: St-Ours, Québec, Canada
Contact:

Re: System information page is showing wrong os

Post by JacquesD » Tue 15 Dec 2015 1:46 am

Hi Mike,

As a "patch", you could simply edit file wt_data_inc.php.

Locate these lines (#686):

//-- Section WEBTAGS SYSTEM --
$OsVersion = '<#OsVersion>';


... and change text... <#OsVersion> ...with something more accurate.

Also, be careful with future updates en this file.

Regards,
Jacques
Image

M1DUL
Posts: 260
Joined: Wed 31 Dec 2008 1:56 pm
Weather Station: W-8681 Solar Weather Station
Operating System: Windows 10 Pro 64bit Build 10586
Location: Poole, Dorset UK
Contact:

Re: System information page is showing wrong os

Post by M1DUL » Tue 15 Dec 2015 9:19 pm

JacquesD wrote:Hi Mike,

As a "patch", you could simply edit file wt_data_inc.php.

Locate these lines (#686):

//-- Section WEBTAGS SYSTEM --
$OsVersion = '<#OsVersion>';


... and change text... <#OsVersion> ...with something more accurate.

Also, be careful with future updates en this file.

Regards,
Jacques
Hi Jacques,
Thank you for your reply to my message. I have sorted it now, here is the code if anyone else wants it.

Locate these lines (#749-750):

//-- Section WEBTAGS SYSTEM --
$OsVersion = "Windows 10 Pro 10586";


Many Thanks for your help Jacques.

User avatar
tomcatuk
Posts: 320
Joined: Fri 26 Dec 2008 4:41 pm
Weather Station: ----> Davis Vantage Vue
Operating System: Windows 10 v1809
Location: Buckingham

Re: System information page is showing wrong os

Post by tomcatuk » Tue 23 Feb 2016 7:55 pm

Thank you for your reply to my message. I have sorted it now, here is the code if anyone else wants it.

Locate these lines (#749-750):

//-- Section WEBTAGS SYSTEM --
$OsVersion = "Windows 10 Pro 10586";
Hi Mike I've only just noticed this on my status page (running windows 10 pro) but not sure where or what I should be editing?
Regards Steve

M1DUL
Posts: 260
Joined: Wed 31 Dec 2008 1:56 pm
Weather Station: W-8681 Solar Weather Station
Operating System: Windows 10 Pro 64bit Build 10586
Location: Poole, Dorset UK
Contact:

Re: System information page is showing wrong os

Post by M1DUL » Tue 23 Feb 2016 8:24 pm

tomcatuk wrote:
Hi Mike I've only just noticed this on my status page (running windows 10 pro) but not sure where or what I should be editing?
Hi Tom,
All you need to do is find and edit file wt_data_inc.php. in your website folder
and Locate these lines it is near to the end of the file so just look for Webtags System.

//-- Section WEBTAGS SYSTEM --
$OsVersion = '<#OsVersion>';

and then change it to
//-- Section WEBTAGS SYSTEM --
$OsVersion = "Windows 10 Pro 10586";

or what ever you want to put in there.
I hope this helps? let me now If you need any more help with it.

User avatar
tomcatuk
Posts: 320
Joined: Fri 26 Dec 2008 4:41 pm
Weather Station: ----> Davis Vantage Vue
Operating System: Windows 10 v1809
Location: Buckingham

Re: System information page is showing wrong os

Post by tomcatuk » Tue 23 Feb 2016 9:45 pm

Thank you, such a long time since I have done anything to cumulus forgot about looking there, will have a look later thanks
Regards Steve

User avatar
tomcatuk
Posts: 320
Joined: Fri 26 Dec 2008 4:41 pm
Weather Station: ----> Davis Vantage Vue
Operating System: Windows 10 v1809
Location: Buckingham

Re: System information page is showing wrong os

Post by tomcatuk » Wed 24 Feb 2016 9:17 am

Hi Mike think the trouble is I am using the std cumulus templates as that file you are referring to I don't have... :-(
But sorted it out anyway.... thanks for the help :D
Regards Steve

M1DUL
Posts: 260
Joined: Wed 31 Dec 2008 1:56 pm
Weather Station: W-8681 Solar Weather Station
Operating System: Windows 10 Pro 64bit Build 10586
Location: Poole, Dorset UK
Contact:

Re: System information page is showing wrong os

Post by M1DUL » Wed 24 Feb 2016 9:12 pm

tomcatuk wrote:Hi Mike think the trouble is I am using the std cumulus templates as that file you are referring to I don't have... :-(
But sorted it out anyway.... thanks for the help :D
You are very welcome I am glad that I could help you, I am glad that you could also find a way of changing it.

Post Reply