Welcome to the Cumulus Support forum.

Latest Cumulus MX release v3.3.0 build 3063 - 10 January 2020.
    Legacy Cumulus 1 release v1.9.4 (build 1099) - 28 November 2014

    See the Wiki for downloading either version.

    installing weather Blues ver2

    Discussion of Jacques DesRoches's web site templates

    Moderator: JacquesD

    Post Reply
    User avatar
    K8POS
    Posts: 94
    Joined: Sat 03 Jan 2015 4:17 am
    Weather Station: Davis Vantage Pro2
    Operating System: Windows 7
    Location: Thumb of Michigan
    Contact:

    installing weather Blues ver2

    Post by K8POS » Mon 09 Feb 2015 6:35 pm

    Right now I have cumulus with the SS gauges and sunny weather templates running.
    To upgrade to the blues template, what all should I remove from my current web server and pc?

    User avatar
    JacquesD
    Posts: 607
    Joined: Tue 27 Jul 2010 3:51 am
    Weather Station: National Geographic 265nc
    Operating System: XP SP3
    Location: St-Ours, Québec, Canada
    Contact:

    Re: installing weather Blues ver2

    Post by JacquesD » Tue 10 Feb 2015 12:52 am

    Hi,

    Everything you need is into .zip file, so, you could flush
    all files and copy archive content as indicated intemplate guide.

    Regards,
    Jacques

    User avatar
    K8POS
    Posts: 94
    Joined: Sat 03 Jan 2015 4:17 am
    Weather Station: Davis Vantage Pro2
    Operating System: Windows 7
    Location: Thumb of Michigan
    Contact:

    Re: installing weather Blues ver2

    Post by K8POS » Sun 15 Feb 2015 5:47 am

    Jacques,
    Have it up and running in a test area on my server.
    Do you have some more info on how to change a few things more to my location.
    I can not figure out where you have the Google Map embedded, on the "INFOS" page.
    Some of the gauges are not centered and show in K/hr not in MPH.
    I intend to soon change the gauges over to the SS gauges anyway.
    Still need to add the other graphs to the trends page.


    http://melvinweather.com/testphp/index.php

    I have figured much of it out so far.

    Bob

    User avatar
    JacquesD
    Posts: 607
    Joined: Tue 27 Jul 2010 3:51 am
    Weather Station: National Geographic 265nc
    Operating System: XP SP3
    Location: St-Ours, Québec, Canada
    Contact:

    Re: installing weather Blues ver2

    Post by JacquesD » Sun 15 Feb 2015 1:47 pm

    Hi Bob,

    For the googlemap interactive picture, you have an iframe command in infos.php file,
    you have to replace it with yours. to do so:

    Go to googlemap and zoom your place to your convenience, then take the chain icon (link),
    a little screen will pop-up with 2 choices, link ot html. Take html code and paste it
    in your infos file. Link paste include <iframe... and long <a href... to be clickable.

    Note you have to keep width and height to 200px.

    For your gauges, you have to adjust alignement this way:

    For Wind speed gauge, edit styles.css file, search for #gauges3
    and change 90px for something smaller

    #gauges3 {
    ...
    margin: 18px 0px 0px 90px;
    }

    For Wind direction gauge, you have to edit file infos.php
    around line 104, you'll find this block and change "404px":

    <td style="padding-left:404px">
    <img src="images/windrose.png" id="WindRose" alt="" title="" />
    </td>

    For your units, check your Cumulus configuration, as this Template use
    informations from Cumulus webtags, as #tempunit.

    Best regards,
    Jacques

    User avatar
    K8POS
    Posts: 94
    Joined: Sat 03 Jan 2015 4:17 am
    Weather Station: Davis Vantage Pro2
    Operating System: Windows 7
    Location: Thumb of Michigan
    Contact:

    Re: installing weather Blues ver2

    Post by K8POS » Sun 15 Feb 2015 4:29 pm

    Jacques,

    Thank you,
    Was so busy trying to decipher some of the code I completely missed the IFRAME.
    Now have my map with proper links embedded.

    The gauge page is all messed up. No data is shown in the top left wind direction, and the top right wind speed. and data is old.
    The trends page does not update. Showing data from 2011.
    Current data on other pages is correct.

    Bob

    bennymeteo
    Posts: 28
    Joined: Sat 10 Sep 2016 5:31 pm
    Weather Station: WH3080
    Operating System: debian

    Re: installing weather Blues ver2

    Post by bennymeteo » Tue 04 Oct 2016 9:26 am

    Ho visto anche questa guida http://weatherbyyou.com/wb_sheet.php e http://weatherbyyou.com/wb_install.php
    I have also seen this guide

    Ma non ho capito cosa devo copiare lato web o cosa su raspberry in CumulusMX
    But I did not understand what I have to copy web side or something of raspberry in CumulusMX

    Lato Cumulus ho configurato e copiato solo questo files
    Cumulus side I configured and only copied the files

    /home/pi/CumulusMX/web/wt_data_inc.php

    Ma sicuro non basta mi da questo errore
    But certainly not enough for me from this mistake

    Parse error: syntax error, unexpected 'h' (T_STRING) in /web/htdocs/www.miosito.com/home/meteo/stazione1/wt_data_inc.php on line 486

    User avatar
    JacquesD
    Posts: 607
    Joined: Tue 27 Jul 2010 3:51 am
    Weather Station: National Geographic 265nc
    Operating System: XP SP3
    Location: St-Ours, Québec, Canada
    Contact:

    Re: installing weather Blues ver2

    Post by JacquesD » Sat 08 Oct 2016 12:30 pm

    Hi benny,

    As I don't have PI experience, i will suggest

    You could see that post and try attached file, as PI need different format.
    http://weatherbyyou.com/forum/index.php ... 02#msg4302

    Regards,
    Jacques

    bennymeteo
    Posts: 28
    Joined: Sat 10 Sep 2016 5:31 pm
    Weather Station: WH3080
    Operating System: debian

    Re: installing weather Blues ver2

    Post by bennymeteo » Mon 10 Oct 2016 6:27 am

    Ok Thanks I also wrote in that topic
    I've actually seen the error line looks like something
    in the given month he does not like

    Post Reply