Welcome to the new home of the Cumulus Support forum.

Latest Cumulus release v1.9.4 (build 1099) - Nov 28 2014
Latest Cumulus MX release - v3.0.0 build 3043 Jan 20 2017. See the Wiki for download

FTP isn't working after host change

Discussion of Ken True's web site templates

Moderator: saratogaWX

User avatar
PaulMy
Posts: 1711
Joined: Sun 28 Sep 2008 11:54 pm
Weather Station: Davis Vantage Pro 2+ w/Envoy USB
Operating System: Windows-8
Location: Komoka, ON Canada
Contact:

Re: FTP isn't working after host change

Post by PaulMy » Tue 04 Sep 2018 1:24 am

That appears to be from a web update. I don't think realtime.txt shows in this if it is set at Realtime interval.

Your Saratoga page starts with the current date/time but the immediately goes to yesterday's date.

Is this your data for today http://www.elgheko.us/today.htm ?

Paul

User avatar
aznetcowboy
Posts: 274
Joined: Fri 04 Jan 2013 6:03 pm
Weather Station: Davis 6153 Vantage Pro2
Operating System: Windows 10 Home 64-bit
Location: Tucson, AZ
Contact:

Re: FTP isn't working after host change

Post by aznetcowboy » Tue 04 Sep 2018 3:21 am

The really strange thing I just noticed is that the data on the Weather Underground and PWS sites is accurate.
Tom Wills
Kingston Knolls Terrace, Tucson, AZ

El Gheko Neighborhood Weather Station: http://www.elgheko.us
El Gheko Neighborhood Association: http://na.elgheko.us

Image

User avatar
mcrossley
Posts: 5209
Joined: Thu 07 Jan 2010 9:44 pm
Weather Station: Davis VP2
Operating System: Stretch Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: FTP isn't working after host change

Post by mcrossley » Tue 04 Sep 2018 11:28 am

I'd try dropping the leading / from your remote file names. Use "public_html/..." Rather than "/public_html/...”

User avatar
aznetcowboy
Posts: 274
Joined: Fri 04 Jan 2013 6:03 pm
Weather Station: Davis 6153 Vantage Pro2
Operating System: Windows 10 Home 64-bit
Location: Tucson, AZ
Contact:

Re: FTP isn't working after host change

Post by aznetcowboy » Tue 04 Sep 2018 5:04 pm

I gave it a try. changing"/public_html/" to " public_html". Much to my surprise the change was accepted. Over the years it has always been the "/public_html/" version my host required. However, the end result is unchanged. What really is confusing is when logging into the webpage, there is a momentary display in green of the actual current readings. Then it goes back to the readings of September 2nd.
Tom Wills
Kingston Knolls Terrace, Tucson, AZ

El Gheko Neighborhood Weather Station: http://www.elgheko.us
El Gheko Neighborhood Association: http://na.elgheko.us

Image

User avatar
mcrossley
Posts: 5209
Joined: Thu 07 Jan 2010 9:44 pm
Weather Station: Davis VP2
Operating System: Stretch Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: FTP isn't working after host change

Post by mcrossley » Tue 04 Sep 2018 5:21 pm

Your trends page is up to date for me http://www.elgheko.us/wxtrends.php
and the realtime.txt file is updating http://www.elgheko.us/realtime.txt

EDIT: Ah, no I see they are fairly recent, but not updating.

sfws
Posts: 461
Joined: Fri 27 Jul 2012 11:29 am
Weather Station: Customised mix of Fine Offset
Operating System: Tempermental Win. 10 PC
Location: UK

Re: FTP isn't working after host change

Post by sfws » Tue 04 Sep 2018 5:25 pm

aznetcowboy wrote: there is a momentary display in green of the actual current readings. Then it goes back to the readings of September 2nd.
I know nothing about your set-up, but seeing correct readings being overwritten suggests to me that JavaScript (perhaps as an AJAX script) is overwriting what the basic website generates. I therefore suggest that you check again, because it may just be that the web page was generated at one interval (Cumulus standard updating interval) and the script is updated at real time interval and the first real-time update happened after you looked, or maybe that script is not being FTP-ed correctly yet.

User avatar
aznetcowboy
Posts: 274
Joined: Fri 04 Jan 2013 6:03 pm
Weather Station: Davis 6153 Vantage Pro2
Operating System: Windows 10 Home 64-bit
Location: Tucson, AZ
Contact:

Re: FTP isn't working after host change

Post by aznetcowboy » Thu 06 Sep 2018 7:02 pm

I just happen to have a thought (ouch, that hurt! :bash: ). In the process of moving everything from my old host to my new host, is it possible that some file permissions got changed/modified and they aren't being updated as they should be? However, I am not certain of which files/folders to check into. Any suggestions? :?

For now I am going to do a complete backup and then restore all my files from the pre-switch backup from my old host to see if that helps. Not sure if that is wise, but it can't hurt (I hope).
Tom Wills
Kingston Knolls Terrace, Tucson, AZ

El Gheko Neighborhood Weather Station: http://www.elgheko.us
El Gheko Neighborhood Association: http://na.elgheko.us

Image

User avatar
aznetcowboy
Posts: 274
Joined: Fri 04 Jan 2013 6:03 pm
Weather Station: Davis 6153 Vantage Pro2
Operating System: Windows 10 Home 64-bit
Location: Tucson, AZ
Contact:

Re: FTP isn't working after host change

Post by aznetcowboy » Fri 07 Sep 2018 12:35 am

I have been in contact with the tech support people of my new host to have them do a complete restore of the backup from 09/01/2018. Seeing as the updating of the system started just before noon on the 2nd, the backup from the 1st is the the one to be used. We'll see what happens. Their backup method is different that the one I was used to from my older host, so I will let my current host do the restore instead my my attempting it.
Tom Wills
Kingston Knolls Terrace, Tucson, AZ

El Gheko Neighborhood Weather Station: http://www.elgheko.us
El Gheko Neighborhood Association: http://na.elgheko.us

Image

User avatar
aznetcowboy
Posts: 274
Joined: Fri 04 Jan 2013 6:03 pm
Weather Station: Davis 6153 Vantage Pro2
Operating System: Windows 10 Home 64-bit
Location: Tucson, AZ
Contact:

Re: FTP isn't working after host change

Post by aznetcowboy » Fri 07 Sep 2018 5:11 pm

Is there a file that I should be looking for in particular that is responsible for updating in real time the current readings? I am getting to the point where I am thinking (not quite seriously yet) of blowing everything away and starting all over from scratch. But that would be a last thing I would even consider. I just figure that there is one file that is malfunctioning and I need to find it.

"HELP" is the key word of the day here. I am 100% baffled at this moment.
Tom Wills
Kingston Knolls Terrace, Tucson, AZ

El Gheko Neighborhood Weather Station: http://www.elgheko.us
El Gheko Neighborhood Association: http://na.elgheko.us

Image

User avatar
PaulMy
Posts: 1711
Joined: Sun 28 Sep 2008 11:54 pm
Weather Station: Davis Vantage Pro 2+ w/Envoy USB
Operating System: Windows-8
Location: Komoka, ON Canada
Contact:

Re: FTP isn't working after host change

Post by PaulMy » Fri 07 Sep 2018 5:36 pm

Your uploads to PWs and WU appears to be current, is that right?
However realtime.txt is not.

I know you are using Saratogo so don't need to upload the standard Cumulus template files, but I would try by setting these to upload, and then see if they are. The result may be a clue.

Can you do a manual FTP i.e. Filezilla, and then using the settings from that make sure that the settings is Cumulus are the same?

I presume that if you can get the realtime.txt updating the rest will fall in place.


Good luck,

Paul

User avatar
aznetcowboy
Posts: 274
Joined: Fri 04 Jan 2013 6:03 pm
Weather Station: Davis 6153 Vantage Pro2
Operating System: Windows 10 Home 64-bit
Location: Tucson, AZ
Contact:

Re: FTP isn't working after host change

Post by aznetcowboy » Sat 08 Sep 2018 10:22 pm

I have determined that it is something with the realtime.txt file that is not being updated properly. I must be missing something that is very obvious. Here are the setting in the cumulus.ini file for the uploads to the website from my PC:


[FTP site]
Host=ftp.elgheko.us
Port=21
Username=uuuuuuuuuu@elgheko.us
Password=pppppppppp
Directory=public_html
AutoUpdate=1
ActiveFTP=1
EnableRealtime=1
RealtimeFTPEnabled=1
RealtimeTxtFTP=1
RealtimeInterval=90000
UpdateInterval=7
IncludeSTD=0
IncludeSTDImages=1
FTPRename=1
DeleteBeforeUpload=0
ResizeGraphs=0
GraphHeight=300
GraphWidth=750
ImageFolder=
ImageCopyRealtime=0
ExtraLocal0=W:\Cumulus\cloudbaseCUT.txt
ExtraRemote0=public_html/cloudbaseCU.txt
ExtraProcess0=1
ExtraBinary0=0
ExtraRealtime0=0
ExtraFTP0=1
ExtraLocal1=W:\Cumulus\realtimegaugesT.txt
ExtraRemote1=public_html/realtimegauges.txt
ExtraProcess1=1
ExtraBinary1=0
ExtraRealtime1=1
ExtraLocal2=W:\Cumulus\wxcurecordsT.php
ExtraRemote2=public_html/wxcurecords.php
ExtraProcess2=1
ExtraBinary2=0
ExtraRealtime2=0
ExtraFTP2=1
ExtraLocal3=W:\Cumulus\radar.php
ExtraRemote3=public_html/radar.php
ExtraProcess3=1
ExtraBinary3=0
ExtraRealtime3=1
ExtraFTP3=1
ExtraLocal4=W:\cumulus\CUtags.txt
ExtraRemote4=public_html/CUtags.php
ExtraProcess4=1
ExtraBinary4=0
ExtraRealtime4=0
ExtraFTP4=1
ExtraLocal5=W:\Cumulus\realtime-extra.txt
ExtraRemote5=public_html/realtime-extra.txt
ExtraProcess5=1
ExtraBinary5=0
ExtraRealtime5=1
ExtraFTP5=1
ExtraLocal6=W:\Cumulus\data\cumuluswebtags.txt
ExtraRemote6=public_html/cumuluswebtags.php
ExtraProcess6=1
ExtraBinary6=0
ExtraRealtime6=0
ExtraFTP6=1
ExtraLocal7=
ExtraRemote7=
ExtraProcess7=0
ExtraBinary7=0
ExtraRealtime7=0
ExtraFTP7=0
ExtraLocal8=
ExtraRemote8=
ExtraProcess8=0
ExtraBinary8=0
ExtraRealtime8=0
ExtraFTP8=0
ExtraLocal9=
ExtraRemote9=
ExtraProcess9=0
ExtraBinary9=0
ExtraRealtime9=0
ExtraFTP9=0
ExtraLocal10=W:\Cumulus\gauges-ss.html
ExtraRemote10=public_html/gauges-ss.htm
ExtraProcess10=1
ExtraBinary10=
ExtraRealtime10=1
ExtraFTP10=1
ExtraLocal11=W:\Cumulus\meteo.htm
ExtraRemote11=public_html/meteo.htm
ExtraProcess11=1
ExtraBinary11=
ExtraRealtime11=
ExtraFTP11=1
ExtraLocal12=W:\cumulus\davcon24T.txt
ExtraRemote12=public_html/davcon24.txt
ExtraProcess12=1
ExtraBinary12=
ExtraRealtime12=
ExtraFTP12=1
ExtraLocal13=W:\Cumulus\noaa-drought.htm
ExtraRemote13=public_html/noaa-drought.htm
ExtraProcess13=1
ExtraBinary13=
ExtraRealtime13=
ExtraFTP13=1
ExtraLocal14=W:\Cumulus\WU-History.php
ExtraRemote14=public_html/WU-History.php
ExtraProcess14=1
ExtraBinary14=
ExtraRealtime14=
ExtraFTP14=1
ExtraLocal15=W:\Cumulus\wxfiredanger.htm
ExtraRemote15=public_html/wxfiredanger.htm
ExtraProcess15=1
ExtraBinary15=
ExtraRealtime15=
ExtraFTP15=1
ExtraLocal16=W:\Cumulus\wxsevere.html
ExtraRemote16=public_html/wxsevere.htm
ExtraProcess16=1
ExtraBinary16=
ExtraRealtime16=
ExtraFTP16=1
ExtraLocal17=W:\Cumulus\wxcumonthT.php
ExtraRemote17=public_html/wxcumonth.php
ExtraProcess17=1
ExtraBinary17=
ExtraRealtime17=
ExtraFTP17=1
ExtraLocal18=W:\Cumulus\realtimeguagesT.txt
ExtraRemote18=public_html/realtimeguages.txt
ExtraProcess18=1
ExtraBinary18=
ExtraRealtime18=1
ExtraFTP18=1
ExtraLocal19=W:\Cumulus\gauges-ssT.htm
ExtraRemote19=public_html/gauges-ss.htm
ExtraProcess19=1
ExtraBinary19=
ExtraRealtime19=
ExtraFTP19=1
ExtraLocal20=W:\Cumulus\wxcutodayT.php
ExtraRemote20=public_html/wxcutoday.php
ExtraProcess20=1
ExtraBinary20=
ExtraRealtime20=
ExtraFTP20=1
ExtraLocal21=W:\Cumulus\wxcuyesterdayT.php
ExtraRemote21=public_html/wxcuyesterday.php
ExtraProcess21=1
ExtraBinary21=
ExtraRealtime21=
ExtraFTP21=1
ExtraLocal22=W:\Cumulus\wxcuyearT.php
ExtraRemote22=public_html/wxcuyear.php
ExtraProcess22=1
ExtraBinary22=
ExtraRealtime22=
ExtraFTP22=1
ExtraLocal23=W:\Cumulus\wxsystemT.php
ExtraRemote23=public_html/wxsystem.php
ExtraProcess23=1
ExtraBinary23=
ExtraRealtime23=
ExtraFTP23=1
ExtraLocal24=W:\Cumulus\data\test.htm
ExtraRemote24=public_html/data/test.htm
ExtraProcess24=1
ExtraBinary24=
ExtraRealtime24=1
ExtraFTP24=1
ExtraLocal25=W:\Cumulus\weathercloud_realtime_template.txt
ExtraRemote25=public_html/weathercloud_realtime.txt
ExtraProcess25=1
ExtraBinary25=
ExtraRealtime25=
ExtraFTP25=1
ExtraUTF25=0
ExternalProgram=
RealtimeProgram=
DailyProgram=
ExternalParams=
RealtimeParams=
DailyParams=
IncludeSolarChart=1
IncludeUVChart=0
IncludeSunshineChart=0
UTF8encode=1
ExtraUTF0=0
ExtraUTF1=0
ExtraUTF2=0
ExtraUTF3=0
ExtraUTF4=0
ExtraUTF5=0
ExtraUTF6=0
ExtraUTF7=0
ExtraUTF8=0
ExtraUTF9=0
ExtraFTP1=1


Does anyone see something amiss in this segment?
Tom Wills
Kingston Knolls Terrace, Tucson, AZ

El Gheko Neighborhood Weather Station: http://www.elgheko.us
El Gheko Neighborhood Association: http://na.elgheko.us

Image

User avatar
aznetcowboy
Posts: 274
Joined: Fri 04 Jan 2013 6:03 pm
Weather Station: Davis 6153 Vantage Pro2
Operating System: Windows 10 Home 64-bit
Location: Tucson, AZ
Contact:

Re: FTP isn't working after host change

Post by aznetcowboy » Sun 09 Sep 2018 1:14 am

I think I have it fixed. And I don't understand the reason why. What I did was add realtime.txt to the config file and downloaded to to the website in a realtime mode. Now it seems to be working. I went back to the beginning of the year backups and I don't find realtime.txt anywhere in any of the backup config files. But now it is working. Go figure. :groan:
Tom Wills
Kingston Knolls Terrace, Tucson, AZ

El Gheko Neighborhood Weather Station: http://www.elgheko.us
El Gheko Neighborhood Association: http://na.elgheko.us

Image

User avatar
ConligWX
Posts: 728
Joined: Mon 19 May 2014 10:45 pm
Weather Station: Davis Vantage Pro2 Plus
Operating System: Debian 9.5 Stretch
Location: Bangor, NI
Contact:

Re: FTP isn't working after host change

Post by ConligWX » Mon 10 Sep 2018 6:29 am

aznetcowboy wrote:I think I have it fixed. And I don't understand the reason why. What I did was add realtime.txt to the config file and downloaded to to the website in a realtime mode. Now it seems to be working. I went back to the beginning of the year backups and I don't find realtime.txt anywhere in any of the backup config files. But now it is working. Go figure. :groan:

when I looked at your status page realtime was not updated intime with your setting of every 15 secs realtime is updated.
status.JPG
Also your Saratoga Templates are in much need of updating. Just to add some more work to you updates :lol:

http://www.elgheko.us/check-fetch-times ... w=versions

infact your updates are not set to what the wxstatus page is expecting.
status1.JPG
You do not have the required permissions to view the files attached to this post.
Regards Simon

https://www.conligwx.org
https://twitter.com/conligwx
Davis Vantage Pro2 Plus - CumulusMX v3.0.0 (build 3043) + Saratoga/PWS Templates

User avatar
aznetcowboy
Posts: 274
Joined: Fri 04 Jan 2013 6:03 pm
Weather Station: Davis 6153 Vantage Pro2
Operating System: Windows 10 Home 64-bit
Location: Tucson, AZ
Contact:

Re: FTP isn't working after host change

Post by aznetcowboy » Mon 10 Sep 2018 5:37 pm

Thanks for noticing this. Boy, switching hosts sure has been more involved than I had expected. :oops:
Hopefully I have updated these extra files so they are all getting sent to the website like they should be.
Tom Wills
Kingston Knolls Terrace, Tucson, AZ

El Gheko Neighborhood Weather Station: http://www.elgheko.us
El Gheko Neighborhood Association: http://na.elgheko.us

Image

Post Reply