Welcome to the new home of the Cumulus Support forum.

Latest Cumulus release v1.9.4 (build 1099) - Nov 28 2014
Latest Cumulus MX release - v3.0.0 build 3043 Jan 20 2017. See the Wiki for download

WU-History-inc.php error in Apache Log.

Discussion of Ken True's web site templates

Moderator: saratogaWX

Post Reply
User avatar
ConligWX
Posts: 728
Joined: Mon 19 May 2014 10:45 pm
Weather Station: Davis Vantage Pro2 Plus
Operating System: Debian 9.5 Stretch
Location: Bangor, NI
Contact:

WU-History-inc.php error in Apache Log.

Post by ConligWX » Sun 04 Mar 2018 7:08 pm

Hi there

still going through some apache errors sinc eth ephp 7.2.2 upgrade and have com across this:

echo '<form method="post" action="' . $SITE['PHPSELF'] . '" />';

Code: Select all

[Sun Mar 04 18:59:06.535442 2018] [php7:notice] [pid 13629:tid 140681175590656] [client 81.104.71.6:56888] PHP Notice:  Undefined index: PHPSELF in /xxxxx/htdocs/weather/WU-History-inc.php on line 388, referer: https://www.conligwx.org/davconvp2CW.php
the line 388refer to this line:

Code: Select all

line 388 -    echo '<form method="post" action="' . $SITE['PHPSELF'] . '" />';
what is value meant to be?

ie

$SITE['PHPSELF'] = '?????';
Regards Simon

https://www.conligwx.org
https://twitter.com/conligwx
Davis Vantage Pro2 Plus - CumulusMX v3.0.0 (build 3043) + Saratoga/PWS Templates

User avatar
saratogaWX
Posts: 904
Joined: Wed 06 May 2009 5:02 am
Weather Station: Davis Vantage Pro Plus
Operating System: Windows 10 Professional
Location: Saratoga, CA, USA
Contact:

Re: WU-History-inc.php error in Apache Log.

Post by saratogaWX » Sun 04 Mar 2018 8:16 pm

Yes, a leftover old error.

Replace $SITE['PHPSELF'] with $_SERVER['PHP_SELF'] and that should fix it.

User avatar
ConligWX
Posts: 728
Joined: Mon 19 May 2014 10:45 pm
Weather Station: Davis Vantage Pro2 Plus
Operating System: Debian 9.5 Stretch
Location: Bangor, NI
Contact:

Re: WU-History-inc.php error in Apache Log.

Post by ConligWX » Sun 04 Mar 2018 9:24 pm

saratogaWX wrote:Yes, a leftover old error.

Replace $SITE['PHPSELF'] with $_SERVER['PHP_SELF'] and that should fix it.
Thanks for the update!
Regards Simon

https://www.conligwx.org
https://twitter.com/conligwx
Davis Vantage Pro2 Plus - CumulusMX v3.0.0 (build 3043) + Saratoga/PWS Templates

Post Reply