Welcome to the new home of the Cumulus Support forum.

Latest Cumulus release v1.9.4 (build 1099) - Nov 28 2014
Latest Cumulus MX release - v3.0.0 build 3044 7 December 2018. See the Wiki for download

"Cumulus Weather Data"

Discussion of Ken True's web site templates

Moderator: saratogaWX

Post Reply
acatalano
Posts: 91
Joined: Tue 16 Jun 2015 2:07 pm
Weather Station: Davis VP2
Operating System: Raspian, Win7 Pro
Location: Boulder, CO
Contact:

"Cumulus Weather Data"

Post by acatalano » Mon 27 Mar 2017 4:35 pm

I've finally gotten CUtags & realtime.txt to update properly and data is being uploaded OK,-mostly. One item which is still completely incorrect is the "cumulus weather data" age and start time, and it's status is never current. Since the realtime.txt and CUtags.php seem to be working properly, I'm at a loss to understand the remaining problem. The page also does not show the proper version of CumulusMX which is 3.0.0 Something is out of whack; I'm not sure what it is. Any suggestions would be appreciated.
Best Regards,
Anthony Catalano
Boulder, Colorado, USA
Webcam & Weather at:
http://www.boulderwx.com, http://www.apcat.org, http://www.boulderweather.org
Blitzortung Lightning Detector Station 1965

User avatar
steve
Cumulus Author
Posts: 26714
Joined: Mon 02 Jun 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: "Cumulus Weather Data"

Post by steve » Mon 27 Mar 2017 5:43 pm

The problem is that your CUtags.php does not contain your data: http://apcat.org/CUtags.php?sce=view

As for the cause, perhaps the CUtags file you are using for input to Cumulus is actually an output file, i.e, it contains real sample data from the Saratoga installation, or perhaps you have not configured Cumulus to upload the genuine file to the correct place. Or, something else.

acatalano
Posts: 91
Joined: Tue 16 Jun 2015 2:07 pm
Weather Station: Davis VP2
Operating System: Raspian, Win7 Pro
Location: Boulder, CO
Contact:

Re: "Cumulus Weather Data"

Post by acatalano » Mon 27 Mar 2017 8:53 pm

Steve
Thanks for the suggestion. Actually I corrected the problem. Way back when I set up the Saratoga Templates I had the exact same problem. In the Settings .php file, it was necessary to change the value of $Site['WDdateMDY']=true to false. So I thought I must have copied an earlier version of the php file with "true", but I had not, so I figured there was an error somewhere else. On a whim, I went back and changed it to the seemingly "incorrect" value to "true" again. Much to my surprise everything works! perhaps the Template has changed? I'm baffled, but relieved. :bash:
Best Regards,
Anthony Catalano
Boulder, Colorado, USA
Webcam & Weather at:
http://www.boulderwx.com, http://www.apcat.org, http://www.boulderweather.org
Blitzortung Lightning Detector Station 1965

Post Reply