Welcome to the new home of the Cumulus Support forum.

Latest Cumulus release v1.9.4 (build 1099) - Nov 28 2014
Latest Cumulus MX release - v3.0.0 build 3043 Jan 20 2017. See the Wiki for download

wxforecast.php doesn't work

Discussion of Ken True's web site templates

Moderator: saratogaWX

Post Reply
User avatar
aznetcowboy
Posts: 274
Joined: Fri Jan 04, 2013 6:03 pm
Weather Station: Davis 6153 Vantage Pro2
Operating System: Windows 10 Home 64-bit
Location: Tucson, AZ
Contact:

wxforecast.php doesn't work

Post by aznetcowboy » Tue May 17, 2016 4:24 pm

I seem to remember that there is some change to the wxforecast.php forecasts script that for a number of reasons I won't go into here that I wasn't able to follow up on updating. Now after all this time, I forget what was required to get it working again. :oops:

There are so many references to wxforecast.php when doing a search, I gave up trying to figure our what I need to do to get it working again. I'm appreciative of any assistance to get this working again.
Tom Wills
Kingston Knolls Terrace, Tucson, AZ

El Gheko Neighborhood Weather Station: http://www.elgheko.us
El Gheko Neighborhood Association: http://na.elgheko.us

Image

User avatar
saratogaWX
Posts: 903
Joined: Wed May 06, 2009 5:02 am
Weather Station: Davis Vantage Pro Plus
Operating System: Windows 10 Professional
Location: Saratoga, CA, USA
Contact:

Re: wxforecast.php doesn't work

Post by saratogaWX » Tue May 17, 2016 4:37 pm

Running check-fetch-times.php?show=versions on your site shows you have a few scripts to update, including advforecast2.php (the forecast script).

Use the update tool to get the scripts you need and update your site.. then all should be well :)

Best regards,
Ken

User avatar
ConligWX
Posts: 721
Joined: Mon May 19, 2014 10:45 pm
Weather Station: Davis Vantage Pro2 Plus
Operating System: Debian 9.5 Stretch
Location: Bangor, NI
Contact:

Re: wxforecast.php doesn't work

Post by ConligWX » Tue May 17, 2016 8:09 pm

saratogaWX wrote:Running check-fetch-times.php?show=versions on your site shows you have a few scripts to update, including advforecast2.php (the forecast script).

Use the update tool to get the scripts you need and update your site.. then all should be well :)

Best regards,
Ken
haha, how did I miss this? thanks for the tip!
Regards Simon

https://www.conligwx.org
https://twitter.com/conligwx
Davis Vantage Pro2 Plus - CumulusMX v3.0.0 (build 3043) + Saratoga/PWS Templates

User avatar
aznetcowboy
Posts: 274
Joined: Fri Jan 04, 2013 6:03 pm
Weather Station: Davis 6153 Vantage Pro2
Operating System: Windows 10 Home 64-bit
Location: Tucson, AZ
Contact:

Re: wxforecast.php doesn't work

Post by aznetcowboy » Mon Jun 27, 2016 6:15 pm

saratogaWX wrote:Running check-fetch-times.php?show=versions on your site shows you have a few scripts to update, including advforecast2.php (the forecast script).

Use the update tool to get the scripts you need and update your site.. then all should be well :)

Best regards,
Ken
I have just completed updating all the files that the Check-fetch-times.php indicated were out of date. It now shows every thing as current. However, my forecasts still do not show up. But, if I click on the line that says "Forecast from NOAA-NWS for . " I get the forecast. I am not sure what I missed in the update, but I don't get the forecasts for Arizona. :bash:

One positive thing, the Alerts seem to be working okay now. :)
Tom Wills
Kingston Knolls Terrace, Tucson, AZ

El Gheko Neighborhood Weather Station: http://www.elgheko.us
El Gheko Neighborhood Association: http://na.elgheko.us

Image

User avatar
saratogaWX
Posts: 903
Joined: Wed May 06, 2009 5:02 am
Weather Station: Davis Vantage Pro Plus
Operating System: Windows 10 Professional
Location: Saratoga, CA, USA
Contact:

Re: wxforecast.php doesn't work

Post by saratogaWX » Mon Jun 27, 2016 10:18 pm

You haven't uploaded the newer advforecast2.php.

Running check-fetch-times.php?show=versions on your site shows you're running 3.12 of the script. It needs to be V4.02 to work correctly. You just need to upload V4.02 of adforecast2.php to have your forecast work again. The DualImage function seems to work fine, and the rest of the key scripts on your site are at current release levels.

User avatar
aznetcowboy
Posts: 274
Joined: Fri Jan 04, 2013 6:03 pm
Weather Station: Davis 6153 Vantage Pro2
Operating System: Windows 10 Home 64-bit
Location: Tucson, AZ
Contact:

Re: wxforecast.php doesn't work

Post by aznetcowboy » Mon Jun 27, 2016 10:54 pm

saratogaWX wrote:You haven't uploaded the newer advforecast2.php.

Running check-fetch-times.php?show=versions on your site shows you're running 3.12 of the script. It needs to be V4.02 to work correctly. You just need to upload V4.02 of adforecast2.php to have your forecast work again. The DualImage function seems to work fine, and the rest of the key scripts on your site are at current release levels.
Oh man... I'm not sure what I did here, but I could have sworn the adforecast2.php was version 4.02. I really blew it this time. :groan:

Thanks for your assistance and patience in dealing with this ID10T. :oops:
Tom Wills
Kingston Knolls Terrace, Tucson, AZ

El Gheko Neighborhood Weather Station: http://www.elgheko.us
El Gheko Neighborhood Association: http://na.elgheko.us

Image

User avatar
aznetcowboy
Posts: 274
Joined: Fri Jan 04, 2013 6:03 pm
Weather Station: Davis 6153 Vantage Pro2
Operating System: Windows 10 Home 64-bit
Location: Tucson, AZ
Contact:

Re: wxforecast.php doesn't work

Post by aznetcowboy » Tue Jun 28, 2016 12:53 am

aznetcowboy wrote:
saratogaWX wrote:You haven't uploaded the newer advforecast2.php.

Running check-fetch-times.php?show=versions on your site shows you're running 3.12 of the script. It needs to be V4.02 to work correctly. You just need to upload V4.02 of adforecast2.php to have your forecast work again. The DualImage function seems to work fine, and the rest of the key scripts on your site are at current release levels.
Oh man... I'm not sure what I did here, but I could have sworn the adforecast2.php was version 4.02. I really blew it this time. :groan:

Thanks for your assistance and patience in dealing with this ID10T. :oops:
I was correct. I had v4.02 uploaded, and after a bit it reverts back to v3.12. Any ideas what is going on here? What should the file permissions be? They are set to 644.
Tom Wills
Kingston Knolls Terrace, Tucson, AZ

El Gheko Neighborhood Weather Station: http://www.elgheko.us
El Gheko Neighborhood Association: http://na.elgheko.us

Image

User avatar
saratogaWX
Posts: 903
Joined: Wed May 06, 2009 5:02 am
Weather Station: Davis Vantage Pro Plus
Operating System: Windows 10 Professional
Location: Saratoga, CA, USA
Contact:

Re: wxforecast.php doesn't work

Post by saratogaWX » Tue Jun 28, 2016 1:03 am

The advforecast2.php script never modifies itself..it has to be manually FTPed to your site. If it is being overwritten with a prior version, it could be a server backup/restore snafu, or some server-side caching in effect.

User avatar
aznetcowboy
Posts: 274
Joined: Fri Jan 04, 2013 6:03 pm
Weather Station: Davis 6153 Vantage Pro2
Operating System: Windows 10 Home 64-bit
Location: Tucson, AZ
Contact:

Re: wxforecast.php doesn't work (UPDATE)

Post by aznetcowboy » Tue Jun 28, 2016 8:48 pm

saratogaWX wrote:The advforecast2.php script never modifies itself..it has to be manually FTPed to your site. If it is being overwritten with a prior version, it could be a server backup/restore snafu, or some server-side caching in effect.
This is crazy! I don't have a version 3.12 anywhere that I can find. I can copy 4.02 to the domain sever and within seconds it is back to version 3.12. If it was something in the code, then I would expect this to be happening to people other than just me and it isn't. I am not even using any FTP utility to upload it just to make sure that isn't the problem.

I am totally baffled about what is going on here. Hopefully someone can come up with an idea. My ISP can't explain it either.


Ignore the above statement. I think it is now resolved. My ISP sent me the following: "I looked at the log, and your machine is uploading the file (STOR) as advforecast2.phptmp and then renaming (RNFR/RNTO) the file every time it connects every 5 minutes:". Is the advforecast2.php supposed to be re-uploaded every five minutes?
Tom Wills
Kingston Knolls Terrace, Tucson, AZ

El Gheko Neighborhood Weather Station: http://www.elgheko.us
El Gheko Neighborhood Association: http://na.elgheko.us

Image

User avatar
saratogaWX
Posts: 903
Joined: Wed May 06, 2009 5:02 am
Weather Station: Davis Vantage Pro Plus
Operating System: Windows 10 Professional
Location: Saratoga, CA, USA
Contact:

Re: wxforecast.php doesn't work

Post by saratogaWX » Tue Jun 28, 2016 10:33 pm

Umm.. No, it is uploaded once. Sounds like your Cumulus settings are trying to upload it as a cumulus template. Turn that setting in cumulus off, and manually upload v4.02 advforecast2.php once.

User avatar
aznetcowboy
Posts: 274
Joined: Fri Jan 04, 2013 6:03 pm
Weather Station: Davis 6153 Vantage Pro2
Operating System: Windows 10 Home 64-bit
Location: Tucson, AZ
Contact:

Re: wxforecast.php doesn't work

Post by aznetcowboy » Sun Mar 25, 2018 6:24 pm

My forecast tool (http://www.elgheko.us/wxforecast.php) has again stopped working. My ISP has informed me that he has upgraded the PHP he uses to version Php 7.0.28 and that version 5.6 is no longer available. Could this be the problem?
Tom Wills
Kingston Knolls Terrace, Tucson, AZ

El Gheko Neighborhood Weather Station: http://www.elgheko.us
El Gheko Neighborhood Association: http://na.elgheko.us

Image

User avatar
saratogaWX
Posts: 903
Joined: Wed May 06, 2009 5:02 am
Weather Station: Davis Vantage Pro Plus
Operating System: Windows 10 Professional
Location: Saratoga, CA, USA
Contact:

Re: wxforecast.php doesn't work

Post by saratogaWX » Sun Mar 25, 2018 9:09 pm

No, the issue is your advforecast2.php (multi) - V4.02 - 07-Nov-2015 -- You need to use V4.03 after the end of February, 2018 when the NWS forced all accesses to *.weather.gov to https. The V4.02 and earlier could not do https (only http).

Download the update from the script page and your forecast should be back.

You may have to do a wxforecast.php?force=1 after installation of the updated script to refresh the cache file.

User avatar
aznetcowboy
Posts: 274
Joined: Fri Jan 04, 2013 6:03 pm
Weather Station: Davis 6153 Vantage Pro2
Operating System: Windows 10 Home 64-bit
Location: Tucson, AZ
Contact:

Re: wxforecast.php doesn't work

Post by aznetcowboy » Sat Apr 07, 2018 11:31 pm

Thanks Ken! It is now working okay. I really appreciate the help!
Tom Wills
Kingston Knolls Terrace, Tucson, AZ

El Gheko Neighborhood Weather Station: http://www.elgheko.us
El Gheko Neighborhood Association: http://na.elgheko.us

Image

User avatar
aznetcowboy
Posts: 274
Joined: Fri Jan 04, 2013 6:03 pm
Weather Station: Davis 6153 Vantage Pro2
Operating System: Windows 10 Home 64-bit
Location: Tucson, AZ
Contact:

Re: wxforecast.php doesn't work

Post by aznetcowboy » Thu Jun 14, 2018 1:44 am

I was gone to Wisconsin from Mid-May until June 6. I came home to having the wxforecast giving me the following error:

The detailed point forecast weather data is not currently available.
The zone forecast data for AZZ504 (Tucson Metro Area including Tucson/Green Valley/Marana/Vail) will be displayed
until the point forecast data is again available.


A friend of mine who works at the National Weather Service office in Tucson said when he tried his link it was fine. So I extracted the "http://forecast.weather.gov/MapClick.ph ... TextType=2" from the Settings file code (below) and tried it and it works.

"AZZ504|El Gheko Neighborhood, Tucson, AZ|http://forecast.weather.gov/MapClick.ph ... TextType=2"

Has something changed in the forecasting script? :?
Tom Wills
Kingston Knolls Terrace, Tucson, AZ

El Gheko Neighborhood Weather Station: http://www.elgheko.us
El Gheko Neighborhood Association: http://na.elgheko.us

Image

User avatar
saratogaWX
Posts: 903
Joined: Wed May 06, 2009 5:02 am
Weather Station: Davis Vantage Pro Plus
Operating System: Windows 10 Professional
Location: Saratoga, CA, USA
Contact:

Re: wxforecast.php doesn't work

Post by saratogaWX » Thu Jun 14, 2018 1:49 am

Looking at http://www.elgheko.us/check-fetch-times ... w=versions shows you downlevel on multiple scripts, including advforecast2.php V5.09 which fixes that issue :)

Post Reply