Welcome to the Cumulus Support forum.

Latest Cumulus MX release 3.8.4 (build 3094) - 14 September 2020 (please see announcement regarding releases since 3.5.0)
Legacy Cumulus 1 release v1.9.4 (build 1099) - 28 November 2014 (a patch is available for 1.9.4 build 1099 that extends the date range of the NOAA report and Snow Index drop-down menus to 2030)

Use this Wiki link to Download the Software (Cumulus MX / Cumulus 1 and other related items).

Suggestions for 'devices'?

Discussion of Mark Crossley's HTML5/Javascript gauges

Moderator: mcrossley

TheBridge
Posts: 37
Joined: Mon 16 Mar 2020 3:23 am
Weather Station: Davis
Operating System: Windows 10

Re: Suggestions for 'devices'?

Post by TheBridge »

It kept failing to download the data from the Davis datalogger. The debug logs said it was getting a CR/LF instead of an ACK when trying to such down the data. Nothing I could do to make that work.

TheBridge
Posts: 37
Joined: Mon 16 Mar 2020 3:23 am
Weather Station: Davis
Operating System: Windows 10

Re: Suggestions for 'devices'?

Post by TheBridge »

Hello Water01,

New day and better luck. MX is running. Admin Webpage is good. Website pages are good but not updating steelgauges (which the site viewers really like). Its late here (California) so I have to look up were the magic setting is for that. I also think I read in a post that under MX the steelgauges no longer have the pop-up graph feature. That's a big feature for the viewers. If it does not are there alternative to showing past 12-hours in graph form?

Bridge

TheBridge
Posts: 37
Joined: Mon 16 Mar 2020 3:23 am
Weather Station: Davis
Operating System: Windows 10

Re: Suggestions for 'devices'?

Post by TheBridge »

Final note tonight. I now shut down MX and turned on Cumulus 1 (because it was working flawlessly). Cumulus 1 and MX are in separate directories. BUT now the steelgauges webpage running under Cumulus 1 NOT working updating (although popup charts are). I notice by the timestamps on the web server files the realtimegauges.txt is not getting updated. It was fine until I ran MX. How could have been affected Cumulus 1??

Sorry, too tired to understand the relationship between Cumukus 1 and MX.

https://climate.tommueller.com/gauges-ss-crows.htm

User avatar
mcrossley
Posts: 6932
Joined: Thu 07 Jan 2010 9:44 pm
Weather Station: Davis VP2
Operating System: Buster Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: Suggestions for 'devices'?

Post by mcrossley »

It looks like you have gone back to MX, the gauges are working, but your graphs are out of date?

To get the graphs working with MX, you need an additional package like this - viewtopic.php?f=40&t=13189

TheBridge
Posts: 37
Joined: Mon 16 Mar 2020 3:23 am
Weather Station: Davis
Operating System: Windows 10

Re: Suggestions for 'devices'?

Post by TheBridge »

Hi Mark, thanks. No, the gauges are not working. The popup time-line graphs will appear but only show the graph up to the moment I started MX this morning.

I could have written a book 'programming for dummies'...but I not that smart at this :-)

1. I have the JPGraphs unzipped. Where did I put in the directory on my webserver?
2. To confirm I need to add all the JSON files (for those elements I intend to use) to my FTP upload. What settings (raltime/remote/process) to set in the upload?

THANK YOU, THANK YOU and THANK YOU!
Bridge

TheBridge
Posts: 37
Joined: Mon 16 Mar 2020 3:23 am
Weather Station: Davis
Operating System: Windows 10

Re: Suggestions for 'devices'?

Post by TheBridge »

Mark- Up.
Gauges working! My error. I overlooked setting MX config for uploading to support ss. One prob down, one to go.
Bridge

Post Reply