Welcome to the Cumulus Support forum.

Latest Cumulus MX release v3.4.6 (build 3070) - 23 March 2020
Legacy Cumulus 1 release v1.9.4 (build 1099) - 28 November 2014

See the Wiki for downloading either version.

http to https problem (Resolved)

Discussion of Mark Crossley's HTML5/Javascript gauges

Moderator: mcrossley

Post Reply
itsfine
Posts: 4
Joined: Fri 06 Mar 2020 7:18 pm
Weather Station: Davis
Operating System: windows7

http to https problem (Resolved)

Post by itsfine » Fri 06 Mar 2020 7:30 pm

Hi, I have been using SSG for years without any problems but have now changed to https. I have checked all files and changed to https but cannot get it working. Obviously I am missing something basic but just can't see it. Any help would be appreciated.

The site is www.itsfine.uk and the SSG page is https://itsfine.uk/wx1/steel/web_server/gauges-ss1.php
Data from WD is in folder wx1.

Thanks
Last edited by itsfine on Sun 08 Mar 2020 12:05 pm, edited 1 time in total.

Mapantz
Posts: 676
Joined: Sat 17 Dec 2011 11:55 am
Weather Station: Davis Vantage Pro2
Operating System: Windows 10 x64
Location: Dorset - UK
Contact:

Re: http to https problem

Post by Mapantz » Fri 06 Mar 2020 11:24 pm

http://www.itsfine.uk/wx1/customclientraw.txt

The gauges are reading that URL.
Image

itsfine
Posts: 4
Joined: Fri 06 Mar 2020 7:18 pm
Weather Station: Davis
Operating System: windows7

Re: http to https problem

Post by itsfine » Sat 07 Mar 2020 8:16 am

Thanks Mapantz, they are reading the file but not displaying any info.

Mapantz
Posts: 676
Joined: Sat 17 Dec 2011 11:55 am
Weather Station: Davis Vantage Pro2
Operating System: Windows 10 x64
Location: Dorset - UK
Contact:

Re: http to https problem

Post by Mapantz » Sat 07 Mar 2020 4:47 pm

In gauges.js

Try changing this line:

Code: Select all

realTimeURL_WD     : 'http://www.itsfine.uk/wx1/customclientraw.txt',    //*** WD Users: Change to your location of the ccr file ***
to either:

Code: Select all

realTimeURL_WD     : 'wx1/customclientraw.txt',    //*** WD Users: Change to your location of the ccr file ***
or:

Code: Select all

realTimeURL_WD     : 'customclientraw.txt',    //*** WD Users: Change to your location of the ccr file ***
Image

itsfine
Posts: 4
Joined: Fri 06 Mar 2020 7:18 pm
Weather Station: Davis
Operating System: windows7

Re: http to https problem

Post by itsfine » Sun 08 Mar 2020 8:27 am

Tried both options plus various alternatives using ../ to go back a level and the full url with http and https but still no change.
It's got me beat!

User avatar
mcrossley
Posts: 6172
Joined: Thu 07 Jan 2010 9:44 pm
Weather Station: Davis VP2
Operating System: Stretch Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: http to https problem

Post by mcrossley » Sun 08 Mar 2020 10:11 am

It's definitely your client raw file causing the problem. It is trying to load...
http://www.itsfine.uk/wx1/customclientraw.txt

Which isn't allowed as that is mixed content. Changing it to...
/wx1/customclientraw.txt

fixes it for me. Btw, you also have a statistics counter script giving mixed content errors as well.

itsfine
Posts: 4
Joined: Fri 06 Mar 2020 7:18 pm
Weather Station: Davis
Operating System: windows7

Re: http to https problem

Post by itsfine » Sun 08 Mar 2020 12:02 pm

Thanks Mark. I've struggled with this for ages. Made the changes and removed the counter as well.
Everything is back to normal - hooray!

Post Reply