Welcome to the Cumulus Support forum.

Latest Cumulus MX release v3.0.2 build 3052 - 13 September 2019.
Legacy Cumulus 1 release v1.9.4 (build 1099) - 28 November 2014

See the Wiki for downloading either version.

steelseries not working

Discussion of Mark Crossley's HTML5/Javascript gauges

Moderator: mcrossley

Thunderstorm
Posts: 8
Joined: Tue 26 Mar 2019 8:49 am
Weather Station: Davis Vantage Pro
Operating System: Win10

steelseries not working

Post by Thunderstorm » Tue 26 Mar 2019 10:05 am

Hello, :(
i`m here for the first time. I have many difficults to start the steelseries gauges. The console is working like this:
http://odenwald-wetter.de/cumulus/davconvp2CU.php
The realtime.txt, the index.htm and the gauges.htm file uploading every time in 10 minutes. But i have seen, that the gauges.htm is emty, 0 byts, no information. The realtimegauges.txt are not uploaded, i think, that`s the reason.
Please may be somebody can help me? What did i miss? Thanks, and excuse my bad english.

thunderstorm
You do not have the required permissions to view the files attached to this post.

User avatar
PaulMy
Posts: 1944
Joined: Sun 28 Sep 2008 11:54 pm
Weather Station: Davis Vantage Pro 2+ w/Envoy USB
Operating System: Windows-8
Location: Komoka, ON Canada
Contact:

Re: steelseries not working

Post by PaulMy » Tue 26 Mar 2019 2:51 pm

Hi,
A few things,
Your realtime.txt is updating at 1 min interval and looks like your VP Console files are updating as well.
Your realtimegauges.txt is stale dated and not updating.

Also, this from your ftplog confuses me:
10:00:57:422 Changing directory to odenwaldwetter/cumulus
10:00:57:422 FTP Command: CWD odenwaldwetter/cumulus
being odenwaldwetter rather than odenwald-wetter

In looking at your http://odenwald-wetter.de/cumulus/ the index.htm (now) seems to work and updating http://odenwald-wetter.de/cumulus/index.htm but the other standard Cumulus template pages are not showing or are stale dated, yet your settings show to Include Standard Files.
Do all the standard template files - gaugesT.htm, yesterdayT.htm, and the other xxxxT.htm files exist in your \Cumulus\web folder?

For the gauges-ss is the source file in your \Cumulus\web\realtimegaugesT.txt or realtimegauges.txt as I can't tell from your attachment?

Enjoy,
Paul

Thunderstorm
Posts: 8
Joined: Tue 26 Mar 2019 8:49 am
Weather Station: Davis Vantage Pro
Operating System: Win10

Re: steelseries not working

Post by Thunderstorm » Tue 26 Mar 2019 7:51 pm

Hi Paul,
thanks for answering so quickly. Please check up the internetsettings files which you find in my first post. I`m not shure, if every thing is registered correctly.
Now i have put a attachment from the cumulus/web folder. Please check it too and tell me what is wrong.
Thank you!
thunderstorm
You do not have the required permissions to view the files attached to this post.

User avatar
PaulMy
Posts: 1944
Joined: Sun 28 Sep 2008 11:54 pm
Weather Station: Davis Vantage Pro 2+ w/Envoy USB
Operating System: Windows-8
Location: Komoka, ON Canada
Contact:

Re: steelseries not working

Post by PaulMy » Tue 26 Mar 2019 8:56 pm

The internet settings seem to be okay, other than you don't need to upload gauges-ss.htm after the first time (only needs to be done once at initial upload).
Strange that only index.htm and realtime.txt are being updated from the full template set along with the added davcon24.txt, and the other standard template files and the other added like gauges-ss.htm, realtimegauges.txt is not. I presume the missing standard template files and added realtimegauges.txt and gauges-ss.htm not showing are related.

Can you provide a screen shot of the files in your /cumulus/ folder on your remote site.
Also turn on FTP logging for a full time of a couple of update intervals and attach it.

Enjoy,
Paul

Thunderstorm
Posts: 8
Joined: Tue 26 Mar 2019 8:49 am
Weather Station: Davis Vantage Pro
Operating System: Win10

Re: steelseries not working

Post by Thunderstorm » Wed 27 Mar 2019 11:21 am

Hi Paul,
today i have found an error in line 67 of my gauges.js.
I adjust the realTimeUrlCumulus : 'odenwald-wetter.de/cumulus/realtime.txt', //*** Cumulus Users: Change to your location of the realtime file ***. But this operation take no effect for the gauges.
As requestet in your last post I attache the ftplog.txt, ftpls.txt and realtimeftplog.txt
Also a screen shot from the cumulus/folder. I hope you can find something to help me.
You do not have the required permissions to view the files attached to this post.

User avatar
PaulMy
Posts: 1944
Joined: Sun 28 Sep 2008 11:54 pm
Weather Station: Davis Vantage Pro 2+ w/Envoy USB
Operating System: Windows-8
Location: Komoka, ON Canada
Contact:

Re: steelseries not working

Post by PaulMy » Wed 27 Mar 2019 1:56 pm

Hi,
The other than index.htm and realtime.txt the other standard files are not showing. I expect a path issue in your settings.

The attached realtimeftp.txt has several No such file or directory.
11:36:06:733 >|550 cumulus/davcon24.txt: No such file or directory|
11:36:04:727 >|550 cumulus/davconfcst.php: No such file or directory|
11:36:02:729 >|550 cumulus/gauges-ss.htm: No such file or directory|
11:36:00:733 >|550 cumulus/realtimegauges.txt: No such file or directory|
but 11:35:58:726 >|150 Opening ASCII mode data connection for odenwaldwetter/cumulus/realtime.txt| is okay

The attached ftplog file still has this:
11:30:05:248 Changing directory to odenwaldwetter/cumulus which is not odenwald-wetter/cumulus
and it appears that the standard Cumulus files are also being uploaded, but to where?

I have tried to search if the files are uploaded to another folder but have not found that, that is why I asked for the screen shot of your remote site file structure with file dates and time. Don't know what you are using for manual FTP but with Filezilla you can see the file structure and files with date/time. Have you looked at that and see if you can find the uploaded files.

Enjoy,
Paul

Thunderstorm
Posts: 8
Joined: Tue 26 Mar 2019 8:49 am
Weather Station: Davis Vantage Pro
Operating System: Win10

Re: steelseries not working

Post by Thunderstorm » Wed 27 Mar 2019 5:53 pm

Hi,
I am uploading with Totalcommander, using this path: ftp://u65281065@home381120389.1and1-dat ... r/cumulus/..
Notice my Website named https://odenwald-wetter.de
I have searched for the other standard cumulus files, in all folders. But there these files you can see in the image folder and in the cumulus folder.
You do not have the required permissions to view the files attached to this post.

User avatar
mcrossley
Posts: 5626
Joined: Thu 07 Jan 2010 9:44 pm
Weather Station: Davis VP2
Operating System: Stretch Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: steelseries not working

Post by mcrossley » Wed 27 Mar 2019 6:57 pm

First, I would delete all the *tmp files in your web folder and see which ones get recreated, and if they have the content you expect.

Now use an FTP client to look at your web server. Remove any of the files on your web server that are zero length - they will prevent new copies being uploaded.

Then move on to the FTP. Your screen shot looks OK, but as Paul said the gauges-ssT.htm does not need updating at the realtime interval. AND once it has been transferred once successfully then it can be disabled altogether.

Your comment on gauges.js and changing the realtimegauges.txt location is not correct.

Code: Select all

realTimeUrlCumulus : 'odenwald-wetter.de/cumulus/realtime.txt', //*** Cumulus Users: Change to your location of the realtime file ***
// should be...
realTimeUrlCumulus : 'realtimegauges.txt', //*** Cumulus Users: Change to your location of the realtime file ***

Thunderstorm
Posts: 8
Joined: Tue 26 Mar 2019 8:49 am
Weather Station: Davis Vantage Pro
Operating System: Win10

Re: steelseries not working

Post by Thunderstorm » Wed 27 Mar 2019 8:47 pm

Hi,
I delete all .txttmp files. And after 3 seconds these files already back. Sheet!
Also i changed the gauges.js back. What can i do else? I think it woud be best to reinstall cumulus 1 and the gauges template.
Can you promise me which template is good working by win 10?
You do not have the required permissions to view the files attached to this post.

User avatar
mcrossley
Posts: 5626
Joined: Thu 07 Jan 2010 9:44 pm
Weather Station: Davis VP2
Operating System: Stretch Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: steelseries not working

Post by mcrossley » Wed 27 Mar 2019 9:02 pm

The tmp files coming back is good, and none of them are blank.

Do not reinstall Cumulus that will achieve nothing.

Now look at your FTP configuration. Please post your logs again

Thunderstorm
Posts: 8
Joined: Tue 26 Mar 2019 8:49 am
Weather Station: Davis Vantage Pro
Operating System: Win10

Re: steelseries not working

Post by Thunderstorm » Wed 27 Mar 2019 9:25 pm

Hi,
i enclose the log.txt files again. It seems that nothing else is modified. And now? :cry:
You do not have the required permissions to view the files attached to this post.

User avatar
PaulMy
Posts: 1944
Joined: Sun 28 Sep 2008 11:54 pm
Weather Station: Davis Vantage Pro 2+ w/Envoy USB
Operating System: Windows-8
Location: Komoka, ON Canada
Contact:

Re: steelseries not working

Post by PaulMy » Thu 28 Mar 2019 1:25 am

Hi,
This should be quite simple, but from what I have been looking at it is far, far from my knowledge and understanding. From what I have learned from past experiences:
The attached ftplog.txt covers your normal interval Cumulus standard files FTP. Looking from
line 1911 at 22:10:02 it connects to site, and "/" is the current directory
line 1961 changes directory to odenwaldwetter/cumulus
line 1973 uploading index.htm and this works at http://odenwald-wetter.de/cumulus/ (I don't understand how it got from odenwaldwetter to odenwald-wetter)
line 2004 uploading to today.htm but this does not display
further lines to 2853 uploads all the standard Cumulus files and images such as http://odenwald-wetter.de/cumulus/images/tempsm.png I can't tell if the images are current or from a prior upload. I don't understand what happened to the other template files like today.htm, yesterday.htm, etc.
Line 2866 at 22:15:02 and down repeats the above

The attached realtimeftplog-2,txt covers your realtime uploads including realtime.txt and the other extra files being uploaded at realtime
line 8096 at 22:10:28 opening for odenwaldwetter/cumulus/realtime.txt and this displays at http://odenwald-wetter.de/cumulus/realtime.txt but don't know how it changed from odenwaldwetter to odenwald-wetter
line 8106 transfer complete
line 8109 at 22:10:29 processing cumulus/realtimegauges.txt
line 8122 at 22:10:31 no such file or directory
line 8128 at 22:10:31 and down repeats the above for the other extra uploads

You seem to have many folders and redirects on your site and don't quite understand your website structure.
What is the directory you have entered in Cumulus Site/Options settings?
Mine is public_html/weather and all Cumulus standard files are uploaded to my komokaweather.com/weather folder (public_html is my komokaweather root folder at my webhost - GoDaddy)

From your previous attachment you have your extra web files uploads as cumulus/realtimegauges.txt
I don't know what it should be as mine is public_html/weather/realtimegauges.txt and in your case to find the correct path I would try /cumulus/realtimegauges.txt or odenwaldwetter/cumulus/realtimegauges.txt or odenwald-wetter/cumulus/realtimegauges.txt etc. (trial and error until it works)
then d the same for the other extra web file uploads.

Good luck,
Paul

Thunderstorm
Posts: 8
Joined: Tue 26 Mar 2019 8:49 am
Weather Station: Davis Vantage Pro
Operating System: Win10

Re: steelseries not working

Post by Thunderstorm » Fri 29 Mar 2019 7:55 am

Hello Paul and Marc,
many thanks for your posts. I have read them for many times. Now i have make a big step forward. What have i done?
I only changed the directory. The cumulus folder is no longer in use as a subdirectory. All files will uploaded well.

http://stuermers-marktplatz.de/cumulus/davconvp2CU.php
The ftp.log is out of errors.
But the bad news: the gauges are not working :!: http://stuermers-marktplatz.de/cumulus/ ... -basic.htm
What `s that supposed to mean ?

thunderstorm

water01
Posts: 1549
Joined: Sat 13 Aug 2011 9:33 am
Weather Station: WH1081
Operating System: Windows 7 64bit HP SP1
Location: Somewhere in the USA
Contact:

Re: steelseries not working

Post by water01 » Fri 29 Mar 2019 1:59 pm

A blank page usually means that the code has been unable to find realtimegauges.txt and sure enough if you type in http://stuermers-marktplatz.de/cumulus/ ... gauges.txt the file is not found.

So either you are uploading it to the wrong place, renaming it incorrectly or gauges.js has an incorrect path for realtimegauges.txt.

User avatar
PaulMy
Posts: 1944
Joined: Sun 28 Sep 2008 11:54 pm
Weather Station: Davis Vantage Pro 2+ w/Envoy USB
Operating System: Windows-8
Location: Komoka, ON Canada
Contact:

Re: steelseries not working

Post by PaulMy » Fri 29 Mar 2019 2:20 pm

Both realtime.txt and realtimegauges.txt http://stuermers-marktplatz.de/cumulus/ ... gauges.txt are now updating so that is good.
I presume you have uploaded all the folders and files from the zip as per the readme.

Marc will be best to diagnose the ss-gauges issue.

Enjoy,
Paul

Post Reply