Welcome to the new home of the Cumulus Support forum.

Latest Cumulus release v1.9.4 (build 1099) - Nov 28 2014
Latest Cumulus MX release - v3.0.0 build 3043 Jan 20 2017. See the Wiki for download

Steel series gauges not updating

Discussion of Mark Crossley's HTML5/Javascript gauges

Moderator: mcrossley

bumpy
Posts: 45
Joined: Fri 24 Sep 2010 12:27 pm
Weather Station: Davis Vantage Vue
Operating System: Windows 7
Location: Tiverton, Devon

Steel series gauges not updating

Post by bumpy » Fri 28 Jul 2017 2:30 pm

Hello
I am having problems getting the Steel Series gauges to update: about a week ago my PC suffered a power outage as a result of a thunderstorm. The result of this was that my website would not update and the power problem caused the Internet settings (Sites/option and files) in the Cumulus configuration to be wiped. I re-entered the relevant information and the website resumed normally and continues to update correctly BUT the Steelseries gauges are resolutely 'stuck' at the time of the power cut. I'm no real computer person but I have carefully followed the instructions in the Wiki and in final desperation deleted the Steel Series files from the server and reloaded them from the original SteelSeries download which worked perfectly until the power cut.
When a scheduled a web update or indeed when I force one, the progress box appears to upload correctly.
I am using the following in the Internet settings (Files):C:\Cumulus\realtimegaugesT.txt uploading to /realtimegauges.txt and C:\Cumulus\gauges-ssT.htm uploading to /gauges-ss.htm
Strangely enough the trends page has also disappeared from my website too but about this I am not too concerned at the moment.
I am at a loss and now very frustrated. Any ideas anyone?

http://www.farleighmeadows.co.uk

Tony

User avatar
mcrossley
Posts: 5209
Joined: Thu 07 Jan 2010 9:44 pm
Weather Station: Davis VP2
Operating System: Stretch Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: Steel series gauges not updating

Post by mcrossley » Fri 28 Jul 2017 3:56 pm

It looks like the gauges-ss.htm hasn't updated since 26/07/2017 22:00:56 either.

Can you zip up your diags folder and post it?

bumpy
Posts: 45
Joined: Fri 24 Sep 2010 12:27 pm
Weather Station: Davis Vantage Vue
Operating System: Windows 7
Location: Tiverton, Devon

Re: Steel series gauges not updating

Post by bumpy » Fri 28 Jul 2017 6:03 pm

Hi Mark

Thank you for responding so promptly. Here is the Diags Zip file:-
cumulus.zip
Tony
You do not have the required permissions to view the files attached to this post.

User avatar
mcrossley
Posts: 5209
Joined: Thu 07 Jan 2010 9:44 pm
Weather Station: Davis VP2
Operating System: Stretch Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: Steel series gauges not updating

Post by mcrossley » Sat 29 Jul 2017 3:52 pm

Hmm FTP error 426 - not a lot of help, but things to try...

1. Delete the existing realtimeGauges.txt (and gauges-ss.htm) from your web server and see if Cumulus will upload a new copy.

2. Are you using FTP rename? If so check for the files realtimeGuages.txttmp and gauges-ss.htmtmp on your web server. Delete them if present.

3. If you are using Active mode FTP, change to Passive - or vice versa. If it doesn't work leave it as Passive (unchecked).

4. Use a ftp client to connect to your web server, are you automatically placed in the correct directory to upload the files?

bumpy
Posts: 45
Joined: Fri 24 Sep 2010 12:27 pm
Weather Station: Davis Vantage Vue
Operating System: Windows 7
Location: Tiverton, Devon

Re: Steel series gauges not updating

Post by bumpy » Sun 30 Jul 2017 8:59 am

Hello Mark
Thank you for your advice.
I deleted realtimegauges.txt (don't have a file realtimeGauges.txt - with capital G) and gauges.txt from the server. The file realtimegauges.txt reloaded at the next web update but gauges.txt did not. I subsequently reloaded this file myself. Nothing changed and the gauges remained fixed at the point of the power outage.
Over the last few days I have seen the suffix .tmp on the two files you indicated but had already deleted these and they haven't reappeared.
I have switched from active to passive several times and this made no difference.
I've obviously done something as the gauges are now not showing the out of date data but conversely aren't updating either.
The gauges were working fine prior to the power cut and I haven't changed the directory from when the gauges were working - I assume as the other pages on the website continue to update regularly then there isn't a directory problem.
I have noticed that the file realtime.txt only updates on the server at the point I delete the file from the server and reload it.
I am unsure how to choose or even know how to use an ftp client.
Have you any other thoughts please?
Tony

User avatar
dimitris vichos
Posts: 85
Joined: Fri 21 Oct 2011 5:29 pm
Weather Station: wh 1080
Operating System: linux mint 19
Location: nea moudania chalkidiki grecce
Contact:

Re: Steel series gauges not updating

Post by dimitris vichos » Sun 30 Jul 2017 9:29 pm

your realtimegauges.txt link?
Meteostation of Nea Moudania Chalkidiki Greece
http://metfm.esy.es/index.php

User avatar
mcrossley
Posts: 5209
Joined: Thu 07 Jan 2010 9:44 pm
Weather Station: Davis VP2
Operating System: Stretch Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: Steel series gauges not updating

Post by mcrossley » Mon 31 Jul 2017 12:50 pm

Your realtimegauges.txt is no longer on your server - http://www.farleighmeadows.co.uk/realtimegauges.txt

So Cumulus isn't uploading it at all for some reason.

Your realtime.txt *is* uploading. So it looks like a path issue in your Cumulus configuration.

Can you post screen shots of your settings... Internet|Site/options and Internet|Files please.

bumpy
Posts: 45
Joined: Fri 24 Sep 2010 12:27 pm
Weather Station: Davis Vantage Vue
Operating System: Windows 7
Location: Tiverton, Devon

Re: Steel series gauges not updating

Post by bumpy » Mon 31 Jul 2017 5:48 pm

Hi Mark
Thank you for helping me. Below are the two screenshots you want:-
Screenshot (3).png
Screenshot (2).png
Hope these are OK.
Tony
You do not have the required permissions to view the files attached to this post.

User avatar
dimitris vichos
Posts: 85
Joined: Fri 21 Oct 2011 5:29 pm
Weather Station: wh 1080
Operating System: linux mint 19
Location: nea moudania chalkidiki grecce
Contact:

Re: Steel series gauges not updating

Post by dimitris vichos » Mon 31 Jul 2017 7:30 pm

try to remove the "/" from "/realtimegauges.txt" to "realtimegauges.txt" , in files section on cumulus settings.
Meteostation of Nea Moudania Chalkidiki Greece
http://metfm.esy.es/index.php

User avatar
steve
Cumulus Author
Posts: 26714
Joined: Mon 02 Jun 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: Steel series gauges not updating

Post by steve » Mon 31 Jul 2017 8:52 pm

You need to specify the directory for the remote files, i.e. public_html/realtimegauges.txt and public_html/gauges-ss.htm
Steve

User avatar
mcrossley
Posts: 5209
Joined: Thu 07 Jan 2010 9:44 pm
Weather Station: Davis VP2
Operating System: Stretch Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: Steel series gauges not updating

Post by mcrossley » Mon 31 Jul 2017 9:05 pm

steve wrote:You need to specify the directory for the remote files, i.e. public_html/realtimegauges.txt and public_html/gauges-ss.htm
Wot he said! ;)

User avatar
steve
Cumulus Author
Posts: 26714
Joined: Mon 02 Jun 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: Steel series gauges not updating

Post by steve » Mon 31 Jul 2017 9:25 pm

I just waited until you'd done all the diagnostic work and then stuck my nose in :lol:

bumpy
Posts: 45
Joined: Fri 24 Sep 2010 12:27 pm
Weather Station: Davis Vantage Vue
Operating System: Windows 7
Location: Tiverton, Devon

Re: Steel series gauges not updating

Post by bumpy » Tue 01 Aug 2017 8:32 am

Good morning
Thank you Steve, Mark and Dimitris for your suggestions. The removal of / in the files settings I'd tried before but without success. I added the /public_html prefix but alas this made no difference and the gauges page remains with empty gauges.
Is there anything else I can try?
Tony

User avatar
mcrossley
Posts: 5209
Joined: Thu 07 Jan 2010 9:44 pm
Weather Station: Davis VP2
Operating System: Stretch Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: Steel series gauges not updating

Post by mcrossley » Tue 01 Aug 2017 9:30 am

Not "/public_html/" but "public_html/"

bumpy
Posts: 45
Joined: Fri 24 Sep 2010 12:27 pm
Weather Station: Davis Vantage Vue
Operating System: Windows 7
Location: Tiverton, Devon

Re: Steel series gauges not updating

Post by bumpy » Tue 01 Aug 2017 2:26 pm

Hi Mark
Apologies! In my previous post I meant to type public_html/realtimegauges.txt and public_htm/gauges-ss.htm. Why I added the / prefix I don't know! I confirm that the remote file names are correct without the first / but this has made no difference as the gauges are still not working.
Tony

Post Reply