Welcome to the Cumulus Support forum.

Latest Cumulus MX release v3.0.2 build 3052 - 13 September 2019.
Legacy Cumulus 1 release v1.9.4 (build 1099) - 28 November 2014

See the Wiki for downloading either version.

Problem with High Gust in Beta 1074

Please discuss beta versions of Cumulus 1 here. Note: There are currently no beta versions of Cumulus 1.
Locked
User avatar
krmidas
Posts: 206
Joined: Sat 03 Jul 2010 9:03 pm
Weather Station: Davis Vantage Pro 2
Operating System: Windows 10
Location: Lake Zurich, IL; USA
Contact:

Problem with High Gust in Beta 1074

Post by krmidas » Sun 12 May 2013 12:56 pm

Odd problem since I installed the new beta:

the daily high gust doesn't seem to be resetting on the new day. As you can see on the page from my website, the page last uploaded at 7:45 AM but it's showing YESTERDAY'S reading for today's high gust (at 12:11 PM). I haven't changed any other settings or my website since I installed the new beta.

I've also attached a frame grab from Cumulus.

I use a Davis VP2.

-Tom
You do not have the required permissions to view the files attached to this post.
Tom Keramidas, Lake Zurich, IL, USA
Image

User avatar
steve
Cumulus Author
Posts: 26717
Joined: Mon 02 Jun 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: Problem with High Gust in Beta 1074

Post by steve » Sun 12 May 2013 1:01 pm

This is the same problem that someone else reported earlier today, but by the time I looked at their web site it was OK. If yours is still showing it, please turn on the debug log for a few minutes and then attach the debug.log file here. The new code which gets the high gust from the console logs what it's doing there.
Steve

User avatar
krmidas
Posts: 206
Joined: Sat 03 Jul 2010 9:03 pm
Weather Station: Davis Vantage Pro 2
Operating System: Windows 10
Location: Lake Zurich, IL; USA
Contact:

Re: Problem with High Gust in Beta 1074

Post by krmidas » Sun 12 May 2013 1:13 pm

Not sure how long you needed the debug log running. Attached.
You do not have the required permissions to view the files attached to this post.
Tom Keramidas, Lake Zurich, IL, USA
Image

User avatar
steve
Cumulus Author
Posts: 26717
Joined: Mon 02 Jun 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: Problem with High Gust in Beta 1074

Post by steve » Sun 12 May 2013 1:20 pm

Thanks, Tom. See the post I've just made in the Davis section for an explanation. I'll have a fix out very soon. You can correct it by stopping Cumulus and editing today.ini. Change the gust line to Gust=0 and start Cumulus; it will then pick up today's value and time.
Steve

User avatar
krmidas
Posts: 206
Joined: Sat 03 Jul 2010 9:03 pm
Weather Station: Davis Vantage Pro 2
Operating System: Windows 10
Location: Lake Zurich, IL; USA
Contact:

Re: Problem with High Gust in Beta 1074

Post by krmidas » Sun 12 May 2013 1:37 pm

Thank you, Steve. Much appreciated.

-Tom
Tom Keramidas, Lake Zurich, IL, USA
Image

User avatar
steve
Cumulus Author
Posts: 26717
Joined: Mon 02 Jun 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: Problem with High Gust in Beta 1074

Post by steve » Sun 12 May 2013 1:40 pm

Build 1075 with the fix now available.
Steve

User avatar
steve
Cumulus Author
Posts: 26717
Joined: Mon 02 Jun 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: Problem with High Gust in Beta 1074

Post by steve » Sun 12 May 2013 4:22 pm

The previous fix doesn't appear to work, I think due to the way the Davis DLL works. I've uploaded another attempt, build 1076.
Steve

Locked