Welcome to the Cumulus Support forum.

Latest Cumulus MX release v3.4.0 (build 3064) - 19 February 2020.
    Legacy Cumulus 1 release v1.9.4 (build 1099) - 28 November 2014

    See the Wiki for downloading either version.

    Cumulus hanging

    Please discuss beta versions of Cumulus 1 here. Note: There are currently no beta versions of Cumulus 1.
    Locked
    johndavidson
    Posts: 17
    Joined: Tue 21 Aug 2012 1:35 am
    Weather Station: WMR200
    Operating System: Windows 7
    Location: New Norfolk, Tasmania, Australia
    Contact:

    Cumulus hanging

    Post by johndavidson » Wed 22 Aug 2012 8:55 am

    I've just started using Cumulus with a new OS WMR200. Periodically (approx. 30 minutes, but don't quote me) Cumulus will hang. Shutting down and restarting gets it going again, but the same problem come up again.

    Attached are the debug log and the relevant cumulus diags file.
    You do not have the required permissions to view the files attached to this post.

    User avatar
    steve
    Cumulus Author
    Posts: 26717
    Joined: Mon 02 Jun 2008 6:49 pm
    Weather Station: None
    Operating System: None
    Location: Vienne, France
    Contact:

    Re: Cumulus hanging

    Post by steve » Wed 22 Aug 2012 7:07 pm

    Did it actually 'hang' (i.e. stop responding to mouse clicks etc) or just stop updating?

    If the time at the end of both of those files corresponds to the time when it stopped, then I would have to guess that the station has stopped responding. Cumulus asked for data but apparently got nothing back. But it had received data only a few seconds earlier, so it's a bit puzzling. At what time did it actually stop updating?
    Steve

    johndavidson
    Posts: 17
    Joined: Tue 21 Aug 2012 1:35 am
    Weather Station: WMR200
    Operating System: Windows 7
    Location: New Norfolk, Tasmania, Australia
    Contact:

    Re: Cumulus hanging

    Post by johndavidson » Wed 22 Aug 2012 10:34 pm

    steve wrote:Did it actually 'hang' (i.e. stop responding to mouse clicks etc) or just stop updating?
    It actually hung. It stopped responding to the mouse and the realtime clock displayed on the app stopped updating. The only way to close it was to kill it though task manager.
    steve wrote:If the time at the end of both of those files corresponds to the time when it stopped, ...
    It did. The frozen realtime clock on Cumulus indicated the same time as the logs.

    A bit of additional info:

    The rain gauge is connected to the station, but not deployed, so the rain figures should be zero for the moment.
    The OS is Windows 7 64bit.

    I intend to repeat the process and include screen caps when I'm back in front of the PC.

    User avatar
    steve
    Cumulus Author
    Posts: 26717
    Joined: Mon 02 Jun 2008 6:49 pm
    Weather Station: None
    Operating System: None
    Location: Vienne, France
    Contact:

    Re: Cumulus hanging

    Post by steve » Thu 23 Aug 2012 7:18 am

    In that case, I'm afraid I have no idea why it hangs, sorry. It's unlikely to be anything to do with the weather station, it's more likely that one of the actions that it performs periodically didn't complete/timeout/give an error, so it locked up.
    Steve

    johndavidson
    Posts: 17
    Joined: Tue 21 Aug 2012 1:35 am
    Weather Station: WMR200
    Operating System: Windows 7
    Location: New Norfolk, Tasmania, Australia
    Contact:

    Re: Cumulus hanging

    Post by johndavidson » Thu 23 Aug 2012 11:22 am

    I've had some time to sit at the PC, so here is what I have found:

    Running beta v1.9.3 build 1044:

    The application will hang after approx. 30 minutes or less. Needs to be killed with task manager.

    I plugged the station into another USB port. No apparent difference. The application still hung.

    I reset the station. The application still hung as before.

    I have now installed the latest stable version (v1.9.2 build 1032) and the application has now run for 3+ hours with no problems.

    I'm going to let this run overnight, and then uninstall it and re-install the beta version. The reason I want the beta is for the extra sensors. I'll be interested in seeing how the reinstalled beta performs.

    Despite all this, I must say that I am impressed with the software. I will certainly be making a donation.

    User avatar
    steve
    Cumulus Author
    Posts: 26717
    Joined: Mon 02 Jun 2008 6:49 pm
    Weather Station: None
    Operating System: None
    Location: Vienne, France
    Contact:

    Re: Cumulus hanging

    Post by steve » Thu 23 Aug 2012 11:57 am

    My development machine is Windows 7 x64, and I have a WMR200 connected to that. I don't tend to run for half an hour at a time, though, but I'm sure there are others running the beta version who don't have the same problem. I'll try leaving mine running for a while and see what happens.
    Steve

    johndavidson
    Posts: 17
    Joined: Tue 21 Aug 2012 1:35 am
    Weather Station: WMR200
    Operating System: Windows 7
    Location: New Norfolk, Tasmania, Australia
    Contact:

    Re: Cumulus hanging

    Post by johndavidson » Mon 27 Aug 2012 5:06 am

    I think I've isolated the problem to the WMR200 not liking the USB3 ports on my desktop PC.

    I tried some other rival programs, and they all behaved the same way - locking up after about 30-60 mins.

    Installed Cumulus on a laptop with USB2 only ports, and it has run perfectly for 2+ days.

    Locked