Welcome to the Cumulus Support forum.

Latest Cumulus MX release 3.16.1 (build 3183) - 06 May 2022

Legacy Cumulus 1 release v1.9.4 (build 1099) - 28 November 2014 (a patch is available for 1.9.4 build 1099 that extends the date range of drop-down menus to 2030)

Download the Software (Cumulus MX / Cumulus 1 and other related items) from the Wiki

If you are interested in supporting Cumulus then maybe you would like to contribute to the maintenance of the Wiki? This need not take hours of your time - just a half hour here and there can make a big difference, particularly if many people are doing this. Any contributions are very welcome, whether they involve new content or editing of existing content. It will be very helpful to current and future users of Cumulus software if the Wiki is kept well-maintained and current. If you are interested then please contact forum user saratogaWX and ask for a Wiki account.

Bug report 1.9.4.1084

Please discuss beta versions of Cumulus 1 here. Note: There are currently no beta versions of Cumulus 1.
Locked
dapym
Posts: 2
Joined: Sun 19 Aug 2012 9:42 pm
Weather Station: Sinometer WS1081
Operating System: XP SP3
Location: Ciudad Autónoma de Buenos Aires, Argentina
Contact:

Bug report 1.9.4.1084

Post by dapym »

Hi.
I`ve installed this version of Cumulus and everytime I try to start the program it`s crash. Please, ask me if you need another procedure.
Regards
You do not have the required permissions to view the files attached to this post.
User avatar
steve
Cumulus Author
Posts: 26702
Joined: Mon 02 Jun 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: Bug report 1.9.4.1084

Post by steve »

You've changed your Windows format settings. Previously you had a comma for a decimal separator, and now you have a period (full stop). So Windows can't convert your old decimal values like 163,0 into a number, and Cumulus, not handling this, crashes. You need to change your Windows settings back to what they were; I think a comma is correct for your country anyway. Make sure your list separators are also correct; with a decimal comma you probably use a semicolon ";" for a list separator.
Steve
dapym
Posts: 2
Joined: Sun 19 Aug 2012 9:42 pm
Weather Station: Sinometer WS1081
Operating System: XP SP3
Location: Ciudad Autónoma de Buenos Aires, Argentina
Contact:

Re: Bug report 1.9.4.1084

Post by dapym »

Hi Steve.
That´s right. I´ve changed the windows format settings. The problem I´ve have is that cumulus takes comma (,) as a list separator so the decimals numbers, in cumulus are the next field in the dayfile.txt, so I have 20 fields more. How can I resolve this problem?
Regards
You do not have the required permissions to view the files attached to this post.
User avatar
steve
Cumulus Author
Posts: 26702
Joined: Mon 02 Jun 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: Bug report 1.9.4.1084

Post by steve »

Cumulus uses the current Windows settings for decimals and list separator. If you have existing data with decimal commas and semicolon separators, Cumulus and Windows can't make sense of that if the current Windows settings aren't the same. If you want to use your existing data, you will need to make your Windows settings match your data. Or edit all of the files and change the data to match your current settings, if you want to keep your current settings.
Steve
Locked